Microphone not recognized. ALC255 on Nitro Aspire V Nitro


#1

Hello everybody!

Unfortunately, I do not get a microphone to run. Neither the microphone, which is installed in the laptop, nor the microphone, which I connect via the combo audio socket work. Sound output works wonderfully.
I will not see the settings microphones.

My laptop is an Acer VN7-572G-54YG. Everything worked fine under Windows.

Would be glad if you can help me to get the microphone up and running


Weird behavior in pulse/alsa when plugging in headphones
#2

please post ALSA information arecord -l
and Pulseaudio information pactl list sources


#3

Hi,
this is the result. does it help?

[]$ arecord -l
**** Liste der Hardware-Geräte (CAPTURE) ****
Karte 0: PCH [HDA Intel PCH], Gerät 0: ALC255 Analog [ALC255 Analog]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 2: ALC255 Alt Analog [ALC255 Alt Analog]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0


[]$ pactl list sources
Quelle #0
Status: SUSPENDED
Name: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
Beschreibung: Monitor of Internes Audio Analog Stereo
Treiber: module-alsa-card.c
Abtastwert-Angabe: s16le 2ch 44100Hz
Kanalzuordnung: front-left,front-right
Besitzer-Modul: 6
Stumm: nein
Lautstärke: front-left: 65536 / 100% / 0,00 dB, front-right: 65536 / 100% / 0,00 dB
Verteilung 0,00
Basis-Lautstärke: 65536 / 100% / 0,00 dB
Ziel-Monitor: alsa_output.pci-0000_00_1f.3.analog-stereo
Latenz: 0 usec, eingestellt 0 usec
Flags: DECIBEL_VOLUME LATENCY
Eigenschaften:
device.description = “Monitor of Internes Audio Analog Stereo”
device.class = “monitor”
alsa.card = “0”
alsa.card_name = “HDA Intel PCH”
alsa.long_card_name = “HDA Intel PCH at 0xa4520000 irq 128”
alsa.driver_name = “snd_hda_intel”
device.bus_path = “pci-0000:00:1f.3”
sysfs.path = “/devices/pci0000:00/0000:00:1f.3/sound/card0”
device.bus = “pci”
device.vendor.id = “8086”
device.vendor.name = “Intel Corporation”
device.product.id = “9d70”
device.product.name = “Sunrise Point-LP HD Audio”
device.form_factor = “internal”
device.string = “0”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-pci”
Formate:
pcm

Quelle #1
Status: SUSPENDED
Name: alsa_input.pci-0000_00_1f.3.analog-stereo
Beschreibung: Internes Audio Analog Stereo
Treiber: module-alsa-card.c
Abtastwert-Angabe: s16le 2ch 44100Hz
Kanalzuordnung: front-left,front-right
Besitzer-Modul: 6
Stumm: nein
Lautstärke: front-left: 65536 / 100% / 0,00 dB, front-right: 65536 / 100% / 0,00 dB
Verteilung 0,00
Basis-Lautstärke: 65536 / 100% / 0,00 dB
Ziel-Monitor: k. A.
Latenz: 0 usec, eingestellt 0 usec
Flags: HARDWARE DECIBEL_VOLUME LATENCY
Eigenschaften:
alsa.resolution_bits = “16”
device.api = “alsa”
device.class = “sound”
alsa.class = “generic”
alsa.subclass = “generic-mix”
alsa.name = “ALC255 Analog”
alsa.id = “ALC255 Analog”
alsa.subdevice = “0”
alsa.subdevice_name = “subdevice #0
alsa.device = “0”
alsa.card = “0”
alsa.card_name = “HDA Intel PCH”
alsa.long_card_name = “HDA Intel PCH at 0xa4520000 irq 128”
alsa.driver_name = “snd_hda_intel”
device.bus_path = “pci-0000:00:1f.3”
sysfs.path = “/devices/pci0000:00/0000:00:1f.3/sound/card0”
device.bus = “pci”
device.vendor.id = “8086”
device.vendor.name = “Intel Corporation”
device.product.id = “9d70”
device.product.name = “Sunrise Point-LP HD Audio”
device.form_factor = “internal”
device.string = “front:0”
device.buffering.buffer_size = “352800”
device.buffering.fragment_size = “176400”
device.access_mode = “mmap+timer”
device.profile.name = “analog-stereo”
device.profile.description = “Analog Stereo”
device.description = “Internes Audio Analog Stereo”
alsa.mixer_name = “Realtek ALC255”
alsa.components = “HDA:10ec0255,10251037,00100002 HDA:80862809,80860101,00100000”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-pci”
Ports:
analog-input: Analoger Eingang (priority: 10000)
Aktiver Port: analog-input
Formate:
pcm


#4

look at ALSA settings in alsamixer --card 0 --view Capture
you should be able to see controls for levels of internal mic and external mic jack
make sure only level for mic jack is turned up and set to ‘Capture’
and turn down level or turn off caprure for internal mic

If you can’t make sense of alsamixer, post text equivalent output from amixer --card 0

For audio codecs on some types of hardware there are codec model-specific fixes

it looks from the list that you may want to use options snd_hda_intel model=alc255-acer

this would usually be loaded from a file /etc/modprobe.d/alsa-base.conf
(file can have any name and will work as long as it has ‘.conf’ ending)

echo 'options snd_hda_intel model=alc255-acer' | sudo tee --append /etc/modprobe.d/alsa-base.conf > /dev/null


#5

The ALSA Mixer does not display any capture source.


This device has no capture adjustment.

here is the text equivalent:
amixer --card 0
Simple mixer control ‘Master’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 43 [49%] [-33.00dB] [on]
Simple mixer control ‘Headphone’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 0 [0%] [-65.25dB] [off]
Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control ‘Speaker’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 87 [100%] [0.00dB] [on]
Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control ‘PCM’,0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 254 [100%] [-0.20dB]
Front Right: Playback 254 [100%] [-0.20dB]
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘IEC958’,1
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘IEC958’,2
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘IEC958’,3
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘IEC958’,4
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘Beep’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 0 [0%] [-34.50dB] [off]
Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control ‘Auto-Mute Mode’,0
Capabilities: enum
Items: ‘Disabled’ ‘Enabled’
Item0: ‘Enabled’
Simple mixer control ‘Loopback Mixing’,0
Capabilities: enum
Items: ‘Disabled’ ‘Enabled’
Item0: ‘Disabled’

Then i was running the suggested code in Terminal.
after that a file has been created with the already mentioned content. The ALSA interface changed to this:

Although i can set it now to 100% I still don’t have any microphone input. Testing with Audacity :confused:


#6

try replacing codec quirk

open file /etc/modprobe.d/alsa-base.conf

replace previously added text with options aspire-headset-mic

if that doesn’t help, possibly try others on list:
options laptop-amic
or
options headset-mic

one of these may show working analog audio controls for jack socket in alsamixer/amixer


#7

options aspire-headset-mic in file /etc/modprobe.d/alsa-base.conf worked for my headset. It’s being recognised when plugged in :slight_smile: that’s great and big thanks already! I can finally do calls from my laptop.

Just my internal Microphone does not work yet. Do you have any idea, how to solve that?


#8

thank you so much for confirming this

I have posted adding model option on here before and in other places, but never got response whether it was successful or not