Microphone is not working

Hi,
I have a creative sound blaster 5.1vx (supports 5.1 speakers) sound card in which i have 2.1 speakers and a microphone plugged the speakers are working but not the microphone.
I tried alsa mixer selected every source and in pavucontrol i selected microphone, line/input, input/input none of them worked.

please use alsa-info.sh and post the link to ALSA information here

Sorry for replying late.Here you go
http://alsa-project.org/db/?f=098e1bb2747bea6b4a9d795c1c56662f65b696ce

I didn't expect to see much about Creative card compared to the onboard device
but there is very showing for audio capture than would be expected

the section '!!Amixer output' is text-equivalent of alsamixer
only showing one thing related to audio capture

!!-------Mixer controls for card 2 [CA0106]

Simple mixer control 'Analog Source',0
Capabilities: cenum
Items: 'Phone' 'Mic' 'Line in' 'Aux'
Item0: 'Line in'

no sign of level controls like your onboard device

check if you have alsa-firmware installed
package should be there if card was in system when manjaro installed
but may not be installed if card was added after install
reboot/restart system and see if there are any changes in ALSA capture controls

noticed you have kernel v4.19
may help to add another later kernel like v5.2
other users with creative cards had reported some fixes appear to have been added to recent kernels,
but can't find any previous discussions on here for same model no card

It was already installed before i switched to manjaro from windows.

Okay i have installed kernel 5.2.8-1. Now how do i know if its working and setup correctly, Sorry i am still a noob. ):
Here is the output of alsa-info
http://alsa-project.org/db/?f=183a52a4c1ccc677a45ca969f22399df37efae02

Is this configuration alright ?. https://imgur.com/C3HJaoo.png
by default i have selected analog stereo duplex

This worked for me, but no guarentees:

cd ~/.config
mv pulse pulse-old
reboot

I found it on the Antergos forum. You can always move the pulse-old back if it doesn't work.

Thanks ill try doing that and see if it works.
Nope it didnt work

OK, worth a try :frowning:

alsa-firmware is not firmware binary code for a device that may have updated in windows
If card was added to system before installing Manjaro, this linux package should have been installed to get the correct driver for creative card, but may have been missed if card was not detected correctly during install
If card was added after manjaro install, user would usually need to install alsa-firmware

Please post response to pacman -Qi alsa-tools | grep Install

changing kernel does not appear to have made any difference for this creative card,
ALSA information still not showing expected capture controls

Pulseaudio screenshot appears to show menu for selecting profile for Onboard Audio and not
Creative Card

Onboard ALC887-VD appears to have all the correct capture controls in ALSA
so could change Creative Card profile from 'Duplex' to 'Playback'
and set Onboard audio to 'Capture'
and plug microphone in to jack for that device instead

Really sorry for replying late.

When i tried installing alsa-firmware first time it asked me to reinstall or not so i just went ahead and reinstalled it.


pacman -Qi alsa-tools | grep Install
Installed Size  : 1475.00 KiB
Install Date    : Sun 01 Sep 2019 12:03:05 AM IST
Install Reason  : Explicitly installed
Install Script  : No

Sorry but can you rephrase this i dont understand which menu are you talking in pulseaudio control. I know this really noob for me to ask but can you give me a step by step instuction on how to make the microphone work on the onboard port. Lets hope those onboard ports work on linux cause it never did on windows.

pavucontrol -t 5 - Configuration tab

set device shown as 'On-board Audio' for microphone capture

set Creative device for playback only

okay which one should i select under built in audio Analog input right.
and on the creative card i selected stereo output but there are many which one should i select.

CA0106 - Analog Surround 5.1 Output

use alsamixer -c 2 if need to adjust ALSA playback levels/settings

(assuming you want 5.1 surround)

Built-In Audio - Analog Stereo Input

alsamixer -c 0 --view capture to adjust ALSA capture levels/settings for microphone

microphone connected to pink mic-in socket for onboard audio

okay i set everything as you said but it only shows some static if i tap the mic nothing happens.
I reset the config file when i first tried to do it and now in alsamixer if i select my sound card and close alsamixer its back to pulseaudio

Screenshot%20from%202019-09-03%2011-36-15 Screenshot%20from%202019-09-03%2011-37-23

Edit: When i select output profile to 5.1 or 2.1 surround sound the sound stops working when i click test sound and click the speakers my sound card goes away and i am only left with hdmi/display port 2 GP104 High Definition Audio Controller and Headphones built-in Audio, This has happened to me many times thats why i reset pulseaudio config and reboot.

Capture Settings for 'Capture' and 'Input Source' look ok

but 'Input Source 1' should be set to something else instead of 'Rear Mic'
any of 3 other options would be ok - 'Front Mic' 'Line' 'CD'

this is in KDE settings?

does the creative card disappear from alsamixer as well as pavucontrol ?

How can i do this lol i am more a gui person i dont get alsamixer at all sorry ): .

nope i use cinnamon its in sound settings.

Only from pavucontrol in alsamixer the card shows up.

left/right arrow keys to highlight 'Input Source 1' control

up/down arrow keys to change it to anything not 'Rear Mic' used on other source

alsamixer is enough for most people because once settings are correct in ALSA they usually do not change.

there are other mixers with better GUI
gnome-alsamixer may not be good choice for KDE
qastools includes QasMixer that might be better for your needs

not found any other information on this Creative card yet
will keep digging and post more on that later

okay, Thank you
So should i leave my output config to analog duplex since my sound goes away if i change it to something else, and change the Input source 1 to anything besides rear mic ?.

Thanks again i really appreciate your help <3

issue may be similar problem to another recent post for different Creative audio cards
alsa-lib-pulseaudio-problem-on-creative-audigy-4

suggest downgrade ALSA to v1.1.8 :

I dont have it in my cache so how do i downgrade ?
Edit: I managed to downgrade alsa-plugin and alsa-lib and alsa-utils to 1.1.8-1 using downgrader got it from the aur repo. but it still not working.

Screenshot%20from%202019-09-11%2015-08-11 Screenshot%20from%202019-09-11%2015-09-17

Forum kindly sponsored by Bytemark