Microphone internal not working. Only noise

Hi guys.
I’m running manjaro on mac-mini and on external ssd.
Manjaro that’s fine but I have a problem with the microphone.

I tried to touch pulse audio, alsa mixer but the only thing I hear when I record with the microphone is a background noise, like a rustle

I’ve tried using both the internal microphone and the webcam microphone, but none of them work. I’ll post all the specifics and I hope you can help me.
Thank you!

pacmd list-cards
        1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1b.0>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xa0900000 irq 50"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "1c20"
		device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller (Apple MacBookPro8,2 [Core i7, 15\", 2011])"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Audio interno"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Ingresso «Stereo analogico» (priority 65, available: unknown)
		input:iec958-stereo: Ingresso «Stereo digitale (IEC958)» (priority 55, available: unknown)
		output:analog-stereo: Uscita «Stereo analogico» (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Duplex stereo analogico (priority 6565, available: unknown)
		output:analog-stereo+input:iec958-stereo: Uscita «Stereo analogico» + Ingresso «Stereo digitale (IEC958)» (priority 6555, available: unknown)
		output:iec958-stereo: Uscita «Stereo digitale (IEC958)» (priority 5500, available: unknown)
		output:iec958-stereo+input:analog-stereo: Uscita «Stereo digitale (IEC958)» + Ingresso «Stereo analogico» (priority 5565, available: unknown)
		output:iec958-stereo+input:iec958-stereo: Duplex stereo digitale (IEC958) (priority 5555, available: unknown)
		output:hdmi-stereo: Uscita «Digital Stereo (HDMI)» (priority 5900, available: no)
		output:hdmi-stereo+input:analog-stereo: Uscita «Digital Stereo (HDMI)» + Ingresso «Stereo analogico» (priority 5965, available: no)
		output:hdmi-stereo+input:iec958-stereo: Uscita «Digital Stereo (HDMI)» + Ingresso «Stereo digitale (IEC958)» (priority 5955, available: no)
		output:hdmi-surround: Uscita «Digital Surround 5.1 (HDMI)» (priority 800, available: no)
		output:hdmi-surround+input:analog-stereo: Uscita «Digital Surround 5.1 (HDMI)» + Ingresso «Stereo analogico» (priority 865, available: no)
		output:hdmi-surround+input:iec958-stereo: Uscita «Digital Surround 5.1 (HDMI)» + Ingresso «Stereo digitale (IEC958)» (priority 855, available: no)
		output:hdmi-surround71: Uscita «Digital Surround 7.1 (HDMI)» (priority 800, available: no)
		output:hdmi-surround71+input:analog-stereo: Uscita «Digital Surround 7.1 (HDMI)» + Ingresso «Stereo analogico» (priority 865, available: no)
		output:hdmi-surround71+input:iec958-stereo: Uscita «Digital Surround 7.1 (HDMI)» + Ingresso «Stereo digitale (IEC958)» (priority 855, available: no)
		output:hdmi-stereo-extra1: Uscita «Digital Stereo (HDMI 2)» (priority 5700, available: no)
		output:hdmi-stereo-extra1+input:analog-stereo: Uscita «Digital Stereo (HDMI 2)» + Ingresso «Stereo analogico» (priority 5765, available: no)
		output:hdmi-stereo-extra1+input:iec958-stereo: Uscita «Digital Stereo (HDMI 2)» + Ingresso «Stereo digitale (IEC958)» (priority 5755, available: no)
		output:hdmi-surround-extra1: Uscita «Digital Surround 5.1 (HDMI 2)» (priority 600, available: no)
		output:hdmi-surround-extra1+input:analog-stereo: Uscita «Digital Surround 5.1 (HDMI 2)» + Ingresso «Stereo analogico» (priority 665, available: no)
		output:hdmi-surround-extra1+input:iec958-stereo: Uscita «Digital Surround 5.1 (HDMI 2)» + Ingresso «Stereo digitale (IEC958)» (priority 655, available: no)
		output:hdmi-surround71-extra1: Uscita «Digital Surround 7.1 (HDMI 2)» (priority 600, available: no)
		output:hdmi-surround71-extra1+input:analog-stereo: Uscita «Digital Surround 7.1 (HDMI 2)» + Ingresso «Stereo analogico» (priority 665, available: no)
		output:hdmi-surround71-extra1+input:iec958-stereo: Uscita «Digital Surround 7.1 (HDMI 2)» + Ingresso «Stereo digitale (IEC958)» (priority 655, available: no)
		output:hdmi-stereo-extra2: Uscita «Digital Stereo (HDMI 3)» (priority 5700, available: unknown)
		output:hdmi-stereo-extra2+input:analog-stereo: Uscita «Digital Stereo (HDMI 3)» + Ingresso «Stereo analogico» (priority 5765, available: unknown)
		output:hdmi-stereo-extra2+input:iec958-stereo: Uscita «Digital Stereo (HDMI 3)» + Ingresso «Stereo digitale (IEC958)» (priority 5755, available: unknown)
		off: Spento (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Audio interno Stereo analogico
	sources:
		alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Audio interno Stereo analogico
		alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Audio interno Stereo analogico
	ports:
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: yes)
			properties:
				
		iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
	iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
		properties:
			
	hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
		properties:
			device.icon_name = "video-display"
	hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
		properties:
			device.icon_name = "video-display"
	hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: yes)
		properties:
			device.icon_name = "video-display"
			device.product.name = "MSI G24C4"

[    6.839528] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[    7.107096] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops      
[     7.235197] snd_hda_codec_cirrus hdaudioC0D0: autoconfig for CS4206: line_outs=1 (0xb/0x0 /0x0/0x0/0x0) type:speaker
[    7.235208] snd_hda_codec_cirrus hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    7.235212] snd_hda_codec_cirrus hdaudioC0D0:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
[    7.235216] snd_hda_codec_cirrus hdaudioC0D0:    mono: mono_out=0x0
[    7.235219] snd_hda_codec_cirrus hdaudioC0D0:    dig-out=0x10/0x0
[    7.235222] snd_hda_codec_cirrus hdaudioC0D0:    inputs:
[    7.235225] snd_hda_codec_cirrus hdaudioC0D0:      Line=0xc
[    7.235228] snd_hda_codec_cirrus hdaudioC0D0:    dig-in=0xf

System:
  Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: ro root=UUID=b0c999f2-ca5a-4338-859b-26b3781c7c06 
  initrd=boot\initramfs-5.12-x86_64.img 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Apple product: Macmini5,3 v: 1.0 serial: <filter> 
  Chassis: type: 16 v: Mac-7BA5B2794B2CDB12 serial: <filter> 
  Mobo: Apple model: Mac-7BA5B2794B2CDB12 v: Macmini5,3 serial: <filter> 
  UEFI: Apple v: 135.0.0.0.0 date: 06/13/2019 
CPU:
  Info: Quad Core model: Intel Core i7-2635QM bits: 64 type: MT MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  cache: L2: 6 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31940 
  Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 
  4: 798 5: 798 6: 965 7: 888 8: 1044 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Apple driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0116 
  class-ID: 0300 
  Device-2: Chicony TOSHIBA Web Camera - FHD type: USB driver: uvcvideo 
  bus-ID: 2-1.3.3:6 chip-ID: 04f2:b470 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI3 res: 1920x1080 hz: 60 dpi: 94 size: 520x290mm (20.5x11.4") 
  diag: 595mm (23.4") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) 
  v: 3.3 Mesa 21.0.3 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
Network:
  Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3 
  v: kernel port: efa0 bus-ID: 02:00.0 chip-ID: 14e4:16b4 class-ID: 0200 
  IF: enp2s0f0 state: down mac: <filter> 
  Device-2: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge v: N/A 
  modules: bcma port: efa0 bus-ID: 03:00.0 chip-ID: 14e4:4331 class-ID: 0280 
  IF-ID-1: wlp3s0b1 state: up mac: <filter> 
Bluetooth:
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8 
  bus-ID: 1-1.1.3:7 chip-ID: 05ac:8281 class-ID: fe01 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
Drives:
  Local Storage: total: 1.36 TiB used: 7.05 GiB (0.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9500420ASG 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: APM1 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST9500420ASG 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: APM1 scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: SSD PLUS 500GB 
  size: 465.77 GiB block-size: physical: 4096 B logical: 512 B rotation: SSD 
  serial: <filter> rev: 3005 scheme: MBR 
Partition:
  ID-1: / raw-size: 457.5 GiB size: 449.24 GiB (98.19%) used: 7.05 GiB (1.6%) 
  fs: ext4 dev: /dev/sdc1 maj-min: 8:33 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.26 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdc2 maj-min: 8:34 
Sensors:
  System Temperatures: cpu: 69.0 C mobo: 50.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 245 Uptime: 32m wakeups: 1 Memory: 3.75 GiB 
  used: 1.99 GiB (53.1%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 1071 lib: 298 flatpak: 0 Shell: Bash v: 5.1.4 
  running-in: xfce4-terminal inxi: 3.3.04 

pacmd dump
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-remap-source source_name=record_mono master=alsa_input.pci-0000_00_1b.0.analog-stereo master_channel_map=front-left channel_map=mono
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 0x9999
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1b.0.analog-stereo yes

set-source-volume alsa_output.pci-0000_00_1b.0.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1b.0.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1b.0.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_00_1b.0.analog-stereo 0x16485
set-source-mute alsa_input.pci-0000_00_1b.0.analog-stereo no
suspend-source alsa_input.pci-0000_00_1b.0.analog-stereo yes
set-source-volume record_mono 0x10000
set-source-mute record_mono no
suspend-source record_mono yes

set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo
set-default-source record_mono

There is no webcam audio device showing in data, and system does not appear to have an internal microphone

Data in dmesg shows the audio codec (Cirrus CS4206) has only a Line input and digital input

[    7.235225] snd_hda_codec_cirrus hdaudioC0D0:      Line=0xc
[    7.235228] snd_hda_codec_cirrus hdaudioC0D0:    dig-in=0xf

Hardware scans for other Macmini 5,3 systems show similar dmesg data
Apple Macmini 5,3 | linux-hardware.org