Microphone hissing noise with both Apple Earpods and laptop built-in microphone

For a few weeks now, I’ve noticed that when I record my voice with a program like “arecord” or GNOME Sound Recorder, there’s a loud hissing noise that drowns out my voice. I was first made aware of it when speaking with others over the internet with programs like Microsoft Teams and Google Meet.

I’ve been using NoiseTorch to eliminate the hissing, with success, but it makes my voice sound very… “robotic”, or degraded, which I suppose is because the hissing is interfering somehow. I’d like to improve this situation somehow.

I’ve tried the following answer on this forum: Distortions and hissing sound while using microphone

I’ve also tried all the subsections of this section of the Arch Linux PulseAudio help page: PulseAudio/Troubleshooting - ArchWiki

But none of these have eliminated the hissing noise.

Any pointers as to how I can diagnose this further?

Hi there. One simple suggestion comes to mind, but you might have tried it already. If your box has two sets of ports (front & back) for mic and headphones, you might want to try them both. Maybe you’re using a laptop, in which case you will probably only have one. It’s an obvious suggestion but I’m posting it just in case. I hope you get it sorted soon. Ruziel

Hi @ruziel. Indeed it’s a laptop, and it only has one headphone port. Good question, though.

I’m wondering if it might be a hardware issue rather than a software or settings issue. Have you tried a different mic/headset to see if you get better results? Hopefully you find a solution soon. All the best with it. R.

Hi @ruziel - I’ve tried with another pair of Apple Earpods that I own, as well as the built-in microphone of the laptop, and I still have the same hissing noise problem. So it might very well be a hardware problem, but maybe it’s with the audio card, the headphone jack, or another laptop-internal component?

That being said, it’s more prominent with the Apple Earpods. With the built-in microphone, the hissing is less loud and tolerable.

Thanks for the suggestion, though.

It is most likely a problem with my laptop, rather than the earphones, because my Apple Earpods work on my work MacBook without any hissing problems.

Okay, understood. It’s an outside chance but I found one or two strings in other distro chat boards that suggested looking at the kernel & trying a different one. What kernel are you currently using? It might be a long shot but installing a different kernel might help - I always have at least 2 installed, just in case. I hope you find a solution soon. Go well, Ruziel…

I’m currently using 5.10.70-1-MANJARO, an LTS release.

I had 5.4.150-1-MANJARO LTS installed as well, which I tried switching to, but it caused the UEFI splash screen to get stuck; it wouldn’t get through to my desktop environment’s login screen, even after a few minutes.

I then installed and tried 4.19.208-1-MANJARO LTS, but with the same result.

I do have a workaround, though: I can plug my Apple Earpods into my phone anytime I need to speak with someone over the internet. But this assumes I’m using a program that allows me to log in from both my laptop (for video) and my phone (for audio) at the same time. It works with Google Meet, but I’ve not tried other things like Microsoft Teams or Zoom yet.

I’m now considering two options:

  1. Take a risk and try out a non-LTS kernel.
  2. Do a full-disk backup of my laptop and try another rolling distro like openSUSE Tumbleweed, to see if it’s a problem with my Manjaro setup or not.

Thanks for all your help so far, @ruziel!

I had a video suggested by youtube earlier this week that shows a number of ways to resolve hardware noise issues in audio recording
6 simple and cheap ways to fix hum, buzz and ground loop noise - YouTube

Since this is a laptop system I would suggest you test if noise is present in audio recording when system is running on battery power without mains power charger plugged in

@nikgnomic Thanks for the suggestions!

I’ve just tried unplugging my laptop from the mains and re-recording my voice, but the same hissing noise is still present. I’ve even tried unplugging all my peripherals (except my Apple Earpods) and re-recording my voice, and I even tried plugging my laptop back into the mains and re-playing the recordings, but in all these scenarios they have the same level of hissing as before.

I already have everything plugged into the same outlet, as your video describes.

Therefore, I don’t think that the noise is coming from any of my cables, except perhaps the Apple Earpods themselves.

Given how persistent the issue is, I’m going to look into backing up my disk and then trying a non-LTS kernel and/or trying openSUSE Tumbleweed or even a non-rolling distro like Fedora or Ubuntu. I’ll report back when I can procure an external hard drive and find the time to look into this further. :slight_smile:

@nikgnomic Your video also suggests using Audacity to filter out the noise, but AFAICT it only works on recordings, not real-time audio.

Being able to fix real-time audio is important to me so that I can use Google Meet, Zoom and Microsoft Teams through my laptop with whoever I’m speaking to, without them suffering from the loud hissing from my microphone.

I hope you find a solution rather than uninstalling Manjaro, but see how you go. More power to you going forward meantime. Ruziel :slight_smile:

Based on the limited information posted so far I cannot determine the source of this noise with any certainty

So trying some other distributions might elicit some other ideas