MHWD missing nvidia driver repositories to install from after some time and with the new 450xx update

I don’t know if this was a result of the update… it seems strange that this issue began when I hadn’t attempted any updates myself. I only realized this when finding out that my nvidia driver was no longer installed. At least, it appeared that way. Not sure what happened really, but I just wanted to switch from the (prime) 440xx to the 450xx driver. There was something not communicating between nvidia & the linuxXX version kernel. So I decided to go through the process of revamping my system to be solid, and make sure that all my drivers were correct and running smoothly.

I have an Alienware 17R4 laptop and have been running hybrid-nvidia-prime drivers. Taking the course of the suggested method from an online guide; using the command “yay -S nvidia”, which brings up the driver repository list to select from (i.e. linux56-nvidia-440xx), instead of using the “mhwd nonfree 0300” method, which would tend to ignore prime version drivers, and then installing optimus-manager, got my system running perfectly before.

I have been attempting to repeat the process, but for some reason when trying to install nvidia, the driver list is all gone EXCEPT for RealTime versions (linux56-rt-nvidia-450xx). I have tried reinstalling everything. MHWD core files… base-devel, etc. I can’t get them to show up. I ran nonfree 0300 and it appears to have installed the correct driver, but running mhwd -l shows no hybrid drivers installed… however inxi -G does.

I’d like some help getting those repositories back to install things properly. This just feels like a 4 sided, 3 legged table that’s bound to be a disaster later. I’ve come a long way as a newbie still and I’m trying to keep my OS in tact. Anyone have any idea on how to fix this problem and make sure things ARE actually doing what they’re supposed to be doing? Thanks.

Ok could you post the outputs of mhwd -li , mhwd -l and inxi -Gazy? It is not recommended to install things with different managers as that can muck up the configs. Also you can choose which driver to install with mhwd manually.

1 Like

I’m having the exact same problem. I have a fresh install of Manjaro as of today and am unable to use nvidia drivers.

Here is the output from Manjaro Settings Manager.


> Using config 'video-nvidia-450xx' for device: 0000:01:00.0 (0300:10de:1c03) Display controller nVidia Corporation GP106 [GeForce GTX 1060 6GB]

> Installing video-nvidia-450xx...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

Processing classid: 0302

:: Synchronizing package databases...

error: target not found: linux56-nvidia-450xx

core is up to date

extra is up to date

community is up to date

multilib is up to date

Error: pacman failed!

Error: script failed!

Done ...

I went to the terminal and ran pacman -Syu, just in case I had missed an update, but the problem persists.

The 5.6 series kernel is end of life. Upgrade/downgrade to a different one.

1 Like

Hi pobrn. Thank you for pointing that out. I upgraded to 5.8 and rebooted. The problem persisted but after uninstalling 5.6, the problem went away. I am now able to install the nvidia drivers!

Does anyone have any idea how I ended up with an old kernel? I downloaded the Manjaro XFCE ISO just yesterday.

I assume the ISOs haven’t been updated. Depending on when you downloaded the ISO, you might’ve missed the update.

1 Like

Great investigative work, pobrn. I may have missed it by just a minute.

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.