Meta (Windows key) does not launch app launcher - suggestion

If you too are struggling with the Meta key not launching the App Launcher, here is another suggestion to try. It worked for me (Lenovo Desktop, Plasma 5.22.5).
Go to System settings → Hardware ->Input Devices → Keyboard and check the following:

  1. Your keyboard is actually the one listed in ‘Keyboard model’ (or as close to it as possible)
  2. Under the ‘Advanced’ tab → ‘Alt and Win Behavior’ sub-menu, make sure ‘Meta is mapped to Win’ is checked.
    You may want to check other options as well.
    Changes may take place only after re-login or restart.
    Again, this worked for me - hopefully it may work for you as well.

I dont have that option selected and it works here.

Setting to Alt+F12 in Configure Application Launcher > Keyboard Shortcuts will make Meta work.

( yes, its an under-documented plasma incantation :woman_mage: )

This method may be preferred over yours because of overlapping arguments.
Though the reverse may also be true for some.

This fault seems to reoccur every so often, here is how to fix it: