Messy file display (non-uniform columns) in file manager

gnome

#1

I have several problems on Gnome:

  1. Messy columns in Nautilus (problem both on Xorg and Wayland)

  2. Gnome Tweak tool problem related to all Adapta packages, not another theme (problem both on Xorg and Wayland)

  3. Window animations: tiling, maximize and etc. (problem on only Wayland, not on Xorg)


Thunar not displaying files properly
[Stable Update] 2017-10-29 - KDE, Gnome, Deepin, Firefox, Mesa, Kernels
File icons in Thunar too far apart
[Testing Update] 2017-10-28 - KDE, Gnome, Deepin, Firefox, Mesa
Names of files & folders (in french) finaly not truncated after update [Gnome]
[Stable Update] 2017-10-29 - KDE, Gnome, Deepin, Firefox, Mesa, Kernels
#2

Seems similar problem in Nemo on Cinnamon as well. at least here it looks like related to the file names, if they are longer it keeps bigger space for it.
Below a screenshot.


#3

Check this


#4

No success… It had already been turned off.


#5

As far as I could understand after some research, it is related to text-ellipsis-limit.

In Nemo it is here
/org/nemo/icon-view/text-ellipsis-limit
In Gnome Files I guess it should be
/org/gnome/nautilus/icon_view/text_ellipsis_limit

in both case the default value is 3, but at least it Cinnamon changing it doesn’t have an visible effect.


#6

I changed it to value 2:


#7

Oh, your’s look better with value 2, here is Nemo with 2

but with value 1 it looks better


#8

It is a gtk3 bug, I think. Changing the value is not correct solution. Even when I select items, randomly the issue occurs again.


#9

Same here, I guess the last update included some gtk packages, those are probably the reason, as the problem appear after those updates and two systems that use the same toolkit.


#10

It is strange. I downgraded gtk3 packages, again no success:


#11

There’s a new GTK3 point-release coming: http://ftp.gnome.org/pub/gnome/sources/gtk+/3.22/gtk+-3.22.25.news

Reading the changes nothing is obviously related to this, but you never know… :slight_smile:

Edit:

Same issue with Caja.


#12

I have a similar problem in thunar:

I use the gtk3-classic package


#13

For the first time ever in Gnome, after today’s update, the names of the files and folders in my language (french) are not truncated. See the “Téléchargements” folder (Downloads). The spacing between files and folders is now a bit awkward, though.


#14

In Gnome, changing the value from 3 to 1 or 2 had an effect in my Images folder, but not in my Home folder, where the name of one of my folder is long.


#15

maybe also downgrade pango, gtk-update-icon-cache, deconf , (mesa?)


[Stable Update] 2017-10-29 - KDE, Gnome, Deepin, Firefox, Mesa, Kernels
#16

I don’t know this issue solved or no in gtk 3.22.25 version. I can’t find anything:


[Stable Update] 2017-11-04 - Kernels, Gnome, Deepin, Mate, Mesa, Libreoffice
#17

downgrade pango to version 1.40.12-1 resolved the issue in thunar (so it seems a regression)

P.S.: It seems that downgrade package enabled in the stable branch has been useful in this case for me :wink:


Downgrade disabled on the stable branch? Why?
#18

Also in Nautilus.


#19

Yes, downgrading pango also worked for me with spacefm.

It’s been reported for Arch: https://bugs.archlinux.org/task/56147?project=1&cat[0]=2&string=pango

And gnome: https://bugzilla.gnome.org/show_bug.cgi?id=789625


Am I infected by virus?
#20

Hi @philm ,
Please downgrade pango in all Branches in order not to get this issue…