Messed up fonts in several applications

A while back I applied a theme, but I didn’t like it and swapped back to a regular theme and tweaked things to my preference.

However, a part of that theme changed fonts everywhere, and now LibreOffice Calc has some weird number font and tab font in the row labels and tab labels. I’ve tried changing my system fonts, and I’ve tried changing the fonts in LibreOffice settings, but I can’t seem to find whatever is the right setting to fix this.

I’ve even un-installed LibreOffice and re-installed, to no avail. So I assume it’s taking the font setting from somewhere in my desktop config. Does anyone know where to look for this?

EDIT: This has also affected Konsole. I usually use Kitty, which is unaffected, but in Konsole the cursor doesn’t align with where I’m typing and the spacing is all screwy, looks like tabs between words instead of spaces.

Attaching screenshot. You can see it’s not ALL fonts, but look at the row labels, tab name, and the ‘size’ and header fields in the options where it has the non-printable characters.

Here’s an example of Konsole being messed up. Those are only single spaces in the command and return.

A wild guess would be it is somewhere in ~/.config or .cache. Maybe delete ~/.cache/fontconfig/ ? Or play with the fc-cache command to rebuild the cache? That is, if the themes/fonts are fixed on system level and you only have to fix the cache.

Hmm… I tried an fc-cache -f, didn’t seem to have any effect. ~/.cache/fontconfig/ had no contents. I’ll try to dig into this some more, fc-cache is new to me.

With multiple applications affected, albeit in different ways, it would seem that there is a common cause. But on the off chance that things might be separate, the Document Foundation Wiki has a page that describes how to reset the LibreOffice user profile.

The konsole screenshot appears to show the use of a proportional font; this may cause spacing issues on its own. Were you using a monospace font before?

Maybe cleaning the KDE Plasma cache could be helpful. (Although I might be a little more selective in removing things from ~/.cache/ than shown in the Wiki.)

Ah-HA! You got me on the right track!

I did the LibreOffice profile test and discovered it wasn’t that. I tried altering a Konsole profile to use an explicitly mono font and it fixed that profile, but not the others.

That led me back to the system settings fonts, which I tried changing before to resolve this but it didn’t seem to make a difference, but I guess I hadn’t tried hard enough because it turned out that was it. It had a non-mono font for the default “Fixed width” font, so… duh on me.

Thank you!