Messed up colors in KDE

Yesterday I decreased the size of my Windows 10 partition so I could give some more space to Manjaro on my dual-boot machine. I turned my PC off, booted Manjaro from the live environment, updated the system and installed GParted to add the unallocated space to Manjaro (this was like the 3rd time I’ve done this process and never had any sort of issues). I booted to Manjaro after that and everything was working fine except for the colors of some elements that were darker than usual and it’s hard to see some buttons now, which is really annoying. Here are a few screenshots of the messed up colors.

As you can see the button icons are dark, and they weren’t like that before the partition resize. I am currently using the Sweet KDE theme in KDE Plasma 5.23.3, Framework version 5.88.0. And yes I have already tried changing color schemes but I keep getting the same results.
Any help you can give is appreciated.

Please edit your title, the partion resizing does not have anything to do with your problem but the update you did afterwards in all likelihood does.

1 Like

I tried to clean the cache but unfortunately I still have this issue. It could be because when I ran the kbuildsycoca5 --noincremental command, I got the following input:

kbuildsycoca5 running... The desktop entry file "/usr/share/applications/qemu.desktop" has Type= "Application" but no E
xec line
kf.service.sycoca: Invalid Service :  "/usr/share/applications/qemu.desktop"

I also did rm -rf ~/.cache/* and rebooted after that but still no success. Any indications in how to solve this?

inxi -Fazy
  Kernel: 5.14.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
  root=UUID=a11f9168-72df-4c44-8484-893cd57f346e rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
  dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Predator PH317-54 v: V1.04
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: CML model: Vellfire_CMS v: V1.04 serial: <filter> UEFI: Insyde v: 1.04
  date: 07/16/2020
  ID-1: BAT0 charge: 58.7 Wh (100.0%) condition: 58.7/58.8 Wh (99.9%)
  volts: 17.1 min: 15.4 model: S KT00407009 P18E7M type: Li-ion
  serial: <filter> status: Full
  Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 2 microcode: EA
  cache: L2: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 62431
  Speed: 3700 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 3700 2: 3700
  3: 3746 4: 3700 5: 3700 6: 3823 7: 2389 8: 2248 9: 3451 10: 4230 11: 4099
  12: 3423
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
  vendor: Acer Incorporated ALI driver: nvidia v: 495.44
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f15
  class-ID: 0300
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-7:3
  chip-ID: 0408:a061 class-ID: 0e02
  Display: x11 server: X.Org compositor: kwin_x11 driver:
  loaded: modesetting,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 128 size: 381x214mm (15.0x8.4")
  diag: 437mm (17.2")
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.5
  direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
  bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9
  class-ID: 0403
  Sound Server-1: ALSA v: k5.14.18-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.40 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
  driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet
  vendor: Acer Incorporated ALI driver: alx v: kernel port: 3000
  bus-ID: 07:00.0 chip-ID: 1969:e0b1 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 1-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 242.03 GiB (50.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
  model: PC SN730 SDBQNTY-512G-1014 size: 476.94 GiB block-size:
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
  serial: <filter> rev: 11101100 temp: 41.9 C scheme: GPT
  ID-1: / raw-size: 325.66 GiB size: 319.55 GiB (98.12%)
  used: 242.01 GiB (75.7%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 1024 MiB size: 1020 MiB (99.61%)
  used: 26.5 MiB (2.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p7 maj-min: 259:7
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 321 Uptime: 36m wakeups: 1 Memory: 15.47 GiB
  used: 2.76 GiB (17.8%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 1690 pacman: 1676 lib: 459 flatpak: 11
  snap: 3 Shell: Zsh v: 5.8 default: Bash v: 5.1.8 running-in: konsole
  inxi: 3.3.08

I suggest that those icon sets are not complete, restart and if the problem remains choose another icon set

It didn’t solve the problem, I have already tried to do it before but it seems it was no use. Another thing that I forgot to mention is that after this said partition resize, my keyboard’s lights stopped functioning but only in Manjaro. Usually when I boot up my PC the keyboard lights up and keeps like that when I boot to Manjaro, however now it just turns off and I can’t turn it on anymore. I think this said partition resize probably broke something on my system.

Maybe your problem is the theme or icon theme (looks like Candy Icons, right?) needs to be updated. I see on the kde store page that there was recent update to them that fixes some issues.

This has always been an issue with user created content, it usually lags behind a few days or never gets updates to maintain compatibility with new kde updates.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.