Mesa RADV driver not recognized, AMDVLK works

Hi, I have both MESA and AMDVLK installed.
Recently (maybe since last update) the MESA RADV driver ( is not working anymore (recognized when dota started in OpenGL mode).
I never had any problems and all games worked fine with the mesa drivers.

AMD RX 580

I tested with vulkaninfo and vkcube, results below.

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/radeon_icd.x86_64.json vulkaninfo
The selected gpu (0) is not a valid GPU index. The available GPUs are in the range of 0 to 18446744073709551615.
VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/radeon_icd.x86_64.json vkcube
vkEnumeratePhysicalDevices reported zero accessible devices.


    "ICD": {
        "api_version": "1.2.182",
        "library_path": "/usr/lib/"
    "file_format_version": "1.0.0"

Welcome to the forum! :wave:

Please post your system info as outlined here:

same problem with 5.14 kernel

$ inxi --admin --verbosity=7 --filter --no-host --width
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US",
        LC_ALL = (unset),
        LC_ADDRESS = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MONETARY = "en_US.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_MEASUREMENT = "en_US.UTF-8",
        LC_TIME = "en_DE.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
  Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=12aea12d-8449-4d41-9049-75feea41d21d rw 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: Z97 Pro4 serial: <filter> 
  UEFI: American Megatrends v: P2.50 date: 05/27/2016 
  Message: No system battery data found. Is one present? 
  RAM: total: 15.58 GiB used: 5.95 GiB (38.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-4690K bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: L2: 6 MiB 
  bogomips: 28001 
  Speed: 2095 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 2095 2: 2447 
  3: 2521 4: 3146 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht 
  ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor 
  movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb 
  pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good sdbg sep 
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt 
  xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: Tul driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67df 
  class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: amdgpu display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") 
  s-diag: 1165mm (45.9") 
  Monitor-1: DisplayPort-2 res: 3840x2160 hz: 60 dpi: 157 
  size: 621x341mm (24.4x13.4") diag: 708mm (27.9") 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.41.0 
  5.13.13-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Device-1: Intel 9 Series Family HD Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0 
  class-ID: 0403 
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: Tul driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  chip-ID: 1002:aaf0 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: no 
  Device-1: Intel Ethernet I218-V vendor: ASRock driver: e1000e v: kernel 
  port: f040 bus-ID: 00:19.0 chip-ID: 8086:15a1 class-ID: 0200 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 4.09 TiB used: 2.53 TiB (61.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 39.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SH103S3240G 
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: BBF0 scheme: GPT 
  ID-3: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDH2256G 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 200 scheme: GPT 
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital 
  model: WD3003FZEX-00Z4SA0 size: 2.73 TiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> 
  rev: 1A01 scheme: GPT 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH20NS15 rev: IL00 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 94.01 GiB size: 92.04 GiB (97.90%) used: 50.6 GiB (55.0%) 
  fs: ext4 dev: /dev/sdb3 maj-min: 8:19 label: N/A 
  uuid: 12aea12d-8449-4d41-9049-75feea41d21d 
  ID-2: /M2_930GB raw-size: 930.53 GiB size: 914.93 GiB (98.32%) 
  used: 591.76 GiB (64.7%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: 1TB_M2 uuid: afc9ba45-f80e-4a8b-b31f-e0e8a2581623 
  ID-3: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) 
  used: 264 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: BOOT 
  uuid: BE8E-C897 
  ID-4: /home raw-size: 222.01 GiB size: 217.52 GiB (97.98%) 
  used: 164.09 GiB (75.4%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: home 
  uuid: da6c0f95-7f8c-4bfd-bba7-9873346a375d 
  ID-5: /run/media/andreas/WD_3TB_a raw-size: 1.36 TiB 
  size: 1.36 TiB (100.00%) used: 679.47 GiB (48.8%) fs: ntfs dev: /dev/sdc1 
  maj-min: 8:33 label: WD_3TB_a uuid: 7C0CD7A827660DFF 
  ID-6: /run/media/andreas/WD_3TB_b raw-size: 1.37 TiB 
  size: 1.37 TiB (100.00%) used: 1.01 TiB (73.7%) fs: ntfs dev: /dev/sdc2 
  maj-min: 8:34 label: WD_3TB_b uuid: 2A426F505C66E6B0 
  ID-7: /space140 raw-size: 137.3 GiB size: 134.14 GiB (97.70%) 
  used: 69.17 GiB (51.6%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 
  label: space140 uuid: a1e5abaa-f808-46cb-bda5-5d654adec97b 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.37 GiB used: 50.2 MiB (1.1%) 
  priority: -2 dev: /dev/sdb4 maj-min: 8:20 label: N/A 
  uuid: 1d3b88ad-b953-419d-9f94-066969802576 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel ports: 6 rev: 2.0 speed: 480 Mb/s 
  chip-ID: 8087:8009 class-ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s 
  chip-ID: 8087:8001 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-13:2 info: Razer USA DeathAdder Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 1532:0007 class-ID: 0301 
  Device-2: 3-14:3 info: Cherry Keyboard type: Keyboard,HID 
  driver: cherry,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s power: 100mA 
  chip-ID: 046a:0023 class-ID: 0300 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: amdgpu temp: 51.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1057 
  Processes: 252 Uptime: 3h 13m wakeups: 0 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1781 
  lib: 480 flatpak: 0 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Does this occur if you uninstall AMDVLK? If it doesn’t, then the wiki explains why this is happening.

As of amdvlk 2021.Q3.4, a new switching logic was implemented which enforces AMDVLK as the default and mandates you either

  • set AMD_VULKAN_ICD=RADV to switch from the AMDVLK default,
  • or globally set DISABLE_LAYER_AMD_SWITCHABLE_GRAPHICS_1=1 to re-enable the ICD loader method below.
1 Like

thanks for the clarification of the wiki entry, works now

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.