Mesa package causes Illegal Instruction Signal 4 error on Xorg startup

I don't know where to report this and what information is needed.

I am using Majaro with XFCE with an old AMD grpahics card and my updates were kept up to date.

My mesa package upgraded to version 19.3.4-0.1 today. That caused the following error on startup:

[ 11198.411] (EE) Backtrace:
[ 11198.411] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x4d) [0x55f196e6d6dd]
[ 11198.411] (EE) 1: /usr/lib/Xorg (0x55f196dba000+0xa9c68) [0x55f196e63c68]
[ 11198.411] (EE) 2: /usr/lib/libc.so.6 (0x7fba68a28000+0x3bfb0) [0x7fba68a63fb0]
[ 11198.411] (EE) 3: /usr/lib/dri/r600_dri.so (0x7fba6614d000+0x52a404) [0x7fba66677404]
[ 11198.411] (EE) 4: /usr/lib/dri/r600_dri.so (0x7fba6614d000+0x53cf16) [0x7fba66689f16]
[ 11198.411] (EE) 5: /usr/lib/dri/r600_dri.so (0x7fba6614d000+0x527e04) [0x7fba66674e04]
[ 11198.411] (EE) 6: /usr/lib/dri/r600_dri.so (0x7fba6614d000+0x528fa3) [0x7fba66675fa3]
[ 11198.411] (EE) 7: /usr/lib/dri/r600_dri.so (0x7fba6614d000+0xed4cd) [0x7fba6623a4cd]
[ 11198.411] (EE) 8: /lib64/ld-linux-x86-64.so.2 (0x7fba68c2d000+0x1072a) [0x7fba68c3d72a]
[ 11198.411] (EE) 9: /lib64/ld-linux-x86-64.so.2 (0x7fba68c2d000+0x10831) [0x7fba68c3d831]
[ 11198.411] (EE) 10: /lib64/ld-linux-x86-64.so.2 (0x7fba68c2d000+0x14603) [0x7fba68c41603]
[ 11198.411] (EE) 11: /usr/lib/libc.so.6 (_dl_catch_exception+0x79) [0x7fba68b61d79]
[ 11198.411] (EE) 12: /lib64/ld-linux-x86-64.so.2 (0x7fba68c2d000+0x13eee) [0x7fba68c40eee]
[ 11198.411] (EE) 13: /usr/lib/libdl.so.2 (0x7fba68833000+0x134c) [0x7fba6883434c]
[ 11198.411] (EE) 14: /usr/lib/libc.so.6 (_dl_catch_exception+0x79) [0x7fba68b61d79]
[ 11198.412] (EE) 15: /usr/lib/libc.so.6 (_dl_catch_error+0x33) [0x7fba68b61e13]
[ 11198.412] (EE) 16: /usr/lib/libdl.so.2 (0x7fba68833000+0x1ab9) [0x7fba68834ab9]
[ 11198.412] (EE) 17: /usr/lib/libdl.so.2 (dlopen+0x4a) [0x7fba688343da]
[ 11198.412] (EE) 18: /usr/lib/libgbm.so.1 (0x7fba678b0000+0x62d0) [0x7fba678b62d0]
[ 11198.412] (EE) 19: /usr/lib/libgbm.so.1 (0x7fba678b0000+0x50a7) [0x7fba678b50a7]
[ 11198.412] (EE) 20: /usr/lib/libgbm.so.1 (0x7fba678b0000+0x553c) [0x7fba678b553c]
[ 11198.412] (EE) 21: /usr/lib/libgbm.so.1 (gbm_create_device+0x59) [0x7fba678b31d9]
[ 11198.412] (EE) 22: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7fba678d0000+0x5bf86) [0x7fba6792bf86]
[ 11198.412] (EE) 23: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x7fba678d0000+0x4c2a4) [0x7fba6791c2a4]
[ 11198.412] (EE) 24: /usr/lib/Xorg (InitOutput+0x1412) [0x55f196e50412]
[ 11198.412] (EE) 25: /usr/lib/Xorg (0x55f196dba000+0x38503) [0x55f196df2503]
[ 11198.412] (EE) 26: /usr/lib/libc.so.6 (__libc_start_main+0xf3) [0x7fba68a4f153]
[ 11198.412] (EE) 27: /usr/lib/Xorg (_start+0x2e) [0x55f196df33be]
[ 11198.412] (EE)
[ 11198.412] (EE) Illegal instruction at address 0x7fba66677404
[ 11198.412] (EE)
Fatal server error:
[ 11198.412] (EE) Caught signal 4 (Illegal instruction). Server aborting

I resolved the problem by down grading the mesa package back to 19.3.3-1

1 Like

I am using XFCE on an nvidia graphics card with the nouveau driver and have also hit a problem with 'mesa 19.3.4-0.1.

Dump

Process 435 (Xorg) of user 0 dumped core.

Stack trace of thread 435:
#0 0x00007fb2683c0f25 raise (libc.so.6)
#1 0x00007fb2683aa897 abort (libc.so.6)
#2 0x000055d69dc5ac5a OsAbort (Xorg)
#3 0x000055d69dc5e4a1 FatalError (Xorg)
#4 0x000055d69dc61cd2 n/a (Xorg)
#5 0x00007fb2683c0fb0 __restore_rt (libc.so.6)
#6 0x00007fb266075404 n/a (nouveau_dri.so)
#7 0x00007fb266087f16 n/a (nouveau_dri.so)
#8 0x00007fb266072e04 n/a (nouveau_dri.so)
#9 0x00007fb266073fa3 n/a (nouveau_dri.so)
#10 0x00007fb265c384cd n/a (nouveau_dri.so)
#11 0x00007fb26858e72a call_init.part.0 (ld-linux-x86-64.so.2)
#12 0x00007fb26858e831 _dl_init (ld-linux-x86-64.so.2)
#13 0x00007fb268592603 dl_open_worker (ld-linux-x86-64.so.2)
#14 0x00007fb2684bed79 _dl_catch_exception (libc.so.6)
#15 0x00007fb268591eee _dl_open (ld-linux-x86-64.so.2)
#16 0x00007fb26819134c n/a (libdl.so.2)
#17 0x00007fb2684bed79 _dl_catch_exception (libc.so.6)
#18 0x00007fb2684bee13 _dl_catch_error (libc.so.6)
#19 0x00007fb268191ab9 n/a (libdl.so.2)
#20 0x00007fb2681913da dlopen (libdl.so.2)
#21 0x00007fb267599e53 n/a (libglx.so)
#22 0x00007fb2675b4b1b n/a (libglx.so)
#23 0x00007fb2675988c7 n/a (libglx.so)
#24 0x000055d69dd26744 _CallCallbacks (Xorg)
#25 0x000055d69dc56ce3 n/a (Xorg)
#26 0x000055d69dd639d9 InitExtensions (Xorg)
#27 0x000055d69dbf0526 n/a (Xorg)
#28 0x00007fb2683ac153 __libc_start_main (libc.so.6)
#29 0x000055d69dbf13be _start (Xorg)

inxi -Fxxx

[keith@Elephant-Stable ~]$ inxi -Fxxx
System: Host: Elephant-Stable Kernel: 5.5.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Xfce 4.14.2
tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASUSTeK model: M2N-E SLI v: 1.XX serial: BIOS: Phoenix
v: ASUS M2N-E SLI Revision 1301 date: 09/16/2010
CPU: Topology: Dual Core model: AMD Athlon 64 X2 6400+ bits: 64 type: MCP arch: K8 rev.F+ rev: 3 L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 svm bogomips: 12870
Speed: 1000 MHz min/max: 1000/3200 MHz Core speeds (MHz): 1: 1000 2: 1000
Graphics: Device-1: NVIDIA NV42GL [Quadro FX 3450/4000 SDI] driver: nouveau v: kernel bus ID: 05:00.0 chip ID: 10de:00cd
Display: x11 server: X.Org 1.20.7 driver: nouveau unloaded: modesetting alternate: fbdev,nv,vesa
resolution: 1600x900~60Hz, 1280x1024_75~75Hz
OpenGL: renderer: NV42 v: 2.1 Mesa 19.3.3 direct render: Yes
Audio: Device-1: C-Media CM6501 type: USB driver: snd-usb-audio bus ID: 2-7:3 chip ID: 0d8c:0201
Sound Server: ALSA v: k5.5.2-1-MANJARO
Network: Device-1: NVIDIA CK804 Ethernet vendor: ASUSTeK type: network bridge driver: forcedeth v: kernel port: bc00
bus ID: 00:0a.0 chip ID: 10de:0057
IF: enp0s10 state: up speed: 1000 Mbps duplex: full mac: 00:1b:fc:ed:26:be
Drives: Local Storage: total: 646.39 GiB used: 103.15 GiB (16.0%)
ID-1: /dev/sda vendor: Western Digital model: WD1200BB-32DWA0 size: 111.79 GiB speed:
serial: WD-WMAEL1096158 rev: 5R15 scheme: GPT
ID-2: /dev/sdb vendor: Maxtor model: 6L200P0 size: 189.92 GiB speed: serial: L41JYV2G rev: 1G20
scheme: GPT
ID-3: /dev/sdc vendor: Western Digital model: WD1200BB-00CAA1 size: 111.79 GiB speed:
serial: WD-WMA8C2591421 rev: 7W17 scheme: GPT
ID-4: /dev/sdd vendor: Western Digital model: WD2500AAKX-00ERMA0 size: 232.89 GiB speed: 1.5 Gb/s
serial: WD-WCC2EE715879 rev: 1H15 scheme: GPT
Partition: ID-1: / size: 13.64 GiB used: 11.08 GiB (81.2%) fs: ext4 dev: /dev/sdd1
ID-2: /home size: 192.41 GiB used: 92.07 GiB (47.8%) fs: ext4 dev: /dev/sdd3
ID-3: swap-1 size: 7.54 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdd4
Sensors: System Temperatures: cpu: 32.0 C mobo: 27.0 C
Fan Speeds (RPM): cpu: 584 psu: 0 case-1: 382
Info: Processes: 150 Uptime: 9m Memory: 3.84 GiB used: 720.3 MiB (18.3%) Init: systemd v: 242 Compilers: gcc: 9.2.0
Shell: bash v: 5.0.11 running in: xfce4-terminal inxi: 3.0.37

I have also downgraded mesa to 19.3.3-1.

1 Like

@philm Is it intentional that mesa 19.3.4 is available in stable but not in testing and unstable?
http://manjaro32.org/repo-compare/extra.html

Same problem on all OS that were updated with the latest Mesa update. Downgrading works.

Thank you guys! Tried stuff for hours before I found this thread. Should I blacklist mesa for updates or will it soon be resolved?

I have the same problem on a pc using the graphics card [AMD/ATI] RV670 [Radeon HD 3870] after updating today. I am using Manjaro with XFCE. It is not possible to start lightdm.service due to the error above:

$ sudo systemctl start lightdm.service
$ sudo systemctl status lightdm.service
â—Ź lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Fri 2020-02-14 16:24:17 CET; 9s ago
Docs: man:lightdm(1)
Process: 778 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
Main PID: 778 (code=exited, status=1/FAILURE)

Feb 14 16:24:17 tower systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Feb 14 16:24:17 tower systemd[1]: lightdm.service: Failed with result 'exit-code'.
Feb 14 16:24:17 tower systemd[1]: lightdm.service: Service RestartSec=100ms expired, scheduling restart.
Feb 14 16:24:17 tower systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Feb 14 16:24:17 tower systemd[1]: Stopped Light Display Manager.
Feb 14 16:24:17 tower systemd[1]: lightdm.service: Start request repeated too quickly.
Feb 14 16:24:17 tower systemd[1]: lightdm.service: Failed with result 'exit-code'.
Feb 14 16:24:17 tower systemd[1]: Failed to start Light Display Manager.

1 Like

Have the same problem today after updating, thanks to this post I fixed it.
In my case I got stuck at verbose boot.
Switch to another tty with CTRL + ALT + F2~F9
Login with your user
Install "downgrade" package
source: https://wiki.manjaro.org/index.php?title=Downgrading_packages

sudo pacman -S downgrade

After installing:

sudo downgrade mesa

Will get you a choose 1~5 menu, select the previous working version (actual version has a '+' in front) with the numbers.

Will ask you if you want to blacklist (optional, y/n)
Reboot
Done

2 Likes

Seems to be related to this issue. We removed our overlay packages and wait for upstream for a proper fix. To fix it on your end please do:

sudo pacman -Syyuu

1 Like

I did it.
Now I see and can move the mouse-curser, but there is no login-screen.
I have plasma - stable on my system:

System:    Host: Laptop Kernel: 5.5.2-1-MANJARO x86_64 bits: 64 Console: tty 0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 766511G v: ThinkPad T61 serial: <root required> 
           Mobo: LENOVO model: 766511G serial: <root required> BIOS: LENOVO v: 7LETC1WW (2.21 ) date: 07/01/2008 
Battery:   ID-1: BAT0 charge: 57.6 Wh condition: 61.2/71.3 Wh (86%) 
CPU:       Topology: Dual Core model: Intel Core2 Duo T7100 bits: 64 type: MCP L2 cache: 2048 KiB 
           Speed: 798 MHz min/max: 800/1801 MHz Core speeds (MHz): 1: 852 2: 824 
Graphics:  Device-1: NVIDIA G86M [Quadro NVS 140M] driver: nouveau v: kernel 
           Display: server: X.org 1.20.7 driver: nouveau unloaded: modesetting tty: 212x27 
           Message: Advanced graphics data unavailable in console. Try -G --display 
Audio:     Device-1: Intel 82801H HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.5.2-1-MANJARO 
Network:   Device-1: Intel 82566MM Gigabit Network driver: e1000e 
           IF: enp0s25 state: down mac: 00:21:86:5c:7d:c5 
           Device-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network driver: iwl4965 
           IF: wls3 state: up mac: 00:21:5c:4e:c3:0b 
Drives:    Local Storage: total: 223.57 GiB used: 14.21 GiB (6.4%) 
           ID-1: /dev/sda vendor: SanDisk model: SDSSDHII240G size: 223.57 GiB 
Partition: ID-1: / size: 211.70 GiB used: 14.21 GiB (6.7%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.36 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 47.0 C mobo: 44.0 C 
           Fan Speeds (RPM): fan-1: 0 
Use of uninitialized value $val2 in string eq at /usr/bin/inxi line 5792.
Use of uninitialized value $val2 in split at /usr/bin/inxi line 5797.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5799.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5800.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5801.
           GPU: device: temp: N/A device: nouveau temp: 62 C 
Info:      Processes: 125 Uptime: 4m Memory: 3.78 GiB used: 205.3 MiB (5.3%) Init: systemd Shell: bash inxi: 3.0.37 

regards
caho

Did you reboot your machine? Only thing I added today was mesa 19.3.4, which was a mistake. Normally those updates kinda work. Check your /var/log/pacman.log on packages got updated today.

Thanks @philm, it worked for me. The login screen appears again and I can login again with no problems.
I executed sudo pacman-mirrors -f 6 before executing sudo pacman -Syyuu.

This is what pacman displayed:

:: Starting full system upgrade...
warning: lib32-libva-mesa-driver: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: lib32-mesa: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: lib32-mesa-vdpau: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: lib32-vulkan-intel: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: lib32-vulkan-radeon: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: libva-mesa-driver: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: mesa: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: mesa-vdpau: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: vulkan-intel: downgrading from version 19.3.4-0.1 to version 19.3.3-1
warning: vulkan-radeon: downgrading from version 19.3.4-0.1 to version 19.3.3-1
resolving dependencies...
looking for conflicting packages...

Packages (10) lib32-libva-mesa-driver-19.3.3-1  lib32-mesa-19.3.3-1  lib32-mesa-vdpau-19.3.3-1  lib32-vulkan-intel-19.3.3-1  lib32-vulkan-radeon-19.3.3-1
              libva-mesa-driver-19.3.3-1  mesa-19.3.3-1  mesa-vdpau-19.3.3-1  vulkan-intel-19.3.3-1  vulkan-radeon-19.3.3-1

Total Installed Size:  210,70 MiB
Net Upgrade Size:       -0,40 MiB

Yes, I rebooted my machine.

Here is the output from pacman.log:

[2020-02-14T16:19:26+0100] [PACMAN] Running 'pacman -Syu'
[2020-02-14T16:19:26+0100] [PACMAN] synchronizing package lists
[2020-02-14T16:19:27+0100] [PACMAN] starting full system upgrade
[2020-02-14T16:20:05+0100] [ALPM] transaction started
[2020-02-14T16:20:06+0100] [ALPM] upgraded mesa (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:06+0100] [ALPM] upgraded lib32-mesa (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:07+0100] [ALPM] upgraded lib32-mesa-vdpau (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:07+0100] [ALPM] upgraded lib32-vulkan-intel (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:07+0100] [ALPM] upgraded lib32-vulkan-radeon (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:07+0100] [ALPM] upgraded libva-mesa-driver (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:07+0100] [ALPM] upgraded manjaro-hello (0.6.4-1 -> 0.6.4-2)
[2020-02-14T16:20:07+0100] [ALPM] upgraded mesa-vdpau (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:07+0100] [ALPM] upgraded vulkan-intel (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:07+0100] [ALPM] upgraded vulkan-radeon (19.3.3-1 -> 19.3.4-0.1)
[2020-02-14T16:20:08+0100] [ALPM] transaction completed
[2020-02-14T16:20:08+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T16:20:08+0100] [ALPM] running 'update-desktop-database.hook'...
[2020-02-14T16:27:20+0100] [PACMAN] Running 'pacman -Syyuu'
[2020-02-14T16:27:20+0100] [PACMAN] synchronizing package lists
[2020-02-14T16:27:22+0100] [PACMAN] starting full system upgrade
[2020-02-14T16:34:09+0100] [PACMAN] Running 'pacman -Syyuu'
[2020-02-14T16:34:09+0100] [PACMAN] synchronizing package lists
[2020-02-14T16:34:10+0100] [PACMAN] starting full system upgrade
[2020-02-14T16:41:23+0100] [PACMAN] Running 'pacman -Syyuu'
[2020-02-14T16:41:23+0100] [PACMAN] synchronizing package lists
[2020-02-14T16:41:28+0100] [PACMAN] starting full system upgrade
[2020-02-14T16:42:23+0100] [PACMAN] Running 'pacman -S video-nvidia'
[2020-02-14T16:43:56+0100] [PACMAN] Running 'pacman -S linux-latest-nvidia-340xx'
[2020-02-14T16:44:14+0100] [ALPM] transaction started
[2020-02-14T16:44:18+0100] [ALPM] installed nvidia-340xx-utils (340.108-1)
[2020-02-14T16:44:18+0100] [ALPM-SCRIPTLET] ==> If you run into trouble with CUDA not being available, run nvidia-modprobe first.
[2020-02-14T16:44:18+0100] [ALPM] installed linux54-nvidia-340xx (340.108-13)
[2020-02-14T16:44:32+0100] [ALPM-SCRIPTLET] In order to use nvidia module, reboot the system.
[2020-02-14T16:44:32+0100] [ALPM] installed linux-latest-nvidia-340xx (5.4-1)
[2020-02-14T16:44:32+0100] [ALPM] transaction completed
[2020-02-14T16:44:32+0100] [ALPM] running '20-systemd-sysusers.hook'...
[2020-02-14T16:44:33+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T16:44:33+0100] [ALPM] running '60-depmod.hook'...
[2020-02-14T16:44:33+0100] [ALPM] running 'update-desktop-database.hook'...
[2020-02-14T16:46:17+0100] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy nvidia-340xx-utils lib32-nvidia-340xx-utils linux54-nvidia-340xx linux55-nvidia-340xx'
[2020-02-14T16:46:17+0100] [PACMAN] synchronizing package lists
[2020-02-14T17:03:28+0100] [PACMAN] Running 'pacman -S downgrade'
[2020-02-14T17:03:31+0100] [ALPM] transaction started
[2020-02-14T17:03:31+0100] [ALPM] installed downgrade (6.2.3-1)
[2020-02-14T17:03:31+0100] [ALPM] transaction completed
[2020-02-14T17:03:31+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:03:39+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst'
[2020-02-14T17:04:50+0100] [ALPM] transaction started
[2020-02-14T17:04:50+0100] [ALPM] reinstalled mesa (19.3.4-0.1)
[2020-02-14T17:04:51+0100] [ALPM] transaction completed
[2020-02-14T17:04:51+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:07:26+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst'
[2020-02-14T17:11:23+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst'
[2020-02-14T17:12:32+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst'
[2020-02-14T17:12:38+0100] [ALPM] transaction started
[2020-02-14T17:12:38+0100] [ALPM] reinstalled mesa (19.3.4-0.1)
[2020-02-14T17:12:39+0100] [ALPM] transaction completed
[2020-02-14T17:12:39+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:15:54+0100] [PACMAN] Running 'pacman -Syyuu'
[2020-02-14T17:15:54+0100] [PACMAN] synchronizing package lists
[2020-02-14T17:15:55+0100] [PACMAN] starting full system upgrade
[2020-02-14T17:20:32+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst'
[2020-02-14T17:21:40+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst'
[2020-02-14T17:22:28+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/mesa-19.3.4-0.1-x86_64.pkg.tar.zst'
[2020-02-14T17:22:34+0100] [ALPM] transaction started
[2020-02-14T17:22:34+0100] [ALPM] reinstalled mesa (19.3.4-0.1)
[2020-02-14T17:22:35+0100] [ALPM] transaction completed
[2020-02-14T17:22:35+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:27:04+0100] [PACMAN] Running 'pacman -Syyuu'
[2020-02-14T17:27:04+0100] [PACMAN] synchronizing package lists
[2020-02-14T17:27:06+0100] [PACMAN] starting full system upgrade
[2020-02-14T17:27:18+0100] [ALPM] transaction started
[2020-02-14T17:27:19+0100] [ALPM] downgraded mesa (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:19+0100] [ALPM] downgraded lib32-mesa (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:19+0100] [ALPM] downgraded lib32-mesa-vdpau (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:19+0100] [ALPM] downgraded lib32-vulkan-intel (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:20+0100] [ALPM] downgraded lib32-vulkan-radeon (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:20+0100] [ALPM] downgraded libva-mesa-driver (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:20+0100] [ALPM] downgraded mesa-vdpau (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:20+0100] [ALPM] downgraded vulkan-intel (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:20+0100] [ALPM] downgraded vulkan-radeon (19.3.4-0.1 -> 19.3.3-1)
[2020-02-14T17:27:20+0100] [ALPM] transaction completed
[2020-02-14T17:27:20+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:37:18+0100] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -Rs xf86-video-ati xf86-video-amdgpu xf86-video-intel xf86-video-nouveau vulkan-intel vulkan-radeon libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-vulkan-intel lib32-vulkan-radeon lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2020-02-14T17:37:18+0100] [ALPM] transaction started
[2020-02-14T17:37:19+0100] [ALPM] removed lib32-mesa-vdpau (19.3.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed lib32-libva-vdpau-driver (0.7.4-6)
[2020-02-14T17:37:19+0100] [ALPM] removed lib32-libvdpau (1.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed lib32-libva (2.6.0-1)
[2020-02-14T17:37:19+0100] [ALPM] removed lib32-vulkan-radeon (19.3.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed lib32-vulkan-intel (19.3.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed mesa-vdpau (19.3.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed libva-vdpau-driver (0.7.4-4)
[2020-02-14T17:37:19+0100] [ALPM] removed libva-mesa-driver (19.3.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed vulkan-radeon (19.3.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed vulkan-intel (19.3.3-1)
[2020-02-14T17:37:19+0100] [ALPM] removed xf86-video-nouveau (1.0.16-1)
[2020-02-14T17:37:19+0100] [ALPM] removed xf86-video-intel (1:2.99.917+899+gf66d3954-1)
[2020-02-14T17:37:19+0100] [ALPM] removed xf86-video-amdgpu (19.1.0-1)
[2020-02-14T17:37:19+0100] [ALPM] removed xf86-video-ati (1:19.1.0-1)
[2020-02-14T17:37:20+0100] [ALPM] transaction completed
[2020-02-14T17:37:20+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:37:21+0100] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy xf86-video-ati xf86-video-amdgpu xf86-video-intel xf86-video-nouveau vulkan-intel vulkan-radeon libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-vulkan-intel lib32-vulkan-radeon lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2020-02-14T17:37:21+0100] [PACMAN] synchronizing package lists
[2020-02-14T17:37:24+0100] [ALPM] transaction started
[2020-02-14T17:37:24+0100] [ALPM] installed xf86-video-ati (1:19.1.0-1)
[2020-02-14T17:37:24+0100] [ALPM] installed xf86-video-amdgpu (19.1.0-1)
[2020-02-14T17:37:24+0100] [ALPM] installed xf86-video-intel (1:2.99.917+899+gf66d3954-1)
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET] >>> This driver now uses DRI3 as the default Direct Rendering
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]     Infrastructure. You can try falling back to DRI2 if you run
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]     into trouble. To do so, save a file with the following 
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]     content as /etc/X11/xorg.conf.d/20-intel.conf :
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]       Section "Device"
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]         Identifier  "Intel Graphics"
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]         Driver      "intel"
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]         Option      "DRI" "2"             # DRI3 is now default 
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "sna" # default
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "uxa" # fallback
[2020-02-14T17:37:24+0100] [ALPM-SCRIPTLET]       EndSection
[2020-02-14T17:37:24+0100] [ALPM] installed xf86-video-nouveau (1.0.16-1)
[2020-02-14T17:37:24+0100] [ALPM] installed vulkan-intel (19.3.3-1)
[2020-02-14T17:37:24+0100] [ALPM] installed vulkan-radeon (19.3.3-1)
[2020-02-14T17:37:24+0100] [ALPM] installed libva-mesa-driver (19.3.3-1)
[2020-02-14T17:37:24+0100] [ALPM] installed libva-vdpau-driver (0.7.4-4)
[2020-02-14T17:37:25+0100] [ALPM] installed mesa-vdpau (19.3.3-1)
[2020-02-14T17:37:25+0100] [ALPM] installed lib32-vulkan-intel (19.3.3-1)
[2020-02-14T17:37:25+0100] [ALPM] installed lib32-vulkan-radeon (19.3.3-1)
[2020-02-14T17:37:25+0100] [ALPM] installed lib32-libva (2.6.0-1)
[2020-02-14T17:37:25+0100] [ALPM] installed lib32-libvdpau (1.3-1)
[2020-02-14T17:37:25+0100] [ALPM] installed lib32-libva-vdpau-driver (0.7.4-6)
[2020-02-14T17:37:25+0100] [ALPM] installed lib32-mesa-vdpau (19.3.3-1)
[2020-02-14T17:37:25+0100] [ALPM] transaction completed
[2020-02-14T17:37:25+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:45:32+0100] [PACMAN] Running 'pacman -S xf86-video nouveau'
[2020-02-14T17:53:00+0100] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -Rs xf86-video-ati xf86-video-amdgpu xf86-video-intel xf86-video-nouveau vulkan-intel vulkan-radeon libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-vulkan-intel lib32-vulkan-radeon lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2020-02-14T17:53:00+0100] [ALPM] transaction started
[2020-02-14T17:53:01+0100] [ALPM] removed lib32-mesa-vdpau (19.3.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed lib32-libva-vdpau-driver (0.7.4-6)
[2020-02-14T17:53:01+0100] [ALPM] removed lib32-libvdpau (1.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed lib32-libva (2.6.0-1)
[2020-02-14T17:53:01+0100] [ALPM] removed lib32-vulkan-radeon (19.3.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed lib32-vulkan-intel (19.3.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed mesa-vdpau (19.3.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed libva-vdpau-driver (0.7.4-4)
[2020-02-14T17:53:01+0100] [ALPM] removed libva-mesa-driver (19.3.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed vulkan-radeon (19.3.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed vulkan-intel (19.3.3-1)
[2020-02-14T17:53:01+0100] [ALPM] removed xf86-video-nouveau (1.0.16-1)
[2020-02-14T17:53:01+0100] [ALPM] removed xf86-video-intel (1:2.99.917+899+gf66d3954-1)
[2020-02-14T17:53:01+0100] [ALPM] removed xf86-video-amdgpu (19.1.0-1)
[2020-02-14T17:53:01+0100] [ALPM] removed xf86-video-ati (1:19.1.0-1)
[2020-02-14T17:53:02+0100] [ALPM] transaction completed
[2020-02-14T17:53:02+0100] [ALPM] running '30-systemd-update.hook'...
[2020-02-14T17:53:16+0100] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy xf86-video-ati xf86-video-amdgpu xf86-video-intel xf86-video-nouveau vulkan-intel vulkan-radeon libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-vulkan-intel lib32-vulkan-radeon lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2020-02-14T17:53:16+0100] [PACMAN] synchronizing package lists
[2020-02-14T17:53:19+0100] [ALPM] transaction started
[2020-02-14T17:53:19+0100] [ALPM] installed xf86-video-ati (1:19.1.0-1)
[2020-02-14T17:53:19+0100] [ALPM] installed xf86-video-amdgpu (19.1.0-1)
[2020-02-14T17:53:19+0100] [ALPM] installed xf86-video-intel (1:2.99.917+899+gf66d3954-1)
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET] >>> This driver now uses DRI3 as the default Direct Rendering
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]     Infrastructure. You can try falling back to DRI2 if you run
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]     into trouble. To do so, save a file with the following 
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]     content as /etc/X11/xorg.conf.d/20-intel.conf :
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]       Section "Device"
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]         Identifier  "Intel Graphics"
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]         Driver      "intel"
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]         Option      "DRI" "2"             # DRI3 is now default 
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "sna" # default
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "uxa" # fallback
[2020-02-14T17:53:19+0100] [ALPM-SCRIPTLET]       EndSection
[2020-02-14T17:53:19+0100] [ALPM] installed xf86-video-nouveau (1.0.16-1)
[2020-02-14T17:53:19+0100] [ALPM] installed vulkan-intel (19.3.3-1)
[2020-02-14T17:53:19+0100] [ALPM] installed vulkan-radeon (19.3.3-1)
[2020-02-14T17:53:20+0100] [ALPM] installed libva-mesa-driver (19.3.3-1)
[2020-02-14T17:53:20+0100] [ALPM] installed libva-vdpau-driver (0.7.4-4)
[2020-02-14T17:53:20+0100] [ALPM] installed mesa-vdpau (19.3.3-1)
[2020-02-14T17:53:20+0100] [ALPM] installed lib32-vulkan-intel (19.3.3-1)
[2020-02-14T17:53:20+0100] [ALPM] installed lib32-vulkan-radeon (19.3.3-1)
[2020-02-14T17:53:20+0100] [ALPM] installed lib32-libva (2.6.0-1)
[2020-02-14T17:53:20+0100] [ALPM] installed lib32-libvdpau (1.3-1)
[2020-02-14T17:53:20+0100] [ALPM] installed lib32-libva-vdpau-driver (0.7.4-6)
[2020-02-14T17:53:20+0100] [ALPM] installed lib32-mesa-vdpau (19.3.3-1)
[2020-02-14T17:53:20+0100] [ALPM] transaction completed
[2020-02-14T17:53:20+0100] [ALPM] running '30-systemd-update.hook'...

A mhwd -li -d --pci shows me:

 NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de

I have a black screen with a movable mouse ...

First of all which desktop environment do you use? Due to the mesa update it seems you tried to fix it with installing and uninstalling drivers. Based on the feedback we got, only free drivers were affected by this. Check what mhwd would offer for you as drivers. On my end it would be some like this:

phil@development ~/ $ mhwd
> 0000:26:00.0 (0300:10de:0fc6) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-440xx            2019.10.25               false            PCI
    video-nvidia-435xx            2019.10.25               false            PCI
    video-nvidia-430xx            2019.10.25               false            PCI
    video-nvidia-418xx            2019.10.25               false            PCI
    video-nvidia-390xx            2019.10.25               false            PCI
    video-nvidia-340xx            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:22:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI

To automatically install nonfree drivers you can do this:

sudo mhwd -a pci nonfree 0300

Journalctl shows me a coredump, but what can I do now?

Feb 14 18:08:57 Laptop systemd-coredump[875]: Process 829 (sddm-greeter) of user 996 dumped core.
                                              
                                              Stack trace of thread 829:
                                              #0  0x00007f1132eb4f25 raise (libc.so.6)
                                              #1  0x00007f1132e9e897 abort (libc.so.6)
                                              #2  0x00007f11332d296c _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
                                              #3  0x00007f1134745139 _ZN13QSGRenderLoop28handleContextCreationFailureEP12QQuickWindowb (libQt5Quick.so.5)
                                              #4  0x00007f1134746e40 n/a (libQt5Quick.so.5)
                                              #5  0x00007f1134747bba n/a (libQt5Quick.so.5)
                                              #6  0x00007f11338bb9dd _ZN7QWindow5eventEP6QEvent (libQt5Gui.so.5)
                                              #7  0x00007f11347d3183 _ZN12QQuickWindow5eventEP6QEvent (libQt5Quick.so.5)
                                              #8  0x00007f11334e9962 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
                                              #9  0x00007f11338b19c2 _ZN22QGuiApplicationPrivate18processExposeEventEPN29QWindowSystemInterfacePrivate11ExposeEventE (libQt5Gui.so.5)
                                              #10 0x00007f11338b1c00 _ZN22QGuiApplicationPrivate24processWindowSystemEventEPN29QWindowSystemInterfacePrivate17WindowSystemEventE (libQt5Gui.so.5)
                                              #11 0x00007f113388ac2c _ZN22QWindowSystemInterface22sendWindowSystemEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Gui.so.5)
                                              #12 0x00007f112c93abac n/a (libQt5XcbQpa.so.5)
                                              #13 0x00007f1131ba139e g_main_context_dispatch (libglib-2.0.so.0)
                                              #14 0x00007f1131ba31b1 n/a (libglib-2.0.so.0)
                                              #15 0x00007f1131ba31f1 g_main_context_iteration (libglib-2.0.so.0)
                                              #16 0x00007f1133542020 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                              #17 0x00007f11334e84cc _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                              #18 0x00007f11334f04d6 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                                              #19 0x0000563d67ec7d72 main (sddm-greeter)
                                              #20 0x00007f1132ea0153 __libc_start_main (libc.so.6)
                                              #21 0x0000563d67ec80ae _start (sddm-greeter)
                                              
                                              Stack trace of thread 830:
                                              #0  0x00007f1132f6d9ef __poll (libc.so.6)
                                              #1  0x00007f113453a630 n/a (libxcb.so.1)
                                              #2  0x00007f113453c2db xcb_wait_for_event (libxcb.so.1)
                                              #3  0x00007f112c939b81 n/a (libQt5XcbQpa.so.5)
                                              #4  0x00007f113330dfc6 n/a (libQt5Core.so.5)
                                              #5  0x00007f1132c674cf start_thread (libpthread.so.0)
                                              #6  0x00007f1132f782d3 __clone (libc.so.6)
                                              
                                              Stack trace of thread 833:
                                              #0  0x00007f1132f6d9ef __poll (libc.so.6)
                                              #1  0x00007f1131ba3120 n/a (libglib-2.0.so.0)
                                              #2  0x00007f1131ba31f1 g_main_context_iteration (libglib-2.0.so.0)
                                              #3  0x00007f1133542020 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                              #4  0x00007f11334e84cc _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                              #5  0x00007f113330ce52 _ZN7QThread4execEv (libQt5Core.so.5)
                                              #6  0x00007f1134315f89 n/a (libQt5Qml.so.5)
                                              #7  0x00007f113330dfc6 n/a (libQt5Core.so.5)
                                              #8  0x00007f1132c674cf start_thread (libpthread.so.0)
                                              #9  0x00007f1132f782d3 __clone (libc.so.6)
                                              
                                              Stack trace of thread 831:
                                              #0  0x00007f1132f6d9ef __poll (libc.so.6)
                                              #1  0x00007f1131ba3120 n/a (libglib-2.0.so.0)
                                              #2  0x00007f1131ba31f1 g_main_context_iteration (libglib-2.0.so.0)
                                              #3  0x00007f1133542020 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                              #4  0x00007f11334e84cc _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                              #5  0x00007f113330ce52 _ZN7QThread4execEv (libQt5Core.so.5)
                                              #6  0x00007f112c807b28 n/a (libQt5DBus.so.5)
                                              #7  0x00007f113330dfc6 n/a (libQt5Core.so.5)
                                              #8  0x00007f1132c674cf start_thread (libpthread.so.0)
                                              #9  0x00007f1132f782d3 __clone (libc.so.6)
Feb 14 18:08:57 Laptop systemd[1]: systemd-coredump@0-874-0.service: Succeeded.

mhwd shows me

> 0000:01:00.0 (0300:10de:0429) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-340xx            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

I want to run with the nouveau driver. Befor this update, it works fine with nouveau.

Then try to reinstall the driver with:

sudo mhwd -a pci free 0300

Also check if any nvidia package is still left on your system, as it may blacklist something.

I did it.

It shows me

> Skipping already installed config 'video-linux' for device: 0000:01:00.0 (0300:10de:0429) Display controller nVidia Corporation Quadro NVS 140M

but after a reboot there is no solution. Black screem witch movable cursor

sudo mhwd --force -i pci video-linux

I did it, but without a solution.

> Removing video-linux...
Using default
Has lib32 support: true                                                                                                                                                                                             
Sourcing /var/lib/mhwd/local/pci/video-linux/MHWDCONFIG                                                                                                                                                             
Processing classid: 0300                                                                                                                                                                                            
Sourcing /var/lib/mhwd/scripts/include/0300                                                                                                                                                                         
Processing classid: 0380                                                                                                                                                                                            
Processing classid: 0302                                                                                                                                                                                            
Prüfe Abhängigkeiten...                                                                                                                                                                                             
:: lib32-mesa benötigt optional lib32-mesa-vdpau: for accelerated video playback                                                                                                                                    
:: libva benötigt optional libva-vdpau-driver: backend for Nvidia and AMD GPUs                                                                                                                                      
:: mesa benötigt optional mesa-vdpau: for accelerated video playback                                                                                                                                                
:: mesa benötigt optional libva-mesa-driver: for accelerated video playback                                                                                                                                         
:: vlc benötigt optional libva-vdpau-driver: vdpau backend nvidia                                                                                                                                                   
:: vulkan-icd-loader benötigt optional vulkan-driver: packaged vulkan driver                                                                                                                                        

Pakete (15) lib32-libva-2.6.0-1  lib32-libvdpau-1.3-1  lib32-libva-vdpau-driver-0.7.4-6  lib32-mesa-vdpau-19.3.3-1  lib32-vulkan-intel-19.3.3-1  lib32-vulkan-radeon-19.3.3-1  libva-mesa-driver-19.3.3-1  libva-vdpau-driver-0.7.4-4  mesa-vdpau-19.3.3-1  vulkan-intel-19.3.3-1  vulkan-radeon-19.3.3-1  xf86-video-amdgpu-19.1.0-1  xf86-video-ati-1:19.1.0-1  xf86-video-intel-1:2.99.917+899+gf66d3954-1  xf86-video-nouveau-1.0.16-1                                                                                                                                                                                                                  

Gesamtgröße der entfernten Pakete:  57,67 MiB                                                                                                                                                                       

:: Möchten Sie diese Pakete entfernen? [J/n]                                                                                                                                                                        
:: Verarbeite Paketänderungen...                                                                                                                                                                                    
Entferne lib32-mesa-vdpau...                                                                                                                                                                                        
Entferne lib32-libva-vdpau-driver...                                                                                                                                                                                
Entferne lib32-libvdpau...                                                                                                                                                                                          
Entferne lib32-libva...                                                                                                                                                                                             
Entferne lib32-vulkan-radeon...                                                                                                                                                                                     
Entferne lib32-vulkan-intel...                                                                                                                                                                                      
Entferne mesa-vdpau...                                                                                                                                                                                              
Entferne libva-vdpau-driver...                                                                                                                                                                                      
Entferne libva-mesa-driver...                                                                                                                                                                                       
Entferne vulkan-radeon...                                                                                                                                                                                           
Entferne vulkan-intel...                                                                                                                                                                                            
Entferne xf86-video-nouveau...                                                                                                                                                                                      
Entferne xf86-video-intel...                                                                                                                                                                                        
Entferne xf86-video-amdgpu...                                                                                                                                                                                       
Entferne xf86-video-ati...                                                                                                                                                                                          
:: Starte post-transaction hooks...                                                                                                                                                                                 
(1/1) Arming ConditionNeedsUpdate...                                                                                                                                                                                
> Successfully removed video-linux
> Installing video-linux...
Using default
Has lib32 support: true                                                                                                                                                                                             
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/video-linux/MHWDCONFIG                                                                                                                                                
Processing classid: 0300                                                                                                                                                                                            
Sourcing /var/lib/mhwd/scripts/include/0300                                                                                                                                                                         
Processing classid: 0380                                                                                                                                                                                            
Processing classid: 0302                                                                                                                                                                                            
:: Synchronisiere Paketdatenbanken...                                                                                                                                                                               
 core ist aktuell                                                                                                                                                                                                   
 extra ist aktuell                                                                                                                                                                                                  
 community ist aktuell                                                                                                                                                                                              
 multilib ist aktuell                                                                                                                                                                                               
Löse Abhängigkeiten auf...                                                                                                                                                                                          
Suche nach in Konflikt stehenden Paketen...                                                                                                                                                                         

Pakete (15) lib32-libva-2.6.0-1  lib32-libvdpau-1.3-1  lib32-libva-vdpau-driver-0.7.4-6  lib32-mesa-vdpau-19.3.3-1  lib32-vulkan-intel-19.3.3-1  lib32-vulkan-radeon-19.3.3-1  libva-mesa-driver-19.3.3-1  libva-vdpau-driver-0.7.4-4  mesa-vdpau-19.3.3-1  vulkan-intel-19.3.3-1  vulkan-radeon-19.3.3-1  xf86-video-amdgpu-19.1.0-1  xf86-video-ati-1:19.1.0-1  xf86-video-intel-1:2.99.917+899+gf66d3954-1  xf86-video-nouveau-1.0.16-1                                                                                                                                                                                                                  

Gesamtgröße der installierten Pakete:  57,67 MiB                                                                                                                                                                    

:: Installation fortsetzen? [J/n]                                                                                                                                                                                   
PrĂĽfe SchlĂĽsselring...                                                                                                                                                                                              
Prüfe Paketintegrität...                                                                                                                                                                                            
Lade Paket-Dateien...                                                                                                                                                                                               
PrĂĽfe auf Dateikonflikte...                                                                                                                                                                                         
:: Verarbeite Paketänderungen...                                                                                                                                                                                    
Installiere xf86-video-ati...                                                                                                                                                                                       
Installiere xf86-video-amdgpu...                                                                                                                                                                                    
Installiere xf86-video-intel...                                                                                                                                                                                     
>>> This driver now uses DRI3 as the default Direct Rendering                                                                                                                                                       
    Infrastructure. You can try falling back to DRI2 if you run                                                                                                                                                     
    into trouble. To do so, save a file with the following                                                                                                                                                          
    content as /etc/X11/xorg.conf.d/20-intel.conf :                                                                                                                                                                 
      Section "Device"                                                                                                                                                                                              
        Identifier  "Intel Graphics"                                                                                                                                                                                
        Driver      "intel"                                                                                                                                                                                         
        Option      "DRI" "2"             # DRI3 is now default                                                                                                                                                     
        #Option      "AccelMethod"  "sna" # default                                                                                                                                                                 
        #Option      "AccelMethod"  "uxa" # fallback                                                                                                                                                                
      EndSection                                                                                                                                                                                                    
Optionale Abhängigkeiten für xf86-video-intel                                                                                                                                                                       
    libxrandr: for intel-virtual-output [Installiert]                                                                                                                                                               
    libxinerama: for intel-virtual-output [Installiert]
    libxcursor: for intel-virtual-output [Installiert]
    libxtst: for intel-virtual-output [Installiert]
    libxss: for intel-virtual-output [Installiert]
Installiere xf86-video-nouveau...
Installiere vulkan-intel...
Optionale Abhängigkeiten für vulkan-intel
    vulkan-mesa-layer: a vulkan layer to display information using an overlay
Installiere vulkan-radeon...
Optionale Abhängigkeiten für vulkan-radeon
    vulkan-mesa-layer: a vulkan layer to display information using an overlay
Installiere libva-mesa-driver...
Installiere libva-vdpau-driver...
Installiere mesa-vdpau...
Installiere lib32-vulkan-intel...
Installiere lib32-vulkan-radeon...
Installiere lib32-libva...
Optionale Abhängigkeiten für lib32-libva
    lib32-libva-vdpau-driver: vdpau back-end for nvidia [ausstehend]
    lib32-libva-intel-driver: back-end for intel cards
Installiere lib32-libvdpau...
Installiere lib32-libva-vdpau-driver...
Installiere lib32-mesa-vdpau...
:: Starte post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
> Successfully installed video-linux

pacman -Q | grep nvidia

Remove any additional installed nvidia driver, as that might blacklist nouveau. In your case look for 340xx packages.

Forum kindly sponsored by