Mesa-git build correctly but "vainfo" and "vdpauinfo" core dump

Due to recent AMD GPU and mesa codec restritions ( which I respect and understand fully ), had to try to activate AMD GPU HW aceleration via installing Manjaro mesa-git package ( via git clone Packages / Extra / mesa · GitLab )
with the codec flags enabled.

But despite everything “looked and build normally” I have not be able to execute both vainfo nor vdpauinfo utils …

Although Both utils report the same error :

manjaro$ vainfo
Trying display: wayland
Trying display: x11
vainfo: …/mesa-22.3.1/src/compiler/glsl_types.cpp:1245: static const glsl_type*
glsl_type::get_array_instance(const glsl_type*, unsigned int, unsigned int): Assertion `glsl_type_users > 0’ failed.
Aborted (core dumped)

Any ideas ?

mesa-git is the bleeding edge of development for Mesa. It can and will break sometimes. It is not recommended to use it on a daily driver machine.

I understand that …

But for a system as :

Device-1: AMD Barts PRO [Radeon HD 6850] driver: radeon v: kernel
Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: radeon dri: r600
gpu: radeon resolution: 1: N/A 2: 1920x1080~60Hz
API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.

That until last weekend were working flawlessy with Manjaro …
What other options do I have ?

Since 3 weeks I nailed it on the door that this change in mesa will make manjaro unusable for the average user with amd hardware.

…wow !

these are your options

Also at a loss I get the exact same error on my old 2008 laptop (Intel CPU and AMD/ATI GPU) - post in other thread here Best way to get h264 accelerated again? - #47 by llhasa.

As a check I quickly installed Manjaro (Mabox - openbox spin but should be exact same repos afaik both on stable branch) on a 2011 laptop (same brand and type) but with an integrated Intel CPU+GPU chipset. Tried building mesa and it built fine with no core dump errors after. Of course it’s not useful on this 2011 laptop as it has no AMD GPU but it didn’t core dump.

For 2011 laptop with integrated Intel CPU+GPU and mesa built from source

Trying display: wayland
Trying display: x11
vainfo: VA-API version: 1.16 (libva 2.16.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Sandybridge Mobile - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc

From lspci -v

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Kernel driver in use: i915
	Kernel modules: i915

Both laptops on manjaro stable branch . Curiously I seem to have lost realtime-privileges on both laptops and despite trying everything I can’t get it back but that’s a separate issue from this thread.

For the meantime I downgraded using pacman -U /var/cache/pacman/pkg/mesa-22.2.3-1.1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/mesa-vdpau-22.2.3-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/opencl-mesa-22.2.3-1-x86_64.pkg.tar.zst

I really hope there is a solution, again any help appreciated.

Just to report , that in my case, I had to switch to the Unstable branch and recompile the mesa-git package and only then I was able to solve the HW accel issue at least in the browser .

Despite still having the “core dump” from both “vainfo” and “vdpauinfo” utils .

Just a small reminder that both in Stable and Testing branches , compiling the mesa-git with the correct flags were not enough …

1 Like

If you want to stay on stable branch, you need the corresponding PKGBUILD for stable branch (as of right now it is mesa 22.3.1-1).

insert the line that include the codecs

     -D microsoft-clc=disabled \
     -D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc \
     -D valgrind=enabled

…and build it.

makepkg -si
1 Like

Thanks @banjo @markmarques both methods worked.