Mesa 21 causes screen tearing

Recently (3rd April) after updating Mesa to 21, not all but many application was unable to render properly, including plasmashell, zoom and systemsettings5, but firefox, dolphin, konki and konsole (last two used transparency) were unaffected. Starting plasmashell from terminal didn’t produced any informative debug statement. I pulled mesa and vulkan-intel 20 from stable and problem was resolved.

I again tried to update today, along with newer update of libva-mesa-driver and mesa-vdpau, but problem persisted.


GPU:  Intel HD Graphics 4400 
Compositor: xrender
GPU driver: i915 

New discovery:
I just notice (while writing this, to find GPU model) the GPU is reported to be llvmpipe (LLVM 11.1.0, 256 bits) in screenfetch, inxi and OpenGL renderer string of glxinfo which used to be (last seen months ago), Mesa DRI Intel HD Graphics 4400 (HSW GT2) (Collected from inxi output on 10 June 2020)

I recently tried some VNC and also using Weylus.

Incredibly enough, the problem is resolved quite soon as I wrote the issue. After writing this I head to weylus repo and read the README, the intel.conf turns off the DRI. Turned on the DRI nad updated and its all fine.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.