MenuLibre parsing error

Menu editor shows: Parsing Errors
The following files have failed parsing by the underlying library, and therefore will not show up in the MenuLibre. Please investigate these problems with the associated file package maintainer

The parsing error is

Exec program 'com.zamaudio.zammulticompx2' has not been found in the PATH

Clicking on the icons- it reads:
[Desktop Entry]

The reason I was in the MenuEditor was that over 100 different programs related to some weird sound equalizer have appeared in my menu since the update last night. For instance typing mo for mouse in the menu search box- now has over 30 “mono-somesound- equalizername” that I have now scroll through to find the mouse or mousepad icon. Same for mi- there are new midi and s shows all kinds of programs that begin with stereo… I wish I could just easily put them in a folder or something!!!

The problem is with the zammulticompx2 (whatever that is? part of zam-plugins) desktop file, not MenuLibre. It can’t find com.zamaudio.zammulticompx2 in /usr/bin/ or elsewhere in your $PATH.

Change this to Exec=ZaMultiCompX2. Might get reverted during next zam-plugins update.

1 Like

Thank you! That fixed it! I’ll try to remember in case it updates again.

(I did not knowingly install any package by that name or using that name.??? My sound on this computer is having a hard time understanding Linux- so I’ll leave it be since last I knew my sound worked.)

See what depends on it:

pacman -Qi zam-plugins | grep 'Required By\|Optional For'

It’s only an optional dependency for easyeffects, so that’s probably it.

pacman -Qi zam-plugins | grep 'Required By\|Optional For'
Required By     : None
Optional For    : easyeffects

Yes!!! And this explains source of another weird issues since the last update which was appearance of 100’s of sound icons shortcuts in my menu, that must have updated as visible. Thank you for your help! Much appreciated!!

Spam plugins? Yeah, it’s a bit ridiculous.

Spam? I didn’t click on ANY of them because my sound was finally working. But if i typed mo to find mousepad over 30 mono-sound related shortcuts showed up I couldn’t just arrow down 2 to get to mousepad. Then S had stereo and mi had all kinds of midi things. I thought ea were modules to the sound program. Spam, huh? Is nothing sacred anymore?

Rhymes with Zam? Get it? :wink:

It was joking in reference to the multiple menu shortcuts most folks will never use.

PS the fix for the menu- was going to menu editor, finding the multimedia category and selecting the hidden option-- for the two culprits that were creating the new sound related shortcuts. Get to menu editor by typing "menu’ into the menu search box. Until today I didn’t know a menu editor even existed.

LOL! I just want to be able to hear more than crackling when trying to watch a video is all…nothing fancy.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.