Menu on desktop not completely visible

2 displays connected with DisplayPorts, with a resolution of 3840x2160. I set the zoom factor to 200% because otherwise, everything is too small for me to read. Now, here’s the issue:

When I right-click on the desktop, I only see the top left quarter of the menu. When I move the mouse over where the rest should be, the pointer acts as if there is more to the menu, but it is not visible. How can I fix this?

Just in case you need it, here is the output of inxi and mhwd

inxi -v7azy

System:
  Kernel: 6.1.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=924095d4-0579-4229-9d54-6fb389299be2 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Cinnamon v: 5.6.4 tk: GTK v: 3.24.35 vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B450M DS3H V2 v: x.x
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: F1
    date: 08/17/2020
Battery:
  Message: No system battery data found. Is one present?
Memory:
  RAM: total: 62.75 GiB used: 2.99 GiB (4.8%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 4x16 MiB
  Speed (MHz): avg: 2400 high: 3800 min/max: 2200/4672 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3800 2: 2200
    3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 3800 9: 2200 10: 2200 11: 2200
    12: 2200 13: 2200 14: 2200 15: 2200 16: 2200 17: 2200 18: 2200 19: 2200
    20: 2200 21: 2200 22: 2200 23: 3800 24: 2200 bogomips: 182137
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2
    sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext
    tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: PNY driver: nvidia
    v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.0 chip-ID: 10de:2484
    class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-1:2 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 driver: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 159 s-size: 613x352mm (24.13x13.86")
    s-diag: 707mm (27.83")
  Monitor-1: DP-4 res: 3840x2160 hz: 60 dpi: 161
    size: 607x345mm (23.9x13.58") diag: 698mm (27.49") modes: N/A
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA GA104 High Definition Audio vendor: PNY
    driver: snd_hda_intel v: kernel bus-ID: 1-9.1:5 chip-ID: 0d8c:000e pcie:
    class-ID: 0300 gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 06:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: C-Media Audio Adapter (Planet UP-100 Genius G-Talk) type: USB
    driver: cm109,snd-usb-audio
  Device-4: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-1:2 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Sound API: ALSA v: k6.1.0-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 953.87 GiB used: 15.67 GiB (1.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Silicon Power
    model: SPCC Solid State Disk size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 9A0
    scheme: MBR
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 953.86 GiB size: 937.82 GiB (98.32%) used: 15.67 GiB (1.7%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 924095d4-0579-4229-9d54-6fb389299be2
Swap:
  Alert: No swap data was found.
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: Micro Star MSI GM20 Elite type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA
    chip-ID: 0db0:0d2e class-ID: 0301 serial: <filter>
  Device-2: 1-6:3 info: Holtek USB-HID Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 1.1 speed: 12 Mb/s power: 100mA
    chip-ID: 04d9:018b class-ID: 0300
  Hub-2: 1-9:4 info: Genesys Logic USB 2.0 Hub / D-Link DUB-H4 ports: 4
    rev: 2.0 speed: 480 Mb/s power: 100mA chip-ID: 05e3:0606 class-ID: 0900
  Device-1: 1-9.1:5 info: C-Media Audio Adapter (Planet UP-100 Genius G-Talk)
    type: Audio,HID driver: cm109,snd-usb-audio interfaces: 4 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 0d8c:000e class-ID: 0300
  Device-2: 1-9.4:6 info: Yubicom Yubikey 4/5 OTP+U2F+CCID
    type: Keyboard,HID,Smart Card driver: hid-generic,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 30mA chip-ID: 1050:0407 class-ID: 0b00
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Logitech Webcam C270 type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Device-2: 3-3:3 info: Logitech 3Dconnexion Space Mouse Pro type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 046d:c62b class-ID: 0300
  Hub-5: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 50.6 C mobo: N/A gpu: nvidia temp: 56 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 379 Uptime: 1h 19m wakeups: 0 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1181 libs: 346 tools: pamac,paru,yay pm: flatpak
  pkgs: 0 Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.24

mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
          video-nvidia            2021.11.04               false            PCI


Warning: No installed USB configs!