Memory leak issue

verbose appears if debug is on

I don’t think I have debug on

Anything I need to provide to help figure out this issue? :slightly_smiling_face:

Have you tried turning off the compositor?

Don’t think it has anything to do with the compositor, also going into suspend can cause lightdm or xorg to grow in size

Try anyway, please. You in top that Xorg and xfwm4 use a lot of memory.
You should also paste /var/log/Xorg.0.log on a pastebin service like

Using 450 Nvidia has mostly fixed it tho if I suspend it still has the issue coming back with 4gb ram usage, have to check if the wierd gpu usage happens

also but still does do it when the computer is running after a while

here is my Xorg.0.log

also xfwm4 doesn’t use that much memory at all just to add

1 Like

I think the memory leaking on my memory and gpu memory and the other lag issues after a while has to do with xfce’s desktop after the 1.14 update because I have been using budgie for a few days and haven’t had any of those issues.

So, you didn’t mention explicitely whethter you tried to disable Xfce’s compositor?

Yes, it didn’t do anything to help with the issues both with ram and especially gpu memory leak which would happen regardless :slightly_frowning_face: :frowning_face:

1 Like

I think this title should be changed to xfce desktop memory leak while using Nvidia driver because I have used a couple different desktops now without any issues.

I was going to make a new topic, but apparently there’s somebody with the same issue. I’m on XFCE too, and I have huge memory leaks at times. I don’t have an NVIDIA GPU so we can rule that out. My issues seem to happen when a combination of wine + discord + firefox are present. I always had memory leaks when I tried to install the .net framework with wine, it couldn’t install it due to a bug, and after some minutes my RAM was filled and it was unusable, only way to get out of that is waiting for the system to kill a memory intensive process or rebooting. Interestingly tho, I managed to take a peak at htop when these things happened and the process using up all the memory is Firefox. Discord is one of the processes that gets closed when memory is full, that’s why I’m throwing it under the bus too.

I managed to circumvent wine’s bug by installing a previous version of it, installing .net framework on a prefix and then reverting to the newest version (5.16). Now I’m using the program I wanted to install, that is MusicBee… and seems to cause memory leaks too. Everything works fine for a bit and then system slows down and it’s unusable… really annoying.

Hmm I see, my issue wasn’t to do with wine as I wasn’t using it when this happens, also really annoying tho haha

It’s most likely discord. Try not running discord and see if you still have a memory leak.

Read my comments above, it wasn’t Discord as it wasn’t even running and would also do it when you suspend. it seems like they have done some updates to fix it I think but now I am having a gpu fell off bus issue but I have no idea if it’s related or some other issue.

I also get fairly substantial firefox leaks when browsing certain, um, “video sites,” but I suspect the issue is probably an unbreak filter on ublock messing with some of the html5 elements on a page and when you manipulate them (say, resizing a video window,) firefox chews through 16GB of ram as if it was candy…although my gpu memory is under control. My fix has been pretty simple, just close the offending tabs and then simply re-load them per ctrl+shift+t. We got a few ff updates recently so I’ll take a closer look when it happens again.

We should also explore the item that we’re all running multihead?

What specs do you have cpu and gpu wise? I feel like 4.14 has been a bit buggy which is unusual for xfce which tests for bugs before release

Me? i5 3320m, Intel HD 4000 and 8GB or RAM.

Here’s my relevant inxi (as of today):

inxi -SMCGAxxxzc0
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: TUF Z270 MARK 2 v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 1301 date: 03/14/2018 
  Topology: Quad Core model: Intel Core i5-7500 bits: 64 type: MCP 
  arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 27208 
  Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: 
  driver: nvidia v: 450.66 bus ID: 01:00.0 chip ID: 10de:1c02 
  Display: x11 server: X.Org 1.20.9 driver: nvidia resolution: 
  1: 1920x1080~60Hz 2: 1920x1080~60Hz s-dpi: 96 
  OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
  Device-1: NVIDIA GP106 High Definition Audio vendor: 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
  Device-2: GYROCOM C&C Fiio E10 type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-4:4 chip ID: 1852:7022 
  Sound Server: ALSA v: k5.8.11-1-MANJARO