Megasync not working

I have a Problem that output megasync won’t open:

Setting QT_SCREEN_SCALE_FACTORS= "DP-3=1.16667;eDP-1=1.16667"
Speicherzugriffsfehler (Speicherabzug geschrieben)

comes from the AUR. Please notify the package maintainer.


Megasync got an update this morning, have you tried the update?

1 Like

no still not working with that 4.3.8-1 version


sudo nano /usr/share/applications/megasync.desktop

Delete: TryExec line

Change: Exec

Exec=env QT_SCALE_FACTOR=1 megasync



bionor commented on 2020-09-07 21:32

I had the segmentation fault as well and I tried this I found on github and it worked for me :slight_smile:

"you can fix this by adding the env variable in the launch file: e.g.: nano /usr/share/applications/megasync.desktop

and then replace “Exec=megasync” with “Exec=env QT_SCALE_FACTOR=1 megasync”

remove the TryExec line and save. you can then copy the megasync.desktop launch file to your autostart folder, e.g.:

cp /usr/share/applications/megasync.desktop ~/.config/autostart/

if you don’t want to vi/nano, you can use sed, e.g.: sudo sed -i -r ‘/^TryExec/d;s|^(Exec=).*$|\1env QT_SCALE_FACTOR=1 megasync|g’ /usr/share/applications/megasync.desktop

and then copy the changed file to your autostart folder.

this worked even with the latest deepin-qt5integration installed."

jpggsb commented on 2020-09-06 20:50

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.