Megasync not compile

Hi guys,

Tryin to compile megasync, but get only error:

In file included from /usr/include/string.h:519,
from /usr/include/qt/QtCore/qarraydata.h:44,
from /usr/include/qt/QtCore/qbytearray.h:46,
from /usr/include/qt/QtCore/qstring.h:50,
from /usr/include/qt/QtCore/qcoreapplication.h:44,
from /usr/include/qt/QtWidgets/qapplication.h:44,
from /usr/include/qt/QtWidgets/QApplication:1,
from ./MegaApplication.h:4,
from platform/linux/ExtServer.h:4,
from platform/linux/ExtServer.cpp:1:
In function ‘char* strncpy(char*, const char*, size_t)’,
inlined from ‘const char* ExtServer::GetAnswerToRequest(const char*)’ at platform/linux/ExtServer.cpp:213:20:
/usr/include/bits/string_fortified.h:106:34: warning: ‘char* __builtin_strncpy(char*, const char*, long unsigned int)’ specified bound 1024 equals destination size [-Wstringop-truncation]
106 | return __builtin___strncpy_chk (__dest, __src, __len, __bos (__dest));
| ^~~~~~~~~~~~~~
make[1]: Leaving directory ‘/var/tmp/pamac-build-marcus/megasync-nopdfium/src/MEGAsync/src/MEGASync’
make: *** [Makefile:47: sub-MEGASync-make_first] Error 2
==> ERROR: A failure occurred in build().

That happens with the packages from AUR:

Before that I had nodpfum version installed, but was unable to run it due to this error:
megasync: error while loading shared libraries: cannot open shared object file: No such file or directory

So I’ve deleted and tried to compile, but attempt was not very succescful.

Any cure to this?


Have you updated your system?

sudo pacman-mirrors -f && sudo pacman -Syyu

I also just tried to build the package (megasync-nopdfium) and got the same error.
Both megasync-nopdfium and megasync pull from the same git repo, so it’s not surprising that they both don’t work.

However, if you look at the megasync AUR package on the AUR site, there are some steps there on how to create a specific crashhandler.patch and updating the PKGBUILD file. There are reports that it compiles successfully afterwards.