Megasync needs the lib "libraw 0.20"

Hello,

Megasync can not start, because the lib "libraw 0.20" is missing in the Manjaro repos. But it is in Arch repos.

I am waiting for the lib update in the Manjaro repos. :slight_smile:

Thanks!

1 Like

Hello,

That version is in testing and unstable branches, not missing. The stable branch has the 0.19.5 version.
Since megasync is an AUR package, the packager made sure it lines up with the Arch repositories.

Moved to #technical-issues-and-assistance:aur

Welcome!

1 Like

Hello, you need to rebuild AUR packages when there is a .so library version bumps

I downloaded and installed Megasync arch package from Mega's original website.
https://mega.nz/sync

Then Pamac added Megasync automatically.


I use it better than AUR. Megasync supports Arch Linux well

1 Like

The AUR version doesn't build because it requires libpdfium:

There is as alternative megasync-nopdfium, which builds perfectly.

The package on the official website is made with Arch Linux in mind, not Manjaro. While it does work most of the time (this is what I do on my systems), it can become a problem when Arch Linux bumps libraries that Megasync depends on while Manjaro has not made the upgrade yet in the branch you are using.

So, what you could do is revert the megasync package to a previous version you had, if you still have the previous one somewhere in your cache (by default, /var/lib/pacman/pkg). Personally, I downgraded the megasync package from 4.3.3-8 to 4.3.3-5. Once it is done, Pamac will annoy you for a while because there's an update available, but just leave it like that until you have an upgrade for libraw as well.

1 Like

For me megasync gave the same error, I just recompile it from AUR and no problem. And I am using megasync with libpdfium (libpdfium-nojs 4103.r0.daabea6ba6-1).

According Megasync support, they still use libraw 0.19 while Arch moved forward to libraw 0.20.
But Manjaro still use libraw 0.19 and still Megasync doesn't work even if downloaded Megasync from their site.

Hi there,

Archlinux recently upgraded to libraw 0.20, but our installer package still requests 0.19.
Other MEGA users have reported that if they create a symlink, this appears to solve the problem.

Could you please try the same?

Kind Regards,
MEGA Support

Try again. :crazy_face:
@xircon posted another fix here.

1 Like

You need to install a package that provide libpdfium, see Can't update megasync


Moving to third party since is used developer's build

1 Like

Thanks..it works finally.

1 Like

Forum kindly sponsored by