Mediatek WI-FI mt7921

I installed Manjaro Qonos KDE on new pc
Love Manjaro, new user

Problem, with wifi card: only bluetooth working on kernel 5.15

Installed kernel 5.16rc4 (latest I get in Settings Manager…no luck either

Any idea please? (internet on usb tethering on phone)

Hi @giukas, and welcome!

Since 5.15 is set to be the next LTS, and will be supported until at least October 2023, after which I’m sure there’ll be a new one, how is that a problem? What do you need, or want to fix if everything’s working?

Thank you :blush:

I can see the WiFi card on lspci, but driver not loaded.

Had the same problem on Ubuntu, they say to update firmware. I moved to Manjaro because I wanted too long time. But wifi card still not working

Not dual booting

I want to use the WiFi

OK, but I still fail to get it. How is it a problem if it works in 5.15? I get the idea the card is still relatively new, which might explain why it doesn’t work on all other kernels, especially considering 5.15 is new, and the others are older kernels.

If you want, for whatever reason, to use an older kernel, have you tried 5.10 or even 5.4? Both of which are also LTS.

For this card it was recommended to install 5.12 +

But still not able to load the driver

I must be daft because I still don’t understand the problem.

5.15 is greater, more than, higher than 15.12

Yes it is

I stated clearly the card driver , mt76, is not loading
So can’t use wifi

I did modprobe mt76, nothing happens

For some reason the driver is not loading

Can you help?

My most humble of apologies, I don’t know what happened, but I somehow understood it as it works, and that’s s problem. So was confused, and not only a little bit.

If the module is loaded, I don’t know what to do. You can check with :point_down:

sudo modinfo mt76

For example:

$ sudo modinfo mt76
[sudo] password for mirdarthos:
filename:       /lib/modules/5.15.7-1-MANJARO/kernel/drivers/net/wireless/mediatek/mt76/mt76.ko.xz
license:        Dual BSD/GPL
srcversion:     D88003E2A4B8FF1776BCD35
depends:        mac80211,cfg80211
retpoline:      Y
intree:         Y
name:           mt76
vermagic:       5.15.7-1-MANJARO SMP preempt mod_unload
sig_id:         PKCS#7
signer:         Build time autogenerated kernel key
sig_key:        5B:80:45:EC:95:D5:96:D2:50:7A:51:26:10:F6:5F:1B:66:8B:CD:90
sig_hashalgo:   sha512
signature:      30:65:02:30:14:9D:EF:5F:C0:82:2E:7E:A3:79:61:F0:A6:38:32:87:

no worries, probably I didn’t explain myself clearly )))

this is the outcome

[sudo] password for gianluca:
filename: /lib/modules/5.16.0-1-MANJARO/kernel/drivers/net/wireless/mediatek/mt76/mt76.ko.xz
license: Dual BSD/GPL
srcversion: 339DBB53D4BD85BF7C6C3E1
depends: mac80211,cfg80211
retpoline: Y
intree: Y
name: mt76
vermagic: 5.16.0-1-MANJARO SMP preempt mod_unload
sig_id: PKCS#7
signer: Build time autogenerated kernel key
sig_key: 14:1E:C9:05:3C:A0:F3:DF:CB:36:00:D3:CD:A9:31:76:DF:8B:41:E4
sig_hashalgo: sha512
signature: 30:65:02:31:00:C6:C1:EB:27:8D:E5:F7:35:54:04:C8:31:86:AD:BA:

for info…
I’m not a super tech guy with linux although I have been using it for long. It’s the 1st time I have a problem with drivers plus I’m coming from ubuntu based distros

Well, the driver seem to be loaded, so I hate to say, or even suggest it, but it seems there is something wrong with the wireless card. Especially since you mentioned the bluetooth part is working…so it looks like the driver is working.

Have you tried testing it on another computer? Preferably another Linux one? This should confirm/deny a software or hardware issue…

lspci -k
the driver doesn’t seem working

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
DeviceName: Onboard LAN Brodcom
Subsystem: Realtek Semiconductor Co., Ltd. Device 0123
Kernel driver in use: r8169
Kernel modules: r8169
03:00.0 Network controller: MEDIATEK Corp. Device 0608
Subsystem: MEDIATEK Corp. Device 0608
04:00.0 Ethernet controller: Intel Corporation Ethernet Controller I225-V (rev 01)
Subsystem: Intel Corporation Device 0000
Kernel driver in use: igc
Kernel modules: igc

don’t have another pc :frowning_face:

It seems to be working, according to from what I can see there. I mean, the adapter is recognized as a Mediatek one.

And, AFAIK if it was fine, then it would have shown two Mediatek devices:

  • One for the bluetooth; and
  • one for the wireless networking.

a guy seemed to have the same problem but he sorted it


I’ve spent 5 days on it))))) no luck


Well, sadly I’ve got to be of now, will keep on pondering about the problem.

P.S.: Provide the link that you found in the first post, perhaps there’s something someone can see there. This’ll be helpful for the link: [HowTo] post screenshots and links

Hope you manage!

the card works in windows

which link do you mean?

What I meant was, I had to be off - sorry for the typo - my mistake.

Could you post the output of

lshw -C network


ip link


modinfo mt7921e

I believe I found the Arch Linux thread you were taking about, but I’m afraid that doesn’t help ME as I’m not technical enough, at least not yet, to understand it.

P.S.: In the future, when providing terminal output, paste the output text and wrap it in 3 backticks (```). Like this:

pasted text

This will just cause it to be rendered like this:

Felis suspendisse
massa enim tortor bibendum
aliquam aliquam nec
adipiscing massa
suspendisse diam
vivamus sit.

instead of like this:

Felis suspendisse massa enim tortor bibendum aliquam aliquam nec adipiscing massa suspendisse diam vivamus sit amet tristique lorem arcu tortor mi bibendum tincidunt elementum ac.

increasing legibility and making it easier for those trying to provide assistance.

Alternatively, paste the text, select it all, and press the </> button in the toolbar of the editor.

At this moment, I honestly have no idea what else to try, I’m kind of shooting in the dark here. (There’s a reason I don’t like wireless, and this is i88t. Mostly. I think. :thinking:


I see lots of problems with this card on the internet, so there are known problems. Hopefully we can just wait it out.

Edit 2:

Is the linux-firmware package installed? Check by running:

pamac search linux-firmware                                                                                                                                                                                              

in the terminal. For example:

$ pamac search linux-firmware                                                                                                                                                                                              [Installed] 20211027.1d00989-1            core
Firmware files for Linux

The [Installed] flag shows it’s…well…installed. :wink:

If it’s not, you can install it with:

pamac install linux-firmware

Edit 3:

After some more reading, I came across this page:

Where the first post states:

I am not on linux but I spent hours on this problem on a brand new Asus gaming laptop and I wish I could credit the original poster but it was a video that led me to this solution:

Hold down the power button for a full 60 seconds and it resets your bluetooth and wifi then restart. Completely fixed the issue for me.

Don’tcha hate when it turns out to be so easy?

So it might be worth it to give that a try as well.

1 Like

Hi @giukas,
I just ran into the same problem with an ASUS Vivobook.
I used the USB thetering on my phone to install networkmanager (sudo pacman -Sy networkmanager) . After a reboot wifi was available.
Hope this helps.

Kernels 5.15 / 5.16 already support this wireless module, though probably with initialization bugs. See my other post where I show how to get it running on 5.15.
PS: I don’t know how reinstalling networkmanager could’ve helped.