mcomix broke after latest update on testing branch

xfce
#1

Hi!

I am new here so I apologize in advance if I posted this in wrong forum. I tried to reply to the update topic for the latest update on Testing branch but I couldn’t find the reply-button (perhaps a limitation as I just registered on the forum)

Basically, when running mcomix from terminal, this is the output:

[user@user-ryzen ~]$ mcomix 
Traceback (most recent call last):
  File "/usr/bin/mcomix", line 11, in <module>
    load_entry_point('mcomix==1.2.1', 'console_scripts', 'mcomix')()
  File "/usr/lib/python2.7/site-packages/mcomix/run.py", line 206, in run
    assert PIL.Image.VERSION >= '1.1.5'
AttributeError: 'module' object has no attribute 'VERSION'

Kernel version: 4.19.33-1-MANJARO

Thank you in advance.

Unable to run Mcomix
Unable to run Mcomix
#2

This project hasn’t been updated for 3 years (latest version- 1.2.1 2016 February ) Most likely python rebuilds broke it. I will ping @jonathon . Hopefully he will clarify this situation

#3
$ pacman -Si mcomix
Repository      : community
Name            : mcomix
Version         : 1.2.1-4
Description     : A user-friendly, customizable image viewer specifically designed to handle comic books
Architecture    : any
URL             : http://sourceforge.net/projects/mcomix/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : pygtk  python2-pillow  xdg-utils  python2  desktop-file-utils  hicolor-icon-theme  python2-setuptools
Optional Deps   : libunrar: for rar compressed comics
                  mupdf-tools: for pdf comics
                  p7zip: for 7zip compressed comics
Conflicts With  : comix
Replaces        : comix
Download Size   : 471.21 KiB
Installed Size  : 2734.00 KiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Fri 09 Nov 2018 21:02:58 GMT
Validated By    : MD5 Sum  SHA-256 Sum  Signature

This is an Arch package.

You can try rebuilding it to see if that helps.

1 Like
#4

Thank you very much!

I am looking in pamac and the mcomix seems to be installed from community repository? Version is 1.2.1-4.

#5

Sorry, my misstake, will try rebuilding it.

1 Like
#6

Oops my bad ,forgot about minor versions. Probably patches to assure that it works properly.

#7

https://bugs.archlinux.org/task/62242?project=5&string=mcomix
Issue reported here.Guess we will have to wait?

2 Likes
#8

If you need a comic reader in the meantime (I know I couldn’t live without one), I use YACReader, which also includes a database/manager system, YACREader Library. There is also Peruse and if you are on KDE, Okular does a bang up job for reading single issues (no database/mgr system though.) :man_superhero:

1 Like
#9

Thank you for the recommendation, will have a look. For now I simply extracted image files from the CBZ/CBR archives.

1 Like
#10

From the bug report: “Downgrade to pillow 5.4.1-1 fixes the Problem.”

downgrade python2-pillow

If you have downgrade installed. If not, install it.

#11

The problem is that we only have 5.4.1.1. (I checked via pamac couple minutes ago)

#12

Using the command…

downgrade python2-pillow

…will list every version going back quite some time. I’m running Arch so I cannot tell you what, exactly, that command will list in Manjaro. I was showing you what the bug report suggested as a viable workaround. What you do (or not) with it is up to you. But, for example, on my machine, it lists the following…

[c00ter@baked ~]$ downgrade python2-pillow
Available packages:

   1)  python2-pillow    4.0.0  1  x86_64  (remote)
   2)  python2-pillow    4.0.0  2  x86_64  (remote)
   3)  python2-pillow    4.0.0  3  x86_64  (remote)
   4)  python2-pillow    4.1.0  1  x86_64  (remote)
   5)  python2-pillow    4.1.0  2  x86_64  (remote)
   6)  python2-pillow    4.1.1  1  x86_64  (remote)
   7)  python2-pillow    4.2.0  1  x86_64  (remote)
   8)  python2-pillow    4.2.1  1  x86_64  (remote)
   9)  python2-pillow    4.3.0  1  x86_64  (remote)
  10)  python2-pillow    5.0.0  1  x86_64  (remote)
  11)  python2-pillow    5.1.0  1  x86_64  (remote)
  12)  python2-pillow    5.1.0  2  x86_64  (remote)
  13)  python2-pillow    5.2.0  1  x86_64  (remote)
  14)  python2-pillow    5.2.0  2  x86_64  (remote)
  15)  python2-pillow    5.2.0  3  x86_64  (remote)
  16)  python2-pillow    5.3.0  1  x86_64  (remote)

  •  17)  python2-pillow    5.4.1  1  x86_64  (remote)
  •  18)  python2-pillow    5.4.1  1  x86_64  (local)
  •  19)  python2-pillow    6.0.0  1  x86_64  (remote)
  •  20)  python2-pillow    6.0.0  1  x86_64  (local)

select a package by number:

Downgrade and Pamac are not the same thing.

1 Like
#13

I mean if user installed mcomix trough pamac it pulled dependency python2-pillow (version 5.4.1.1) right? If so why error still persists? If not which version of pillow was installed.

#14
  • I run Arch.
  • I don’t use Pamac.
  • Try downgrading to an earlier version. Or not. It’s your system. (A/K/A Aint freedom great!)
1 Like
#15

Gotcha. :+1:

#16

There’s a reason for Testing in Manjaro, and my hat is always toffed to those brave enough to use it. :slight_smile:

1 Like
#17

The dependency is not for any particular version of python2-pillow.

Just downgrade to 5.4.1-1 and it will work again.

1 Like
#18

First of all I am gonna point out the fact that I am super dumb. The title literally said TESTING BRANCH and yet I (the stable branch user) assumed that we didn't have version 6.0.0 yet.Sorry for all confusion everyone @c00ter @jonathon @veroslav .

1 Like
#19

I got tired of waiting for mcomix to update.

Here is the solution taken from https://bugs.archlinux.org/task/62242. Line 206 in /usr/lib/python2.7/site-packages/mcomix/run.py needs an edit.

from:
assert PIL.Image.VERSION >= '1.1.5'
to:
assert PIL.Image.__version__ >= '1.1.5'

Here is the sed command to do this. Tested working with mcomix 1.2.1-4 and python2-pillow 6.0.0-1.

sudo sed -i "s:assert PIL.Image.VERSION:assert PIL.Image.__version__:g" /usr/lib/python2.7/site-packages/mcomix/run.py

3 Likes
#20

If you can format that as a diff to the PKGBUILD I'll build and upload to unstable.

Otherwise I'll try and do it at some point.