MATE Tweaks bug


#1
  • What device are you using?

Raspberry Pi 3 model B

  • What edition of Manjaro-ARM is installed? (eg minimal, server, etc.)

MATE

  • When did you last run updates and reboot?

Fresh install. There were no updates when I checked

  • What package contains the bug?

MATE Tweaks

  • Describe the bug the best you can. What where you doing when the bug happened?

I was checking the difference in appearance between Fedora and GNOME 2. When I switched to Fedora I couldn’t switch back to GNOME 2. I’ve tried rebooting the system and Fedora was still there. It will act as if I switched back but nothing changes.

  • Any workarounds or known fixes?

None that I know of.


#2

Not really sure what you are saying here.
Do you have Manjaro ARM installed, or Fedora?
Gnome2 is not present in any of them as far as I know. Especially not in Manjaro.
To switch OS, you need to switch/reflash the SD card.


#3

I have Manjaro-ARM MATE edition installed.

It’s under System>Preferences>Look and Feel>MATE Tweak

From there, go to Panel. It gives you the option for either the GNOME2 or Fedora UI.

Here’s a picture. It only switches to the Fedora layout and not the GNOME2 layout(it was originally set to GNOME2).

Okay seems the update tool didn’t show anything last time but now I have a list of things to update. Maybe that’ll fix it. I will update and let you know if that works.


#4

Else maybe @grayjack knows. He did the MATE edition back then.


#5

Oh okay yeah that may work. I’m not sure but I checked the md5sum and it was incorrect. After multiple downloads the result was still the same. Is there maybe an issue with the link or is it just me? Is @GrayJack still working on the MATE edition?


#6

No, he “resigned” because of time constraints. So there won’t be a new MATE image until someone makes it.


#7

Oh I see. That’s too bad…I liked the speed of MATE but there were a bit too many bugs I found after playing around with it. How is LXQT fairing? I can’t really find any information online about Manjaro-ARM since it’s been brought back to life.


#8

good morning:

I remember the problem of the MATE Tweaks, in fact during the time that I had mate it happened that the configuration of the original panel of manjaro was lost, or if it was changed to mutini or fedora or gnome it did not remember the configurations of the panel, for that reason it always kept the configuration with another name different from the one that appears in mate Tweaks, (my fedora, original manyaro, gnome2.0 … martini instead of mutini … as you like da =)

My experience at this desk was the best I’ve seen of manjaro, I recommend that desk (mine xfce now)

(you can use timeshift also to save the hidden settings of the home)

Excellent Mate


#9

Good afternoon! Haha

Thanks for the info, but I actually just switched to LXDE as it was more up to date than MATE. I actually didn’t realize MATE had been dropped as far as support and updates go. So far I’m really liking it but now I can’t connect to the internet :sweat_smile:.

I didn’t see an XFCE version for the raspberry pi. Is there one that’s still supported?


#10

No.
The currently supported editions for the raspberry pi are:
Minimal
LXQT

Other DE’s can of course be installed like normal, which I guess is what you did with LXDE.


#11

Oops, sorry I meant LXQT, not LXDE. I’m not quite that advanced YET haha. I’m learning as I go actually. I’m not able to open up network settings on LXQT. It’s acting as if nothing is installed there or it’s a broken link. Is there a quick fix for this?


#12

Yeah, the current release of LXQT does not have a network manager GUI installed.
The next release will have CMST installed and active.

You can install CMST with the following command:
sudo pacman -S cmst

After that you can launch it from the menu.


#13

Thank you! I will try this out in a bit. This won’t mess up the update when you add it?


#14

it shouldn’t. But it’s recommended to disable Network Manager service when enabling cmst. :slight_smile:


#15

Okay and which terminal do I use? I saw like 3 or 4 different ones to choose from. Thank you for all the help! Also, after disabling Network Manager, do I then proceed to uninstall the software? It would no longer be needed, correct?


#16

qterminal is a full emulator.

Correct. As long as CMST works networkmanager is no longer needed.


#17

Perfect! I will follow your instructions once I get home! Thanks again!