Matcha-gtk-theme doesn't work for GTK3-Apps all of a sudden

Hi
it's not an important ticket, but jut wanting to now:
Can it be that I have a wrong version of matcha-gtk-theme on my system?
When I do a neofetch I get this output:

Compared it with the current Manjaro xfce, and there it says:
Theme: Matcha-dark-sea [GTK2/3].

I have matcha-gtk-theme:

local/matcha-gtk-theme 20200509-1
A flat design themes for GNOME, MATE, Openbox, Unity, XFCE, Budgie

installed.

But I am also not offered an update.

~Seantum

Hello,

well, set the gtk3 applications to use Matcha instead of Adapta ... there is no issue with the Matcha theme version.

Uhm, stupid question: how would I do that?

Not quite into how awesome WM works, but probably in your XFCE settings you just have to change the Style in Window Manager, or maybe simply is an issue on how neofetch gathers some information about the themes ...

image

No Adwaita on my end :slight_smile:

1 Like

I have Adapta-Nokto-Eta-Maia installed.
Checked the xfce-settings, there matcha is chosen, also in Kvantum.
Checked my awesome-config-files: nowhere Adapta-Nokto-Eta-Maia. Not in rc.lua, nor in theme.lua.

EDIT: -OK, I haven't; But I can choose it form my xfce-settings. Weird... / Oh Adapta-Nokto-Eta-Maia is part of adapta-maia-theme. - So it is installed (I used awesome iso 18 for installation, and there the old themes seem to be still on).

Yes, you're right, it maybe a bug in neofetch
in my xfce-edition (wihtout awesome) it also shows now adwaita for gtk3, like it is the case with you.

1 Like

Or maybe that is the fallback theme ? I will have to investigate this a bit. On KDE Plasma i have no redundant information about another theme in neofetch

1 Like

I've found out what might be the problem:
It seems that all gtk3-apps don't use the matcha-theme.
Only the GTK2 Apps. -

How can I fix this?

One way would be to install lxappearance and use that to set your gtk themes.

1 Like

Good news first, it shows correctly in neofetch now.
Bad news, my icons are still gone.
Will post screenshot later.
(haven't rebooted yet though. - only started awesome wm with the shortcut)

I think you can also set your icon set through lxappearance

Yes, just did that.
But why do I need lxappearence for that and it doesn't work with xfce built-in appearence in settings?
(awesome uses a very minimal version of xfce4 desktop in Manjaro)

I mark this solved here. - My problem seems to relate to awesome itself. in rofi I have all the icons, but not in the freedesktop-menu.
I only realized when I saw that shutdown, hibernate etc are gone.

Forum kindly sponsored by