https://manjaro.kurdy.org is back an issue of VPS provider. It took the supplier several hours to detect and repair…
this service crashes or fails for every second run for me also.
× archlinux-keyring-wkd-sync.service - Refresh existing keys of archlinux-keyring
Loaded: loaded (/usr/lib/systemd/system/archlinux-keyring-wkd-sync.service; static)
Active: failed (Result: exit-code) since Tue 2025-01-28 12:20:22 EET; 4 days ago
Duration: 21.153s
Invocation: 508160b99c894d8b9aa921cc2bef889d
TriggeredBy: ● archlinux-keyring-wkd-sync.timer
Process: 757409 ExecStart=/usr/bin/archlinux-keyring-wkd-sync (code=exited, status=1/FAILURE)
Main PID: 757409 (code=exited, status=1/FAILURE)
jaan 28 12:20:22 Zen systemd[1]: archlinux-keyring-wkd-sync.service: Scheduled restart job, restart counter is at 3.
jaan 28 12:20:22 Zen systemd[1]: archlinux-keyring-wkd-sync.service: Start request repeated too quickly.
jaan 28 12:20:22 Zen systemd[1]: archlinux-keyring-wkd-sync.service: Failed with result 'exit-code'.
jaan 28 12:20:22 Zen systemd[1]: Failed to start Refresh existing keys of archlinux-keyring.
Maybe it’s not set up correctly? Maybe the restart delay 5m is too short? especially for a service that’s supposed to be run every 5 days? … why not make the restart 1h? 1d? so whatever ailment was possessing the mirror in question should be surely gone by then?
Can you check your journal and determine which key is causing problems?
An earlier thread, Problems with keyring, noted a problem specifically with andrew@archlinux.org. As described in that thread, this key can be safely removed.
Thank you! Exactly that was problem ![]()