Manuelle Lüftersteuerung

gnome

#1

Hallo, da ich Manjaro 18 erst vor drei Tagen auf meinem Thinkpad T420s installiert habe, kenne ich mich mit der Distro nicht so gut aus. Ich habe knapp zehn Jahre Ubuntu verwendet. Jetzt meine Frage:
Wie kann ich die Lüftersteuerung verbessern? Mein Lüfter läuft fast immer mit 4000 RPM. In ubuntu hatte ich thinkfan installiert und das war wunderbar. Wie kann ich das Programm in Manjaro installieren? Über Pacman kann ich es jedenfalls nicht einbinden und alle weiteren Wege sind mir noch unbekannt.


#2

thinkfan scheint es im AUR zu geben.

https://aur.archlinux.org/packages/thinkfan/

Bevor du das AUR verwendest, solltest du dich ein wenig über das AUR informieren. Besonders was du machen musst um es verwenden zu können.

https://wiki.manjaro.org/index.php?title=AUR
https://wiki.archlinux.org/index.php/Arch_User_Repository


#3

Thanks. I have thinkfan installed. But i am worry, because if i see in the terminal, that the status is “inactive”

**Result for** systemctl status thinkfan.service       
                     
   thinkfan.service - simple and lightweight fan control program
   Loaded: loaded (/usr/lib/systemd/system/thinkfan.service; enabled; vendor preset: disa>
   Active: inactive (dead) since Sun 2018-12-02 12:44:20 CET; 10min ago
 Main PID: 12725 (code=exited, status=0/SUCCESS)

#4

Das bedeutet thinkfan läuft gerade nicht. Du kannst nun anfangen im journal zu schauen ob es irgendwelche Meldungen gibt die darauf hindeuten warum das passiert ist.

Du könntest auch einfach mal versuchen thinkfan im Terminal zu starten, vielleicht mit -n um zu schauen ob es irgendwelche Meldungen gibt.


#5

Ich habe thinkfan mit -n gestartet, aber die Meldung ist immer noch da: Active: inactive (dead).
Ich habe keine Idee mehr.


#6

Das wird sich auch nicht ändern indem du im Terminal thinkfan manuell startest. Es ging mir nur darum, dass du ausprobierst ob thinkfan funktioniert. Ich habe keine Thinkpad deshalb kann ich es nicht ausprobieren, aber ich könnte mir vorstellen das im Terminal thinkfan mit sudo gestartet werden müsste.

Wenn es im Terminal funktioniert, dann kann man schauen warum der systemd service ausgegangen ist.


#7

Ok, hatte auch sudo davor gesetzt.
Selbst wenn ich den Service mit
systemctl enable thinkfan.service
starte, dann kommt immer die Meldung, das der Service nicht aktiv ist.

Wenn ich den Service mit

sudo systemctl start thinkfan

starte, dann ist thinkfan aktiv!


#8

Diese Befehl start den Service nicht. Er wird nur “enabled” was bedeutet bei einem Boot automatisch gestartet.

systemctl start thinkfan.service

oder

systemctl enable --now thinkfan.service

würde den Service sofort starten. Wobei “enable” eigentlich nur einmal verwendet werden muss. Danach besser einfach start verwenden.


#9

Hallo manubu,
habe auch kein Thinkpad, aber wenn ich das lese
https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_T420#Fans
scheint mir das blosse Installieren noch nicht auszureichen, sondern es muss noch ein wenig konfiguriert werden, bevor dann der Dienst mit
sudo systemctl enable --now thinkfan
eingeschaltet und gestartet werden kann.

viele Grüße gosia


#10

Danke gosia für den Hinweis. Das ist absolut korrekt. Diese Schritte hatte ich auch bereits im Vorfeld gemacht.


#11

Hallo manabu,
tja, da weiss ich dann auch nicht, woran es noch hängt. Wie xabbu schon schrieb, könnte da eventuell ein Blick ins Journal weiterbringen. Vielleicht
journalctl -u thinkfan.service
oder
journalctl -p err..alert
Wie ich gerade sehe, gibt es sogar eine eigene Seite für Lenovo ThinkPad T420s
https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_T420s
aber die hast Du bestimmt auch schon studiert.

viele Grüße gosia


#12

Ich danke Euch für die Unterstützung.