Manjaro's Driver Updater left device practically unusable

Hello there, a while back I installed manjaro on my computer alongside windows, due to the fact that it is very old (dell optiplex 755).

Before I get on to what happened, here are some specs:
GPU: Intel Q35 Express chipset family
CPU: Intel Dual-Core E5400 at 2.70GHz
RAM (don’t think it makes a difference but): 4gb
And lastly, I have 64 bits.

I kept running into the error GLXBadFBConfig when trying several apps, specially when using wine, so after I looked up online, I saw that it was likely a driver issue not being installed propperly and thus having an old opengl version. That made sense, specially considering that again, I’m running old hardware.

So, I searched something around the lines of: “manjaro opengl update” or something and came across the “Configure Graphics Cards” (can’t include links or hyperlinks, sorry). The “Overview” section of the page contains this text:

For Beginners, it is recommended to use “Hardware Detection” in [Manjaro Settings Manager] to change or install new graphics drivers.

So, since I don’t really know a lot about hardware in general, I decided to try it out.
This is where the problem began, I saw that 2 drivers weren’t installed, one of them being linux-vesa and the other one I forgot.
I installed them both manually before I realized that there’s a button that installs the open-source updates automatically, so after that I clicked that button.
Then, I hit log off so the changes would apply, and to my surprise, it had installed software that was way too new for my computer, leaving the device practically unusable.

I am unable to provide a photo of the effect it left behind, but half the screen is obstructed. I might be able to provide a recreation of the effect if needed but I don’t think it’d be needed, specially when I’m not looking for a workaround of some sorts so I don’t have this issue: I’m looking to downgrade drivers

So - I’m pretty sure there’s a way to downgrade, but I don’t know how. How can I downgrade my video drivers? And, is there a way to proove if this was a mistake on my end or the system’s end?

I apologize if I’ve missed some things or spelt things terribly as I’m not native and I don’t really understand this topic either.

Also, if I have to reinstall manjaro (seems like easiest solution but the least practical one) I’m okay with it as I’ve been using it for less than a week, and haven’t started anything super important yet.
Thanks, Teo.

Welcome to the forum! :wave:

Please post your system info as outlined here:

Also please post the output of:

mhwd -li

Hello! Thanks for the welcome,
Is there a way to boot into a command line without opening the terminal after logging in? It’s kind of awkard to use the computer with half of the screen not visible

I still haven’t tried since it’s late for me, so I can do tomorrow.
Thanks anyways!

If booting with a live ISO works, you can boot with it, enter a chroot environment, and get the info from there. If that’s the case:

  1. Boot from live ISO into live ISO environment.
  2. Open a terminal and enter the chroot environment:
manjaro-chroot -a

(If prompted, you should use 0 to enter the correct chroot environmenrt. In theory anyway.)

  1. If successful you will now be able to run those commands as if you were on your actual installation. But be careful, as you are now using your actual machine’s installation as root, so this has the possibility of doing lasting damage.

Hello, I’d like to update on the fact that yes, I am still semi-active looking in this.
I’m kinda struggling since I apparently don’t have a working pendrive, I’ll post the output of the command as soon as I can.

Hello again! Finally got a live USB running with rufus, heres the command of mhwd -li

Installed PCI configs:`

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI
        video-vesa            2017.03.12                true            PCI
 video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

Also, I apologize for not being able to put the symbols correctly, I accidentally set the keyboard to another language at boot, whoops!

Thanks for being patient while I was getting a live USB working.

Did you follow @Mirdarthos’s instructions above before running that command? We need to know what’s actually installed on your system.

Please also post your system details:

inxi -Fazy

Yes, if I didn’t use chroot it just would throw multiple errors at me.

If this is the device details I probably dont need to use chroot again, right
Im again in the live USB and forgot to set up my keyboard again.

Heres the output of inxi -Fazy

  Kernel: 5.10.36-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCEM_2105 quiet systemd.show_status=1 
  apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Dell product: OptiPlex 755 v: N/A serial: <filter> 
  Chassis: type: 15 serial: <filter> 
  Mobo: Dell model: 0JR269 serial: <filter> BIOS: Dell v: A22 date: 06/11/2012 
  Info: Dual Core model: Pentium E5400 bits: 64 type: MCP arch: Penryn 
  family: 6 model-id: 17 (23) stepping: A (10) microcode: A0C cache: L2: 2 MiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 10778 
  Speed: 1843 MHz min/max: N/A Core speeds (MHz): 1: 1843 2: 2222 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 82Q35 Express Integrated Graphics vendor: Dell OptiPlex 755 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:29b2 class-ID: 0300 
  Display: x11 server: X *space due to not being able to place links* .Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.0x9.4") 
  s-diag: 449mm (17.7") 
  OpenGL: renderer: Mesa DRI Intel Q35 v: 1.4 Mesa 21.0.3 direct render: Yes 
  Device-1: Intel 82801I HD Audio vendor: Dell Optiplex 755 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:293e 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.36-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Device-1: Intel 82566DM-2 Gigabit Network vendor: Dell OptiPlex 755 
  driver: e1000e v: kernel port: ecc0 bus-ID: 00:19.0 chip-ID: 8086:10bd 
  class-ID: 0200 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 480.78 GiB used: 0 KiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA050 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: A750 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: HP model: x800m 
  size: 15.02 GiB block-size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1100 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No partition data found. 
  Alert: No swap data was found. 
  System Temperatures: cpu: 57.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 181 Uptime: 5m wakeups: 0 Memory: 3.71 GiB used: 1.32 GiB (35.7%) 
  Init: systemd v: 247 tool: systemctl Compilers: gcc: N/A Packages: 
  pacman: 951 lib: 263 Shell: Bash v: 5.1.8 running-in: xfce4-terminal 
  inxi: 3.3.04

Yes, you do.

That’s the video-linux driver that should be installed. The others should not be. If you run inxi -G in the chroot, you’ll see which driver is active.

From the chroot, remove them:

mhwd -r pci video-vesa video-modesetting

Then just to make sure the proper driver is installed:

mhwd -a pci free 0300

After that reboot normally.

Thank you so much! This worked perfectly, I’ll mark is at solution for anyone else having a similar driver issue.
And sorry for the delay to get a live USB working aswell.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.