Manjaro's boot-loader in wrong place, dual-boot with Win10x64 GPT

Hello! I need your help.

The Manjaro’s boot-loader starts when I select Linux Manjaro in default BIOS’es boot menu (I have to press F11 when PC is starting). But if I press nothing it starts Windows 10 and don’t “ask” me for OS to be started.


I have two drives: HDD and SSD. On my HDD I have installed Windows 10 and after it on empty SSD Linux Manjaro.

While I was installing Linux Manjaro, I selected Windows’es FAT32 100 MB partition and gave it /boot/efi mounting point and bios-grub flag, boot was already set.

(I followed Install Manjaro Linux 18.0 alongside Windows 10 as a dual-boot in VMware - YouTube steps)

What did I missed?
What I have to do to fix it?
Can you help me please?

Hello @RamoFX :wink:

  1. Open /etc/default/grub and check if this “GRUB_DISABLE_OS_PROBER=false” is set to false. If not there or true. Change it. Then run sudo update-grub, Windows should be displayed at the output.
  2. Change at your UEFI the bootorder and set Manjaro first. So that the UEFI Bootloader loads Linux and therefore grub bootloader first.

Very simple and working. Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.