Manjaro32 Testing problems following update 2019-12-28

Still cannot start laptop with kernel 5.4 see Manjaro32 Testing kernel 5.4 will not start


Cannot start 'qpdfview'

Summary

[keith@Laptop1 ~]$ qpdfview
qt5ct: using qt5ct plugin
Cannot mix incompatible Qt library (version 0x50d02) with this library (version 0x50e00)
Aborted (core dumped)

Stack trace

Process 1969 (qpdfview) of user 1000 dumped core.

Stack trace of thread 1969:
#0 0x00000000b7f74d39 __kernel_vsyscall (linux-gate.so.1 + 0xd39)
#1 0x00000000b6466e66 raise (libc.so.6 + 0x34e66)
#2 0x00000000b644f375 abort (libc.so.6 + 0x1d375)
#3 0x00000000b697095d _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5 + 0x6f95d)
#4 0x00000000b6989717 n/a (libQt5Core.so.5 + 0x88717)
#5 0x00000000b20607a0 n/a (libqgtk2style.so + 0x217a0)
#6 0x00000000b204e27b n/a (libqgtk2style.so + 0xf27b)
#7 0x00000000b206355d n/a (libqgtk2style.so + 0x2455d)
#8 0x00000000b780b6ca _ZN13QStyleFactory6createERK7QString (libQt5Widgets.so.5 + 0x16b6ca)
#9 0x00000000b78356be _ZN11QProxyStyleC2ERK7QString (libQt5Widgets.so.5 + 0x1956be)
#10 0x00000000b207bd02 _ZN15Qt5CTProxyStyleC1ERK7QString (libqt5ct-style.so + 0x3d02)
#11 0x00000000b207b93d _ZN16Qt5CTStylePlugin6createERK7QString (libqt5ct-style.so + 0x393d)
#12 0x00000000b780b6ca _ZN13QStyleFactory6createERK7QString (libQt5Widgets.so.5 + 0x16b6ca)
#13 0x00000000b779114f _ZN12QApplication5styleEv (libQt5Widgets.so.5 + 0xf114f)
#14 0x00000000b7791506 _ZN19QApplicationPrivate10initializeEv (libQt5Widgets.so.5 + 0xf1506)
#15 0x00000000b7791568 _ZN19QApplicationPrivate4initEv (libQt5Widgets.so.5 + 0xf1568)
#16 0x00000000004547d5 n/a (qpdfview + 0x2b7d5)
#17 0x00000000b6450f29 __libc_start_main (libc.so.6 + 0x1ef29)
#18 0x00000000004565c5 n/a (qpdfview + 0x2d5c5)

Stack trace of thread 1970:
#0 0x00000000b7f74d39 __kernel_vsyscall (linux-gate.so.1 + 0xd39)
#1 0x00000000b65194c3 __poll (libc.so.6 + 0xe74c3)
#2 0x00000000b32156ce n/a (libxcb.so.1 + 0xa6ce)
#3 0x00000000b3217864 xcb_wait_for_event (libxcb.so.1 + 0xc864)
#4 0x00000000b2c20c7a n/a (libQt5XcbQpa.so.5 + 0x58c7a)
#5 0x00000000b69b302f n/a (libQt5Core.so.5 + 0xb202f)
#6 0x00000000b68e6681 start_thread (libpthread.so.0 + 0x8681)
#7 0x00000000b6522d4a __clone (libc.so.6 + 0xf0d4a)


Cannot start 'calibre-python3'

Summary

[keith@Laptop1 ~]$ calibre
Segmentation fault (core dumped)

Stack trace

Stack trace of thread 1982:
#0 0x0000000000000000 n/a (n/a + 0x0)


Dump from 'msm_notifier'

Summary

Cannot mix incompatible Qt library (version 0x50d02) with this library (version 0x50e00)

Stack trace

Process 642 (msm_notifier) of user 1000 dumped core.

Stack trace of thread 642:
#0 0x00000000b7f8fd39 __kernel_vsyscall (linux-gate.so.1 + 0xd39)
#1 0x00000000b675be66 raise (libc.so.6 + 0x34e66)
#2 0x00000000b6744375 abort (libc.so.6 + 0x1d375)
#3 0x00000000b6b1f95d _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5 + 0x6f95d)
#4 0x00000000b6b38717 n/a (libQt5Core.so.5 + 0x88717)
#5 0x00000000b293e7a0 n/a (libqgtk2style.so + 0x217a0)
#6 0x00000000b292c27b n/a (libqgtk2style.so + 0xf27b)
#7 0x00000000b294155d n/a (libqgtk2style.so + 0x2455d)
#8 0x00000000b79656ca _ZN13QStyleFactory6createERK7QString (libQt5Widgets.so.5 + 0x16b6ca)
#9 0x00000000b798f6be _ZN11QProxyStyleC2ERK7QString (libQt5Widgets.so.5 + 0x1956be)
#10 0x00000000b2959d02 _ZN15Qt5CTProxyStyleC1ERK7QString (libqt5ct-style.so + 0x3d02)
#11 0x00000000b295993d _ZN16Qt5CTStylePlugin6createERK7QString (libqt5ct-style.so + 0x393d)
#12 0x00000000b79656ca _ZN13QStyleFactory6createERK7QString (libQt5Widgets.so.5 + 0x16b6ca)
#13 0x00000000b78eb14f _ZN12QApplication5styleEv (libQt5Widgets.so.5 + 0xf114f)
#14 0x00000000b78eb506 _ZN19QApplicationPrivate10initializeEv (libQt5Widgets.so.5 + 0xf1506)
#15 0x00000000b78eb568 _ZN19QApplicationPrivate4initEv (libQt5Widgets.so.5 + 0xf1568)
#16 0x00000000004b042b n/a (msm_notifier + 0x1342b)
#17 0x00000000004aa384 n/a (msm_notifier + 0xd384)
#18 0x00000000b6745f29 __libc_start_main (libc.so.6 + 0x1ef29)
#19 0x00000000004aa915 _start (msm_notifier + 0xd915)

Stack trace of thread 654:
#0 0x00000000b7f8fd39 __kernel_vsyscall (linux-gate.so.1 + 0xd39)
#1 0x00000000b680e4c3 __poll (libc.so.6 + 0xe74c3)
#2 0x00000000b3c036ce n/a (libxcb.so.1 + 0xa6ce)
#3 0x00000000b3c05864 xcb_wait_for_event (libxcb.so.1 + 0xc864)
#4 0x00000000b3610c7a n/a (libQt5XcbQpa.so.5 + 0x58c7a)
#5 0x00000000b6b6202f n/a (libQt5Core.so.5 + 0xb202f)
#6 0x00000000b670c681 start_thread (libpthread.so.0 + 0x8681)
#7 0x00000000b6817d4a __clone (libc.so.6 + 0xf0d4a)

Swapped to 'unstable' and updated using 'pacman -Syu', this resolved the issues with 'qpdfview' and 'msm_notifier'

pacman log

[2019-12-31T05:52:34+0000] [PACMAN] Running 'pacman -Syu'
[2019-12-31T05:52:34+0000] [PACMAN] synchronizing package lists
[2019-12-31T05:52:36+0000] [PACMAN] starting full system upgrade
[2019-12-31T05:53:03+0000] [ALPM] transaction started
[2019-12-31T05:53:04+0000] [ALPM] upgraded bluez-libs (5.52-1.2 -> 5.52-2.0)
[2019-12-31T05:53:04+0000] [ALPM] upgraded groff (1.22.4-2.0 -> 1.22.4-3.0)
[2019-12-31T05:53:05+0000] [ALPM] upgraded libedit (20191025_3.1-1.0 -> 20191211_3.1-1.0)
[2019-12-31T05:53:05+0000] [ALPM] upgraded libevdev (1.8.0-1.1 -> 1.8.0-2.0)
[2019-12-31T05:53:05+0000] [ALPM] upgraded libtirpc (1.1.4-2.0 -> 1.2.5-1.0)
[2019-12-31T05:53:05+0000] [ALPM] upgraded libwacom (1.1-1.0 -> 1.2-1.0)
[2019-12-31T05:53:05+0000] [ALPM] upgraded qt5-styleplugins (5.0.0.20170311-17.0 -> 5.0.0.20170311-18.0)
[2019-12-31T05:53:13+0000] [ALPM] upgraded qt5-svg (5.13.2-1.1 -> 5.14.0-1.0)
[2019-12-31T05:53:14+0000] [ALPM] upgraded qt5-translations (5.13.2-1.0 -> 5.14.0-1.0)
[2019-12-31T05:53:14+0000] [ALPM] upgraded qt5-webchannel (5.13.2-1.0 -> 5.14.0-1.0)
[2019-12-31T05:53:14+0000] [ALPM] upgraded qt5ct (0.41-1.2 -> 0.41-2.0)
[2019-12-31T05:53:14+0000] [ALPM] upgraded talloc (2.3.0-1.0 -> 2.3.1-1.0)
[2019-12-31T05:53:15+0000] [ALPM] upgraded v4l-utils (1.16.7-1.1 -> 1.18.0-1.0)
[2019-12-31T05:53:19+0000] [ALPM] transaction completed
[2019-12-31T05:53:19+0000] [ALPM] running '30-systemd-udev-reload.hook'...
[2019-12-31T05:53:20+0000] [ALPM] running '30-systemd-update.hook'...
[2019-12-31T05:53:20+0000] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-12-31T05:53:21+0000] [ALPM] running 'texinfo-install.hook'...
[2019-12-31T05:53:21+0000] [ALPM] running 'update-desktop-database.hook'...

Swapped to 'unstable' and updated using 'pacman -Syu', this upgraded calibre to version 4.8 and resolved the issue.

NOTE: I am currently needing to ignore the update to 'xorgproto' in unstable as it is causing problems for me. I will create a new topic for this.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by