Manjaro xfce window glitch

youtube video of glitch
I tried the solution at this thread :
xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "xpresent" --create
and then rebooted but it did not work. I also tried reinstalling manjaro xfce but that didn't help either.
The iso was: manjaro-xfce-20.0.3-200606-linux56.iso

Neofetch:

 neofetch
██████████████████  ████████   shraman@shraman-vostro3446 
██████████████████  ████████   -------------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: Vostro 3446 
████████            ████████   Kernel: 5.7.0-3-MANJARO 
████████  ████████  ████████   Uptime: 25 mins 
████████  ████████  ████████   Packages: 1117 (pacman) 
████████  ████████  ████████   Shell: bash 5.0.17 
████████  ████████  ████████   Resolution: 1366x768 
████████  ████████  ████████   DE: Xfce 
████████  ████████  ████████   WM: Xfwm4 
████████  ████████  ████████   WM Theme: Matcha-sea 
████████  ████████  ████████   Theme: Matcha-sea [GTK2], Adwaita [GTK3] 
████████  ████████  ████████   Icons: Papirus-Maia [GTK2], Adwaita [GTK3] 
                               Terminal: xfce4-terminal 
                               Terminal Font: Monospace 12 
                               CPU: Intel i3-4005U (4) @ 1.700GHz 
                               GPU: NVIDIA GeForce 610M/710M/810M/820M / GT 620 
                               GPU: Intel Haswell-ULT 
                               Memory: 2229MiB / 3841MiB 

lspci result:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
06:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
08:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)

Have you tried different kernels too? Also, since the topic you linked is about AMD Laptops, and you have

i presume is a hybrid GPU laptop, what drivers have you installed from this:


?

1 Like

I am using the video-hybrid-intel-nvidia-440xx-prime driver (so nvidia prime).

The issue was also occuring on the 5.6.15-1 kernel and I will try the LTS kernel now.

I also tried going to window manager tweaks and disable compositing and then rebooting but it had no effect

Yes and No.

That is Prime-Offload and not the same as Prime.
Maybe works, but check your xorg config, or if from terminal
mhwd -li
is showing video-linux too, then remove it trough MHWD.

1 Like

The LTS kernel also has the issue.

mhwd -li also shows the same driver:

mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI
   network-broadcom-wl            2018.10.07                true            PCI


Warning: No installed USB configs!

Are you still available? What do you suggest I should do? Thanks for the help so far.

It's a fermi card, so.... 390xx bumblebee.
https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

1 Like

Sorry to bother you again but I keep an error:

> Installing video-hybrid-intel-nvidia-430xx-bumblebee...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-430xx-bumblebee/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
warning: xf86-video-intel-1:2.99.917+908+g7181c5a4-1 is up to date -- skipping
error: target not found: linux57-nvidia-430xx
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
Error: pacman failed!
Error: script failed!

It worked! Thank you so much!
linux57-nvidia-430xx was not available, neither was 418xx so I installed the 390xx and after reboot it shows up as the installed driver according to mhwd -li and I am no longer having the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by