Manjaro XFCE - Shutdown + Ethernet issues

Hello Manjaro Forums!

I hope you are doing well!

I have a strange issue that I have run into.

I had purchased an used HP Z440 workstation for VFX studies. Below are some of the symptoms/problems pertaining to my issue

  • Shutdown/Hibernate/Suspend/Restart will all restart my machine. Occasionally, Manjaro will actually shutdown my machine like I want it to.
  • Power outages leave my ethernet permanently disconnected when I log in again. I checked this against my laptop which has Windows, and the same ethernet wire works fine.
  • Restarts/Shudown/Suspend will leave my ethernet permanently disconnected. Only Hibernate will ‘restart’ my machine and make my ethernet work again

Here are some obervations

  • My connection never drops in the middle of a session or otherwise. Only minor power outages or restarts are an issue.
  • the network manager restart sudo command restarts the applet but doesn’t ‘power on’ ethernet.
  • I’ve reset BIOS by removing my CMOS batter for 5 minutes. Unfortunately, I can’t access MEBx yet. I’m using the HP provided BIOS options and reset those to factory defaults.
  • I did not find any option regarding LAN and power that I could change.

A really stupid obervation.

  • If I physically plug out the ethernet wire and put it back in BEFORE the ethernet shows as disconnected in Manjaro, ethernet will continue to work.
  • If I physically plug out the ethernet wire and put it back in AFTER the ethernet shows as disconnected, then it will remain disconnected. Restart/Shutdown/Suspend won’t help. Only hibernate will.

My ethernet controller is I218-LM from intel.

I’ll continue to search the forums and google for answers in the meanwhile. Any help in the meanwhile is hugely appreciated! Thank you!

Here’s what I found so far!

I tried disabling ‘S5 Wake up on LAN’ from my BIOS as well as disconnecting my headphones and wacom from my USB 3.0 slots, and it worked as expected. Ethernet was back to normal after shutdown/restarts/etc etc. However, the moment I plugged in my headphones and wacom into my usb 3.0 slot, and shutdown, my machine restarted instead of shutting down.

My search continues!

I can now conclusively say that it is indeed USB 3.0 that is interfering with shutdown/hibernate/suspend, etc. since I tested with and without the USB 3.0 slots being used and the setup works perfectly without USB 3.0 in use. In BIOS, I only have options to disable USB slots, but not to convert USB 3.0 to USB 2.0. I really don’t want to plug my Wacom and headphones in a few times a day just to get the ethernet/Shutdown working as expected.

This is the page I came across.

Can somebody help out please?



Just updating this thread so that there is a record of this.

I suspect that this could be due to missing/incorrect wacom driver, since I have not faced the problem ever since I disconnected my wacom. I continue to use my logitech usb headphones in the usb3 slot and all is well.

I’ll update this thread whenever I manage to install the drivers for wacom, since I’ve run into errors doing that.

Thank you.