Manjaro XFCE: Live USB freeze when starting installer or gparted

ssd
xfce

#1

Hi guys,

First of all, this is my first forum post, so nice to meet you all. I’ve been using Linux for almost 7 years, and have been happily using Manjaro for the last 3 years.

Right now I’m having problem while installing Manjaro XFCE 17.1.9 in Intel NUC5CPYH Mini PC Kit. I’m asked to install Linux on five Intel NUC. All five PCs has 2GB RAM and 120GB SSD (with different brand). From those five, I’ve succesfully installed Manjaro on 3 PC, while failed on 2 others.

On these two PCs, the live USB works normally while reading PDF and browsing internet. However, when I start the installer, the live USB suddenly freeze and I have to forcefully turn off the PC.

I’ve tried to start the installer from terminal using command sudo -E calamares -d. From this, I found out that the installer (and live USB) freeze after it finished detecting the SSD (don’t mind those two black circles) :

From this, I suspected that the problem is caused by SSD, so I tried to use gparted to check and partition it manually. However, when I ran gparted it also freeze while scanning /dev/sda.

After I check those two PCs, I found out they have same SSD, which is Midas Force 120GB, a cheap Taiwanese SSD. Here are the result of inxi -Fx :

System:
  Host: manjaro Kernel: 4.14.36-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 7.3.1 Desktop: N/A Distro: Manjaro Linux 17.1.9 Hakoila 
Machine:
  Type: Desktop Mobo: Intel model: NUC5CPYB v: H61145-408 serial: N/A 
  UEFI: Intel v: PYBSWCEL.86A.0069.2018.0314.1745 date: 03/14/2018 
CPU:
  Topology: Dual Core model: Intel Celeron N3050 bits: 64 type: MCP 
  arch: Airmont rev: 3 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6402 
  Speed: 1600 MHz min/max: 480/1600 MHz Core speeds (MHz): 1: 1071 2: 480 
Graphics:
  Card-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: N/A driver: intel unloaded: fbdev,modesetting,vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell) 
  v: 4.5 Mesa 18.0.1 direct render: Yes 
Audio:
  Card-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.14.36-1-MANJARO 
Network:
  Card-1: Intel Wireless 3165 driver: iwlwifi v: kernel bus ID: 02:00.0 
  IF: wlp2s0 state: down mac: <filter> 
  Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 v: 2.3LK-NAPI port: e000 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  HDD Total Size: 119.02 GiB used: 1.64 GiB (1.4%) 
  ID-1: /dev/sda model: Midas_Force_120G size: 111.79 GiB 
  ID-2: /dev/sdb type: USB model: USB_Flash_Drive size: 7.23 GiB 
Partition:
  ID-1: / size: 1.41 GiB used: 43.1 MiB (3.0%) fs: overlay dev: ERR-102 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 147 Uptime: 2m Memory: 1.88 GiB used: 437.2 MiB (22.8%) 
  Init: systemd Compilers: gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07

So, my questions are :

  1. Is this freeze happened because Manjaro unable to scan the Midas Force SSD ? If so, why ? It’s the first time I found HDD or SSD that can’t be installed Linux.
  2. What should I do so I can install Manjaro on those two PCs ? Do I have to replace that SSD ?

P.S: The SSD on those two PCs is brand new (according to the owner anyway). I’ve also tried GSmartControl to check SSD health, and it says that the SSD is passed basic health check.


#2

Hi! I was doing a Google search on the same issue, and found this. Seeing that the post is from today, I decided to register to share my experience since I’m literally having this problem right now.

I’m using the KDE 17.1.9 ISO. I had no problem installing Manjaro on my laptop, but today I’m attempting to install it on my desktop (same install flashdrive) and at the “Partitions” step, if I select something other than “Erase Disk” or do select “Erase Disk” but tick the encryption box and enter a password, it starts to scan and stays there indefinitely.

My install attempt is to an SSD, 120GB Kingston SSDNow. I have a 1TB HDD Western Digital and I even unplugged it and tried again thinking it was faulty.

I also tried running the KDE Partition Manager from the live ISO but it also got stuck. Then it complained about not having root access, I ran it again as root, took it’s sweet time but it finished scanning drives. Prior to this I tried unmounting from the terminal, and a failed attempt at formatting with fdisk because I forgot to do it as root and then decided to wait a bit to see if KDE Partition Manager finished scanning.

After this, I launched the installer and tried to install and it didn’t get stuck again but failed to install. I’ll update this if I find something else.

EDIT:
I ran fdisk to give the SSD a new GPT table and then wrote the changes to disk, rebooted and it installed without issue.

su
fdisk /dev/sda
g
w
reboot

#3

Try installing gparted in the live environment and use it to partition before you install. I’ve found KDE Partition Manager acting a little buggy lately with very long start times. Skip the encryption option, keep it simple. Keep trying.


#4

I find it more likely that your video drivers are causing this and not your SSDs. Were all five of these computers identical or do these two computer use different graphics cards.

(edit) after looking more carefully I now notice:

Your graphics drivers are the problem.


#5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.