Manjaro xfce installation problem

I tried to install linux manjaro XFCE, everything seemed alright then the installation failed at 90% with the error “manjaro nibia has not been installed on your computer the error message was boot.python in job bootloader”

I tried again and this time only manual partitioning is available and I can’t make a partition correctly, there’s no swap and when I put 98296 mb to root and boot but it goes to 67339 mb automatically and I can’t make a swap partition (I have 500 GB).

what I have to do???

And I messed up everything by closing the installer, shutting down and unplugging the pendrive, now it has no internet, somebody help me, please

recheck all option in UEFI/Bios to get only UEFI

disable secureboot
disable fastboot
no CSM or Legacy
choose UEFI only or first or others ( not windows )
disks on AHCI
no optane RST

and boot in UEFI only on USB iso
you should see this
UEFI < USB vendor name > < partition 1>

inxi -Mza
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
sudo efibootmgr -v

hey, I rebooted my pc without pressing any buttons (also without unplugging my pendrive) and the internet is back, manjaro hello acts like I have installed it, do I need to reinstall manjaro somehow?

reports

inxi -Fza
test -d /sys/firmware/efi && echo efi || echo bios

I’m trying to copy and paste but the forum says I can’t post links.