Manjaro xfce fresh install no dock

Hello everyone!(sorry for the essay)(first time on the forum xD)
I recently changed to manjaro for the first time…I usually choose gnome(got nightmares from mint and ubuntu xD they used to be extremely unusable when i first got into linux althout it was propably not the de but the drivers for my nvidia card(open source drivers are terrible i cant even boot xD)).Anyway i chose xfce to check out something new.Experience so far is amazing no crashes or anything but 1 thing i was feeling kinda weird about from the moment i got in the desktop is that there was no dock-taskbar.I let it slide because i thought about xfces desc on manjaro .org about how fast it is and etc and i thought it didnt have a dock(still weird tho).After watching other peoples fresh installs tho on the internet with xfce evreyone’s had a dock.I confirmed it because i now realise there is a display issue:
My monitor is a damn 2007 tv xD(im now gathering up some money to buy a new one xD its about time xD)and doesnt like computers all that much xD…max resolution i can get is 1280x720 although in nvidia settings i have my viewport in at 1080p and out at 720p and thats what i ve done with all the distros(it took me hours to configure it correctly)As it seems tho manjaro is the first 1 that doesnt like it(tried arch,ubuntu,mini,popos,garuda and all of them were fine…)i confirmed the problem because when i try to maximize a windows bottom of the screen is not there(small portion for example on youtube i can see the top part of the time bar(barely))So even if i moved my image on the monitor with port in a bit upwards it still didnt help…so there is a part of the desktop that i cant see no matter what i do,…
Any help is appreciated(thanks for reading my essay,hope you have a good day)

specs:
ryzen 5 3600
gtx 1650super proprietary driver:version 460.73.01
16gb ram i think patrio viper series cl16 3000mhz dual channel
asrock fatality b450 gaming k4 bios version i think p4.20
a be quiet 600w bronze power supply(doesnt matter but since i started i ll refer to all the parts xD)
a kingston a2000 nvme ssd 250g
a western digital 1tb hdd 7200RPM
INXI -FZA:
System:
  Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=64c04644-e445-41d6-89c3-ef82b4b96e23 rw quiet 
  cryptdevice=UUID=2c960bc9-2201-449a-b350-d52df62880bd:luks-2c960bc9-2201-449a-b350-d52df62880bd 
  root=/dev/mapper/luks-2c960bc9-2201-449a-b350-d52df62880bd apparmor=1 
  security=apparmor 
  resume=/dev/mapper/luks-26051d82-a101-43fb-9a93-1c3f99cad1b3 
  udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel, latte-dock 
  wm: xfwm4 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Desktop Mobo: ASRock model: B450 Gaming K4 serial: <filter> 
  UEFI-[Legacy]: American Megatrends v: P4.20 date: 06/19/2020 
CPU:
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: 0 microcode: 8701021 cache: 
  L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86244 
  Speed: 4031 MHz min/max: 3600/4200 MHz boost: enabled Core speeds (MHz): 
  1: 4031 2: 4058 3: 3662 4: 3618 5: 3774 6: 3579 7: 3904 8: 3492 9: 3828 
  10: 3669 11: 3745 12: 3692 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: Micro-Star MSI 
  driver: nvidia v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 0a:00.0 
  chip-ID: 10de:2187 class-ID: 0300 
  Display: x11 server: X. Org 1.20.11 driver: loaded: nvidia display-ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 46 s-size: 1060x609mm (41.7x24.0") 
  s-diag: 1222mm (48.1") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 66 
  size: 735x420mm (28.9x16.5") diag: 847mm (33.3") 
  OpenGL: renderer: GeForce GTX 1650 SUPER/PCIe/SSE2 
  v: 4.6.0 NVIDIA 460.73.01 direct render: Yes 
Audio:
  Device-1: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 0a:00.1 chip-ID: 10de:1aeb 
  class-ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus-ID: 0c:00.4 chip-ID: 1022:1487 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus-ID: 09:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.15 TiB used: 52.85 GiB (4.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8250G 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: S5Z42105 
  temp: 31.9 C scheme: MBR 
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: 1A02 scheme: GPT 
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Blade 
  size: 14.32 GiB block-size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.00 scheme: MBR 
Partition:
  ID-1: / raw-size: 215.76 GiB size: 211.32 GiB (97.94%) 
  used: 52.85 GiB (25.0%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-2c960bc9-2201-449a-b350-d52df62880bd 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.11 GiB used: 1.5 MiB (0.0%) 
  priority: -2 dev: /dev/dm-1 maj-min: 254:1 
  mapped: luks-26051d82-a101-43fb-9a93-1c3f99cad1b3 
Sensors:
  System Temperatures: cpu: 68.0 C mobo: 0 C gpu: nvidia temp: 38 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 23% 
Info:
  Processes: 454 Uptime: 2h 07m wakeups: 0 Memory: 15.56 GiB 
  used: 7.11 GiB (45.7%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 Packages: 1308 apt: 0 pacman: 1300 lib: 363 flatpak: 0 snap: 8 
  Shell: Bash v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.04 
XRANDR:
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 735mm x 420mm
   1280x720      60.00*+  59.94    50.00  
   720x576       50.00  
   720x480       59.94  
   640x480       59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

hello , its more easy to
open terminal and provides

inxi -Fza 
xrandr 
1 Like

DONE,thnx for helping

You can install xfce-docklike-plugin.

picture

AUR: AUR (en) - xfce4-docklike-plugin-git

guys i just figured something out!
i went to the panel setttings the taskbar is there the problem is that its hiding .i can now see half of it
by maximimzing its size but the desktop is ugly now.thats the problem(part of the screen is hiding)

see this
http://us.download.nvidia.com/XFree86/Linux-x86_64/460.73.01/README/configtwinview.html
and
http://us.download.nvidia.com/XFree86/Linux-x86_64/460.73.01/README/configmultxscreens.html

you will find your conf in
/etc/X11.mhwd.d/nvidia.conf

always backup before changing , also be careful because mhwd can rewrite on update
when it’s ok do a copy nvidia.conf.ok

ok got it(ill come back with results)