Manjaro xfce build in microphone issue "failed to accress your microphone" in jitsi

I am troubleshooting on behalf of my friend.
Her manjaro xfce always has mic issue. even after restart.
Please advice.

$ arecord -l 
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC236 Analog [ALC236 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

When i tried $alsamixer
Under F4 [capture] the bar is indicating “capture 100”
Under F6 [select sound card] it is “default”
**in alsamixer, everything seems to be good to me.

GUI (bottom right tray: speaker icon) audio mixer :
Under “Recording” : there is nothing. “no application is currently recording audio”
**BUT I have jitsi session in Brave browser is on"
**on Jitsi session, it is prompting “Failed to access your microphone”.

GUI - audio mixer:
Under “Input Devices” : Monitor of Built-in Audio Analog Stereo
**This computer is not plugged into HDMI tv.

Can you follow the instructions here and test that the mic issue exists on various voice/video software and not just on Jitsi(through Firefox)?

Testing can help us determine if its app level bug or OS level.

After multiple testing…
found out:
It is HDMI plug and unplug issue. also related to “suspend to ram” issue.
The computer of problem, have being having the same no mic issue for 3 times : 3 days in a row…

Each time HDMI is plugged in or unplugged, there surely will be microphone issue.
After “click here and there” in pavucontrol, mic will suddenly works.

But after wake up from suspend to ram, there will be mic problem again.

This is almost repeatable everytime on the laptop with manjaro xfce.

It has got nothing to do with firefox, brave web browser, skype and stuff.

The (default) controls shown with alsamixer command are likely to be for PulseAudio rather than the ALC236 audio codec

Use alsamixer --card=0 --view=capture to view capture controls for onboard audio

Or amixer --card=0 to post information here about ALSA settings in text format

It is HDMI plug and unplug issue. also related to “suspend to ram” issue.

A HDMI audio connection might replace and audio playback sink in PulseAudio, but I would not expect it to change an audio capture source,
but it may be possible if the default source in PulseAudio is using a sink.monitor to capture audio playback instead of microphone source

check PulseAudio pacmd dump to see if microphone is configured as the default source

Also check if PulseAudio modules module-switch-on-port-available and module-suspend-on-idle are loaded

The modules can be unloaded temporarily to test if audio does not switch away from the microphone

pacmd unload-module module-switch-on-port-available
pacmd unload-module module-suspend-on-idle