Manjaro XFCE 20.0.3 - Persistent USB - released

There is no root password set it seems. It should be able to use “sudo” as this is what the repository suggests (alma/presets at master · philmmanjaro/alma · GitHub) as defined in the user.toml-file but that does not work and renders the pre-built image rather useless.
@philm Could you please fix this so we can have a persistent USB image where we can become root?

If you make the image yourself with alma sudo does work and you can set a root password . I don’t know why philm’s doesn’t, but I’m glad it doesn’t, because I learned to use alma and customized a few things, like making the image 14GB so it would install in a 16GB flash drive and, hopefully, use most the size as persistence. Today I go and trade the guy this 16GB Manjaro USB Install for the Persistent MX Linux USB I made for him last week. He seems to like Linux and we may have another user in the community shortly. Thank you for this, @philm

I tried to put an alma image on a ventoy multiboot usb and it didn’t work. I wonder why…It would be cool to have usbs with both an alma/manjaro persistent image AND an installer for when they decide they like it. If anyone has any luck putting this in a multiboot, please share and I will as well.

If I install Manjaro on a persistent USB drive I will have manjaro-chroot to use on it?
This is because I have another installation of Manjaro in another partition and I don’t have it, I can’t use it.

No, if you install Manjaro on an persistent USB drive you can boot from it on serveral PCs and just use it as normal installation. All setting you adjust and application you install will be persistent. That means these (applications/settings) are still there when you boot it on an other (or next time on the same) PCs .

Thats the differnt to the Live-USB which resets to default every time you boot.

Yes, I know about this, I just want to use it to chroot (change root) in to another Manjaro installation, if this is possible?
I will keep using an image of the system to boot from the USB when I need.

Ok, so I have missunderstood your question sorry. So yes chroot from the persistent-USB should work as long as you could mount the / from the other manjaro installation.

1 Like

This image is useless for me since default user is not in sudoers list.

In August when Phil first put up this post, I installed the .iso on a 128GB stick and used it on multiple computers until about a week ago, when I messed something up while addressing cumulated .pacnew files. I decided to wipe the stick and start over with the Alma instructions provided here: GitHub - philmmanjaro/alma: Create Arch Linux based bootable USB drives. I found out that it’s really, really easy to get a system up and running this way. I did not use any presets – I just did the original install script, then added the Gnome desktop (Install Desktop Environments - Manjaro) and tinkered to give myself sudoer permission, switched from stable to unstable, added a couple Gnome extensions and so forth. There were some glitches with the DE installation, but nothing major, and now I have a much better functioning persistent USB system than I had before. I’ve even added a couple extra kernels. Couldn’t be more happy, and I think it’s very worth installing a system with the Alma commands rather than the official .iso, if only for the customization possibilities.


You can plug the flash drive in a PC and edit


change manjaro:x:1000:1000::/home/manjaro:/bin/bash



so you are root now

But it didn’t show the wifi app. I am unable to connect to the network.

Any hints?

@andreapuppet, please share yout ISO with US, please.

Many thanks.

I don’t have an .iso – I just built the persistent system using Phil’s instructions on his Alma github page (linked in my previous post). Then I added the graphical desktop environment (Gnome in my case) and configured everything as though I’d installed a minimal system to a physical hard drive. Give it a try – it’s easier than I thought it would be.

@philm I’m wondering if the latest os-prober updates are preventing Alma from creating a new image.

When issuing sudo alma create -e /dev/disk/by-id/usb-Generic_USB_Flash_Disk-0:0 I get the following:

Error: Error querying information about the block device

Caused by:
    No such file or directory (os error 2)

I’ve tried it with two different usb sticks on two different computers, same result across the board.

I did create an USB-stick today, and it worked.
But a few days ago it did not work. There were a few errors reported then. But i did not copy them. :frowning:

Interesting that it works for you. I tried again and am unable to install, with the same error reported in my previous post.

Maybe try with linux54 on your host system. Newer kernels might added some regressions.

Thanks, Phil. I booted into Linux54 and tried again, but I get the same error. Tried a different USB, and also tried formatting to both Fat32 and Ext4, but it doesn’t seem to make a difference. I also tried reinstalling alma-git with its arch script dependency, but the error pops up again. I noticed that this started happening after GRUB and OS-Prober went through their recent “upgrades.”

then try with older versions of grub to see if that is the case.

Will see about downgrading GRUB when I get home from work.

@philm Issuing sudo downgrade grub I see multiple instances of version 2.04 (my current version) along with one 2.06. Would any of these work for testing purposes here?

for some reason i always get
“ERROR: device ‘UUID=foobar’ not found skipping fsck
mount: /new_root: cant find UUID=foobar,
You are now being dropped to emerygency shell
sh: cant access tty: job control turned off”

I even created a new img using your tutorials but it also gives this error.