Manjaro XFCE 19.0-rc2 released

I am proud to announce our release candidate build of the upcoming Manjaro-XFCE 19.0 Kyria release. This build is based on stable branch .

The Xfce edition remains our flagship offering and has received the attention it deserves. Few can claim to offer such a polished, integrated and leading-edge Xfce experience. We ship Xfce 4.14 with this release of Manjaro.

We mainly focused on polishing the user experience on the desktop and window manager, and on updating some components to take advantage of newly available technologies such as optimization of our theme we call Matcha. The new feature Display-Profiles allows you to store one or more profiles for a particular display configuration that you may be using. To make the deal a little sweeter we implemented auto-applying of profiles when new displays are connected.

Higlight features

New features in xfce edition:

  • Polishing of Matcha themes (incl. dark theme)
  • Whiskermenu can now be more customized
  • Additional wallpapers to match theme changes
  • Fixing bugs and featuring improved translations
  • More features added to Pamac

We hope you enjoy it and please leave feedback. :grinning:


Changes since rc1:

  • Calamares updated to use kpmcore4
  • small fixes overall

Regressions:

  • seems Whiskermenu changed. We updated our configs so it will be fixed in our final release

7 Likes

Will the upcoming Manjaro Xfce edition include the 4.14 latest maintenance release, 4.14.3?

Only XFCE component which have version 4.14.3 version now, is xfce4-panel. This version is already on Manjaro Stable.

Was able to get this installed on my system. However I had to restart the live-usb 3-4 times before it booted into a graphical state that was usable. The other times it would boot to a static screen filled with colored snow. Was going to take a picture on next reboot then the it booted up normally. I am 100% sure this is because of my odd hardware setup I will drop my inix below for reference. What kind of support is coming down the pipes for and amd/nvidia hybrid combo.

System:
  Kernel: 5.4.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: Zephyrus G GU502DU_GA502DU v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: GU502DU v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: GU502DU.208 date: 08/01/2019 
Battery:
  ID-1: BAT0 charge: 68.3 Wh condition: 68.3/76.0 Wh (90%) volts: 15.8/15.8 
  model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> 
  status: Not charging 
CPU:
  Topology: Quad Core model: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 36744 
  Speed: 1344 MHz min/max: 1400/2300 MHz boost: enabled Core speeds (MHz): 
  1: 1386 2: 1582 3: 1194 4: 1175 5: 1496 6: 2522 7: 1177 8: 1175 
Graphics:
  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK 
  driver: nvidia v: 440.59 bus ID: 01:00.0 chip ID: 10de:2191 
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 05:00.0 chip ID: 1002:15d8 
  Display: x11 server: X.Org 1.20.7 driver: amdgpu,nvidia 
  resolution: 1920x1080~120Hz 
  OpenGL: renderer: GeForce GTX 1660 Ti with Max-Q Design/PCIe/SSE2 
  v: 4.6.0 NVIDIA 440.59 direct render: Yes 
Audio:
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:1aeb 
  Device-2: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 05:00.1 chip ID: 1002:15de 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.4.21-1-MANJARO 
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtl8821ce v: N/A port: e000 bus ID: 03:00.0 
  chip ID: 10ec:c821 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 11.37 GiB (2.4%) 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 002C scheme: GPT 
Partition:
  ID-1: / size: 456.91 GiB used: 11.37 GiB (2.5%) fs: btrfs 
  dev: /dev/nvme0n1p2 
  ID-2: /home size: 456.91 GiB used: 11.37 GiB (2.5%) fs: btrfs 
  dev: /dev/nvme0n1p2 
  ID-3: swap-1 size: 19.53 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 62.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2900 
  GPU: device: nvidia screen: :0.0 temp: 52 C device: amdgpu temp: 62 C 
Info:
  Processes: 271 Uptime: 6m Memory: 15.39 GiB used: 1.19 GiB (7.7%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.37

Forum kindly sponsored by