manjaro wont sleep

I've used my Manjaro KDE (20.0.3 Lysia) installation for about six months with out any problems. Then with out warning the sleep function stopped working which I use regularly. I used Timeshift to restore a point before it stopped working but this fixed nothing. What happens is when I initiate the sleep the screen turns black, and I ONLY see the pointer for about 90 seconds, then it goes to start screen ready to be logged in.

Yesterday I deleted the installation and started again (20.0.3 Lysia) with a fresh install. I was going to closely monitor the new installation and install my critical apps one by one then test the sleep in between each installation. Every thing was working great and I had all my required apps installed with all the Manjaro updates as well and sleep was still working.

Today with out any further updates and no more installations the sleep function stopped working. I have no idea what is causing it? I tried Timeshift once again, but still no fix. I searched the web and some have said it could be a kernel update, but I closely watched this during the installation and afterwards where the kernel started off from 5.4 then upgraded to 5.6 and sleep worked fine on both versions. Also I have seen bluetooth could be a suspect, but I have paired NO devices at all and also switched off the functionality.

I have an Intel Skull Canyon NUC8i7HVK with 32GB RAM. Does anyone have any ideas?

1 Like

I suspect, this is a problem with KDE and how it works with Intel graphics.

Perhaps the acceleration method in /etc/X11/xorg.conf.d/20-intel.conf should be changed form uxa to sna as described below:

  Option "AccelMethod" "sna" # default method
  # Option "AccelMethod" "uxa" # alternative method to use instead of the previous

I got this idea from this topic that also describes other potential fixes to try:

Thanks for your reply, but my issue is a little different than the case of both of those links. Those links refer to "Black screen + cursor on resume from sleep". In my case Manjaro NEVER sleeps. I only get a black screen with cursor on shutting down to sleep. This lasts for about 90 seconds, then Manjaro starts up automatically to the login screen. At this point I have total control of the OS and I can log back in again.

I did however read the posts. On the first link:

I have solved this problem NOT using this next file: /etc/X11/xorg.conf.d/20-intel.conf
In my case the problem was the "uxa" method.

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  # Option "AccelMethod" "sna" # default method
  Option "AccelMethod" "uxa" # alternative method to use instead of the previous
  Option "TearFree" "true"
  # Option "DRI" "2" # default "3"
  # Option "DRI" "False" # disables acceleration
EndSection

I have the "xorg.conf.d" folder, but no "20-intel.conf" file. Only "00-keyboard.conf" & "30-touchpad.conf". Also Im not sure what he means by the "xua method"?

On the second link no one seems to have a successful solution?

I have the "xorg.conf.d" folder, but no "20-intel.conf" file.

That is normal. You can create 20-intel.conf file.

Also Im not sure what he means by the "xua method"?

As I understand it, there are different acceleration methods of how graphics is drawn.
SNA is a faster acceleration. UXA is an older, but more stable acceleration method.

I am sorry I understood the situation wrong. Probably you are right and your case, when the computer does not go to hibernate at all, is not related to the idea I suggested.

Hey thanks Mountain for helping and no need to apologies for misunderstanding, you are the one helping me and not the other way around.

Anyway I did what you said, but not sure if I did it right? I created a text file and renamed it "20-intel.conf" and put it in "/etc/X11/xorg.conf.d/". Not sure if you wanted me to add in the .conf file

So I tried both. First empty .conf file then put it to sleep then the above text and put it to sleep. On each occasion it never went to sleep. Doh!!

Forum kindly sponsored by