Manjaro won't launch after restart when i accidentally entered wrong decryption key

I’m new to Linux, because of Steam Deck I installed on my laptop Manjaro KDE. I encrypted the drive while installing, thinking I could eaisly decrypt it later like in Windows.
I think i entered twice the same password for drive decryption when system was starting, it showed me that i should input something else, grub or something like that, I don’t remember, i restarted my laptop.
After that it would not start after decrypting. I was stuck on

/dev/mapper/luks-7125ea18-7c14-49d1-b437-d44807ffad6c: clean, 80316/30507000 fiiles, 35660229/122018184 blocks

sometimes it showed me “recovering journal”
So i tried fixing it by fsck, on a live USB after i finally got it to work with

cryptsetup luksOpen /dev/sda2 _dev_sda2

I used

e2fsck -f -c /dev/system_name/partition_name

Now sometimes this message pops up

[FAILED] to start pkgfile database update

now I’m trying to fix my system using this guide
But I encountered a problem, when I write

sudo pacman -S manjaro-chroot

I get at the end

error: target not found: manjaro-chroot

and when i try manjaro-chroot command it outputs: ERROR: Can’t create chroot on non-directory.

To be honest, I’m afraid that there is a simple fix that i don’t know about as i started my journey with Linux less than a month ago. I tried this guide with 2 resets from live USB and I’m tired as I need this laptop to work correctly, with all the configurations I made while using this system.
I would appreciate any help.

You need to unlock all encrypted partitions before using manjaro-chroot in a live ISO session.

If it does not autodetect your Manjaro installation, then you need to manually mount and specify it with manjaro-chroot.

Could you explain to me how to unlock all encrypted partitions? I thought cryptsetup luksOpen does this thing.
Also how do i specify it? do i use something like

cryptsetup open /dev/sda2 _dev_sda2

(this doesn’t work it says, the device does not exist or acces denied.)
or something else?
As I said, I’m totally new to Linux so I don’t know how to do things unless i can google them or someone explains them to me. And googling these issues is pretty hard because everyone had different problems and uses different systems etc. For example i don’t know what is my device.
in Dolphin for exmaple it says dm-0 and I really don’t have any idea what to do and I’m pretty frustrated.
Please, explain that to me like I’m 5 year old.

In the live ISO, you’re under a non-privileged user. Thus, you need to prepend actions with sudo.

Whatever partitions are encrypted need to be unlocked before you can use manjaro-chroot. (This could be just a single partition.)

So once it (or “all”) are unlocked, you can try again with manjaro-chroot.

When you “enter” a chroot’ed environment, you are by default the root user, and thus you do not need to prepend actions with sudo anymore.

Once you are finished in the chroot’ed environment, you can exit with exit or CTRL + D.

What commands should I use to unlock that partition?

cryptsetup luksOpen /dev/sda2 _dev_sda2

asks me for decryption passwords but manjaro-chroot doesn’t work
The guide says that I should use

sudo mount /dev/sda2 /mnt

but i can’t use it because that partition is crypt_luks.

Because you’re supposed to mount the filesystem, not the encrypted block device.

Once you unlock a LUKS container, it creates a device map to the actual unencrypted device (where the filesystem resides.) This is found under /dev/mapper/

In your cause it would be /dev/mapper/_dev_sda2

You can use whatever mapped name you want to use. For example,
sudo cryptsetup luksOpen /dev/sda2 crypto_sda2

In which you would now see /dev/mapper/crypto_sda2 as the mapped device.

Now you mount that (not the raw block device.)

And now you can specify /mnt/ in your manjaro-chroot command.

I still have issues.
I’ve used

sudo cryptsetup luksOpen /dev/sda2 _dev_sda2
sudo mount /dev/mapper/_dev_sda2
sudo pacman -Sy (because -S manjaro-chroot will not work)
sudo pacman -S manjaro-chroot

with sudo pacman -S manjaro-chroot i get error: target not found: manjaro-chroot
so when i use manjaro-chroot it outputs ERROR: Can't create chroot on non-directory

You don’t need to install the package manjaro-chroot in a live ISO. It comes with it by default. I hope you’re using the latest Manjaro ISO release.

Secondly, specify where to chroot after you’ve mounted everything.

For example, I’m just assuming your setup:

sudo cryptsetup luksOpen /dev/sda2 _dev_sda2
sudo mount /dev/mapper/_dev_sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
sudo manjaro-chroot /mnt

Then you do stuff. Then you exit the chroot’d environment. Then you reboot.

I managed to fix my linux, i tried reinstalling kernel, but I just removed nvidia gpu driver and i think i reinstalled grub, it works now, anyway, thanks for help! You helped a lot.