Manjaro wont get past first install screen

hello all,
trying to install manjaro xfce 20.2.1 on a cube i9(think windows surface). It has windows 10 on it but frankly i dont mind it getting over written by manjaro.

However every time i try to install i get to the open source drivers/proprietary drivers…select open source(it has an intel gpu) and select open source…then nothing happens(blank screen). I have tried various other manjaro versions…and turned csm mode(uefi or legacy) off and on, and even selected the individual selections within my bios but to no avail. Strangely ubuntu will successfully install(it breaks after a few weeks/days due to something updating) but i prefer Manjaro.
The hard drive can be wiped/win 10 removed etc so i dont mind formatting the hard drive. Problem is…i cant even get to the manual partitioning install part of manjaro.

I have tried a tentative stab with using a partitioning tool(usb) but i dont really know what i am doing.
Any help would be appreciated please.

Many thanks,

Try doing a install along side windows, you can manage the space needed. Also try using the proprietary drivers and see if that works.

I managed to install via network(gnome) and it worked…then an error popped up, and it asked me to press any key. First time nothing happened and then after second reboot went into manjaro as normal.
Now the same error has come up…it says press any button (again) but nothing happens. I have checked csm mode is off(legacy is on) and even changed it to on but to no avail.
Must be said…gnome is fantastic with manjaro on this little tablet and is really fast
ps fault says: error:diskfilter writes are not supported

What do you mean by install via network? Do you mean Manjaro Architect?

Yes, but I got the above error after it worked perfectly…and now I can’t get it to install at all