manjaro won't boot, eMMC, pinebookpro

Hello everybody,

I installed Manjaro ARM KDE edition 20.02.1 with the emmc installer on my pinebook pro.
After a shutdown I'm not able to reboot anymore:

  • I push the start button
  • the led turns orange for a while
  • becomes green but nothing happens: the screen is black.

I tried this a couple of times, until, magically, manjaro started once again.

But now, after another shutdown, the problem is still present...

any suggestions?

That's very hard to figure out.

Make sure you have no SD card in the SD slot.

When the screen is just black, can you try adjusting the Brighness on the screen. The kernel changed some stuff in regard to brightness and some panels on some Pinebook Pro's goes all dark at that point.

Hi Strit,
I confirm there's no ssd card in,
also with keys FN + F1 or F2 I'm not able to modify brighness: the screen is completely black!

Is the screen turned off or just black?

sorry Strit,

the screen is turned off...

Hi, we might need more details to your device, as every installation image we test on our devices. However, it seems some hardware configurations might be slightly different. To check if it is no hardware issue, please try also older releases of Manjaro:

Also check other OS images:

https://wiki.pine64.org/index.php/Pinebook_Pro_Software_Release#Bionic_Mate

If possible describe when you got your device and what MMC size your device has. We also check if we can find some more details to define which batch your device comes from. The more details we have the more we can research and find a possible solution.

Hi philm,
I ordered my pinebookpro on the 25 th of January, but it arrived yesterday...
I have 64GB of eMMC.
I'll try to install Manjaro-ARM-kde-plasma-pbpro-19.12-emmc-installer-19.12 and post back here.
Thanks for now.
Marco

1 Like

update:
trying to install Manjaro-ARM-kde-plasma-pbpro-19.12-emmc-installer-19.12.
The prompt says: Choose your eMMC device. Currently, the booted sdcard is at "mmcblk1"

Unfortunately there's no way to choose other locations: I have only "mmcblk1" listed.

Maybe try the SD-Card version of both releases first to see if the software boots at all. @Strit might know what that can be with the MMC installer. First we have to see if it is a software or hardware issue.

Hi,
so, I tried three img.

bionic-mate-pinebookpro-0.9.14-1159-armhf.img.xz
doesn' load anything, the screen is off.

Manjaro-ARM-kde-plasma-pbpro-19.12.img.xz
everything works just fine, the OS works.

pinebookpro-debian-desktop-mrfixit191226.img.xz
the default img works fine.

I think it's not an hardware issue.
I would like to install Manjaro-ARM-kde-plasma-pbpro-19.12-emmc-installer-19.12.img.xz on eMMC or at least return to the defautl OS, but at this point I don't know how to do it.

Any advice?

moved to #manjaro-arm

Hi @mr.angeli

Let me help you with it.

Please download this IMG

Flash it on an sd card using Etcher
Power on the device with sd card inserted to boot the device from it.

You will be greeted with an oem installer wizard just enter the login details and it will reboot.

After this connect to internet with wifi and upgrade the system using the pamac.

Please report back once everything is done.

The reason I am asking you to do this is to debug the issue that you're facing.
It will help me pin point the pkg which is causing such issue.

Hey spikerguy,

thanks for stepping in.
I'm currently dowloading the img and will use Etcher to flash ssd.
I was previously using "Disks" on ubuntu to flash the img.

Let me try and I'll post back.

Marco

1 Like

Hi spikerguy,

  • Manjaro-ARM-kde-plasma-pbpro-20.02.1.img.xz downloaded
  • flashed with Etcher on ssd
  • booted pinebookpro with ssd
  • upgraded the system with "sudo pacman -Syu"

Everything works fine, but how can I replace the old Manjaro img flashed on eMMC with the new one I' m using on ssd?

Hello,

That's good to hear, this means there is no issues with the img nor with updated packages.

Why do you want to flash the whole os from emmc to ssd ?

Why don't you just copy your data from emmc to ssd and format the emmc?

If there is nothing much find on the os config side then its better to just copy the data file from your emmc to ssd, as you have tested everything on ssd.

Same issue on my machine.
I flash 20.02 to emmc and it work fine. Booted fine.
After using the version I started to install flatpak.
Now I get a orange LED and the PBP is hard to boot. Sometimes I get a green LED and if I am lucky it boots.
I am unable to boot from the SD card slot :frowning: It doesn't seem to be recognized.
Only when the system is running and I insert a sd card it shows up

Hi spikerguy,
further testing my system:
sometimes it boots and sometimes not.
As I said, the img from ssd works good...

That's good to hear, this means there is no issues with the img nor with updated packages.

yes, but the OS on eMMC doesn't seem to respond correctly. Once booted the system is stable, but the problem, as jwchter states, is that more often than not, we can't boot.

So, do you think is a software or hardware problem?

Should I try to reinstall everything on my eMMC?

hi jwchter,

In my case I can boot from sd card slot without any issues.

I'd like to point you to this post:

I'll try it if I can boot again...

UPDATE:
after several tries, I was able to boot from eMMC.
So I did what the tutorial said:

sudo pacman-mirrors -f3
sudo pacman -Syyu

the first command does nothing (an error is raised), but the second performed some upgrades on the OS.
After a reboot, now I'm able to start Manjaro from eMMC.
Please report if this solution works also for you...

Forum kindly sponsored by