Manjaro won't boot after switching kernel

It just goes to a black screen, I am able to get to the boot menue but after that it just goes black. Can anyone help?

You can try some of these.

i tried that but i get a bunch of errors after Sudo pacman -Syyu

Maybe those errors tell what’s wrong.

yeah maybe but i cant understand any if them

We may be able to tell you if you paste them here.

i will try ro take a picture/video. I cant paste because i am not able to boot in the first place…

i am now unabe to acess the terminal via control alt f2/f3

By any chance do you have Nvidia drivers installed? If so, are those needed extramodules also installed?

no idea what those are sorry, the system was working before i tried to switch kernals so im assuming i dont need them? not sure on that tho… how would i install them?

Which kernel worked and can you still boot with them? If so issue the following command in a terminal and post the output as text:

pacman -Q | grep linux

5.6 and up worked but somone suggested an lts kernal so i went with 5.4. i cant boot into any other kernals besides 5.4 bc i deleted them. also ctrl+alt+f2 doesnt bring up terminal anymore so i cant do that command

So to recap: Linux54 worked/works and also Linux56. With Linux57 or Linux58 you have issues. So can you boot in a graphical session with Linux54 or is that now broken too?

no linux 5.4 doesnt work, everything after 5.4 works. The issue is i cant boot into manjato to switchj to a kernal that works. It may not even be related to a kernal all i know is that after i removes all installed keranls except for 5.4 it went to a black screen and wouldnt start.

OK, so linux54 doesn’t work on your system at all. So you should have installed linux57 then. Most likely you should have still internet connection available. Boot the system up with Linux54 and try to login into a TTY:

CTRL+ALT+F3

In that terminal you may then install a kernel higher than 5.4:
https://wiki.manjaro.org/index.php?title=Manjaro_Kernels#Adding_New_Kernels

i removed all kernals in my woeful ignorence of thinking that removing all kernals except for one was the only way to boot into it

also when i boot into that terminal it flashes an _ a couple times and then it wont let me type.
^^
either that or nothing happens after ctrl alt
f3

Then you may need to boot into a live session on any Manjaro media, chroot into your installed system and try to fix the mess by installing a kernel working for you. We might need a tutorial on how to install kernels when system is broken:

  • get a 20.1-rc4 ISO
  • start the live session
  • chroot into your installation and try to fix the issue by installing a working kernel
  • report back any issues you may have

ok cool thankyou so much for your help

not sure if your still awake, but when i run these commands from the chroot thing you linked

mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys
mount -o bind /dev /mnt/dev
mount -t devpts pts /mnt/dev/pts/
chroot /mnt

they all return as “mount point does not exist”.
when i run chroot /mnt, it says /bin/sh no such file or directory. does this mean my disk was erased?

I tried doing this too and had to try it with multiple partitions before I got it right. Try doing it with your other partitions.