Manjaro won't boot after manual installation

I’m new to linux altogether and today is my first day to try manjaro. I’ve been getting boot device not found after manual partition installation. Its working fine with erase and install but I wanted to do a manual partition so that I can keep data on home.I’m doing UEFI installation with fat32 boot/efi with flags set to boot and swap, root and home.So I wanted to know where am I doing wrong as other distros are working like this.

EDIT: So I fixed the problem. The problem for me was there was no esp flag option for boot/efi. I had to manually do that through gpart and then install it. Now its booting normally

Do you also use GRUB? or is it refind or something else?

No I don’t see any grub or anything after installation. it just says no boot device

I meant in general - is that your boot manager? do you use one from another distro, or install it during manjaro install? or use another bootloader entirely? is this all klingon to you?

sorry I thought of something else.No I don’t. The only grub was installed when I tried ubuntu before. But now I erased it completely

You will need some kind of grub or similar boot manager, and you will need to select the ESP ofr use (not format!), as you seem to know how to do … but you must install/overwrite grub with manjaro grub … this will allow you to boot your OS’s … and manjaro uses a patched grub thats works with it - it can boot other distros, but generally other distros grub will not boot manjaro easily.

1 Like

can you tell me the process? or the keyword so that I can search for it?

It should look something like this (guide is a bit dated, but mostly correct)

1 Like

hey @cscs I got it solved. I edited my original post. thanks for the guide.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.