Manjaro won't boot after installation

After install to HDD (SSD)
version: Manjaro XFCE Edition (18.0-beta-2)
The system doesn’t boot.
(From the USB boot disk I can select the installed system to start, and starting properly.)

After booting up to installed Manjaro, do step 6 here.
If UEFI, do the 2 [UEFI - additional commands] further down the post #1.
If bios-legacy, at command sudo grub-install /dev/sda make sure sda is the primary disk or if not use /dev/sdb or whichever that applies to the primary disk.

2 Likes

This is the wrong category. I changed it.

after

sudo grub-install /dev/sda
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”

works fine the booting.

1 Like

I installed ver. Manjaro GNOME Edition (17.1.10) from USB, the situation the same.
The system doesn’t boot. (Grub doesn’t start) only cursor blinking.

After fresh install to HDD (SSD) version: Manjaro XFCE Edition (18.0-beta-2)
start from USB dive find installed system,
apply the

sudo grub-install /dev/sda
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi’

can’t start again as before I repaired my system. Perhaps I made other changes in the boot system, before I get your answer. Other supplemental idea?

I fond:
Asus - a small number of models need these F2 settings
… … . . Add a new custom bootentry
… … . . Set the path to that bootentry efi file
… … . . Create the bootentry and make it default.
This link 1 may help

perhaps I made (apply Linux commands) efi boot item before… (???)

From my link,
UEFI - if problem persists , provide

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi
note: ‘parted -l’ --> small ‘L’ and provide information of all disks.
And state computer make and model.

Also the Asus link (I assume you have Asus?), is clear and well written.
Which part are you not clear? Don’t forget step 2 (Boot > Add New Boot Option)
It is okay (and correct) you did my commands before doing the Asus steps.

sudo efibootmgr -c -d /dev/sda -p 1 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi’
line makes a new entry in the BOOT,
but if create manualy a new enty to
\EFI\Manjaro\grubx64.efi
it works.

???

Remove the old one,

Why is this problem arising in the 1st place? It is a regression.

I have mistakenly created another Topic, but this is a more relevant thread.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.