Manjaro won’t boot anymore after laptop dies while installing blender

I have xfce downloaded on a usb drive, and while installing blender from pamac, my laptop(Macbook pro mid 2014) died. After charging and rebooting, it just brings me to a blinking cursor after “clearing orphaned inodes”. I shut both devices down for a few hours and tried again, same problem. I can’t do anything or read any output because all there is is a blinking cursor.

Edit: I was able to log in through tty2, but I’m not sure where to go next. I’ll just continue updating this until I find a solution.
Edit 2: refreshing mirrors and updating did not work

If you are able to log in, try to update the system with

pamac update

Also you can look for errors in the logs:

journalctl -b -xe -nall
1 Like

Alright, it says: Process 1059 (Xorg) crashed and dumped core. There a lot of other info, so here a picture:

If you notice, there are more than 3000 lines in the log. You can move up and down with PageUp and PageDown keys (or Up and Down cursor keys).

If you want, you can share your log with this command (and then post the resulted link here):

journalctl -b | curl -F 'sprunge=<-'

All it gives me is cannot resolve host: . Do I need to be connected to internet? I don’t have Ethernet, just a wireless card.

Looks like your file system is still damaged. Although it tried to fix it. Which filesystem do you use on your flash drive?

With nmtui you can activate your wireless connection on the commandline.

I’m using fat32

WTF? If you installed Linux on fat32, then no wonder it will not work properly after crash… Also fat32 has no permission management… I wonder that this works xD

Can you post an image of this command?

sudo parted -l

Will I have to reinstall completely? If so, I’m supposed to format the disk as exfat, then in partitioning partition it to exfat, right?

It clearly says, that it is ext4, not fat32. fat32 is your efi partition…

No, exfat is the same as fat32… so never install linux on that filesystem, only if you boot an image of a linux iso.

If you need a fast filesystem for linux then use f2fs, but when it crash, there will be less you can do about corruption. BTRFS is the best option for flash drives (and SSDs etc.) i know nowdays. It has live auto correction and COW, but it is not that fast, since it is focused on stability (it has checksums and check on every write and read if the data is still the same). ext4 is clearly optimized for spinning disks although it works on any drive.

ok however… to correct it, you will need another live session and correct the partition on that drive, since that cannot be done on a mounted file system.

Alright, so what do I change it to?

What is exactly the propose to install Manjaro on flash drive instead on your real disk or a VM?

I would like to use it on multiple machines on multiple operating systems, just for coding and surfing the web.

Then I would really recommend to do this with alma: GitHub - philmmanjaro/alma: Create Arch Linux based bootable USB drives

There you can set presets it installs then in one go. You can also test it before with an image. You will be able to boot in UEFI and BIOS mode at the same time. But it works only on a native ArchLinux based Distro like Manjaro.

However… f2fs is the best option when it comes to fast reaction on flash drives. But keep in mind: save your data there regularly on another disk or online because it is not 100% save, since there is no journal.

Alright, give me a minute to try this out.
Edit: How do I use it? When I download, all it gives me is a folder.

Here are for example some more presets to try out or to use as examples:

pamac install alma-git

Then you can use the command alma.

Am I supposed to do this on manjaro or on my Mac?