Manjaro WebDad Community Edition


#81

WebDad edition is now available for installation with manjaro-architect from any manjaro iso :smiley:


#82

Awesome @Chrysostomus will add tray icon on next Iso, thanks :joy:


#83

When you update iso-profiles repo, the version installed by manjaro-architect is automatically updated too.


#84

Alpha 5 Available for download :smile:

Download Manjaro WebDad


#85

Just wondering how to change settings, other than the ones in Manjaro Settings Manager.
I’m thinking of things like wallpaper, theme, etc. The one I see now are not exactly to my liking. The wallpaper is an extremely digitally zoomed-in picture of a lava flow, making the screen pretty dark, the filemanager has a dark theme making buttons on top almost invisible.
Since I can’t use dark themes I like to make things light and bright. How to do that in WebDad?

Installed The Gimp but it doesn’t show up in the graphics menu, or anywhere else. Searching the program does not show it either. How to start it?


#86

when you install software you need to restart the dashboard, logout or change workspace and back to desktop again, this will be fixed in the e future, you can also close the dashboard in the bottom menu, and open again by right clicking on the dark background and chose launch desktop.

the buttons fade for inactive windows, but if you click in the window will will notice that they become more visible, you can change theme by installing lxapearance, but that will only change the theme for GTK applications and they will look different from QT.

to change Lava wallpaper at the moment there is not GUI settings to allow this.

create this file:
.config/jade/theme/override.css
insert your custom styles and restart dashboard.

#background:before {
background-image: url(“my-image.jpg”);
}

You can also adjust screen brightness in bottom menu.


#87

I have 3 questions:
Why chromium?
Why nautilus? I think caja is more suitable, but it’s just my opinion
How to deactivate that voice?


#88

Its faster, I can tweak chromium-flags, it provides api’s i can use for future integration with the desktop itself, google account and connected android devices , like sharing bookmarks directly in the desktop.

cleaner interface, tracker pre caches your files, more extensions, and i can make my own in python if needed, allows remote connections, integrates with recent files in the desktop, allowing you to delete them.
You can always remove nautilus and install caja, along with mate-desktop dependencys

press mute sound or remove webdad-speech package, at the moment there is no switch off bottom.


#89

I did think that voice feature would be annoying for some, with time it will get better, any chance i can get some feedback about that, what you dont like and why?


#90

I don’t like the robotic voice, it has some delay, but that’s a minor thing, and that it does speak for obvious thing like when I change desktop space, it doesn’t need to speak that, cause I did change the thing manually, I know what desktop space I clicked, the same when opening apps, I clicked in the app icon, I know that it is launching.

Of course these features may be useful for someone, but would be great if I could configure for what that voice speaks and what it doesn’t, like deactivate the app opening thing and the desktop space change and it still speak for everything else


#91

I finally tried out WebDAD in VB and I like the setup. It is a little bit different that what I used to but it looks very good. I will play around with for a few weeks. SO far so good


#92

If you using Jade with WebDad or standalone with another DE you can now install jade-desktop-mode to run it as a Desktop Environment instead of an application, avaliable on the unstable branch.:smile:


New Desktop JADE in the works!
#93

Trying this in a VM… it’s so… different haha

I find it a little hard to use, probably because I am not used to this format.


#94

I have been a bit busy to work on this project, Next version will be less complicated and will also come with a more viable Window Manager and maybe a new React front end, this is still all very conceptual and will take some time until it gets decent. :wink:


#95

Apparently downloads went crazy in the last 4 days.

46m in there is a review.:smile:


#96

Maybe I know why, I’m making some searches for my lists and I found Manjaro Webdad added to the distrowatch waiting list since 2018-04-23

With all respect I don’t think that any Manjaro edition should have a separated entry in distrowatch


#97

I don’t have any control over distrowatch, I think wanting list means they are wanting to see if is still under development. @Lolix


#98

It rather means its waiting to be reviewed or ‘recommended’ enough for addition to distrowatches index - you know to have a page and listing like this one: https://distrowatch.com/table.php?distribution=manjaro

(heh. I just looked at some recent reviews. It seems theres more than one person who thinks pacman is ‘limitied in functionality’ or ‘buggy’. My word. :face_with_hand_over_mouth: …so very well informed.)


#99

The waiting list gives a new project time to mature. Given that a large number of newly created distributions don’t survive beyond the first year of their existence, it gives the new project time to set up a proper infrastructure, including forums, mailing lists, documentation, bug tracking databases, etc.

It would be nice to have time to do all that.

My only complain about pacman is the syntax, I find it hard to memorise, would be better to do pacman install x.
.


#100

Speaking of pamac, I just installed all (5?) WebDad ‘parts’ and have seen nothing appear on my XFCE4 DE. I am running using the “Testing” branch of XFCE4 Manjaro (4.14.36 kernel). Because I’m downoading the full install od WebDad right now, I have not rebooted my system to see if it cleans up and I have a bunch of nice new options to test post-reboot. I hope to play with (run a stupid user test, I’ll be the stupid user) both WebDad on XFCE and WebDad standalone.

btw. WebDad looks like a wonderful teaching tool… I’m teaching a bunch of senior citizens about Open Source and what you can do with computing. ;^)

======
Post reboot discoveries:

  1. “Jade” appearss on the LightDM Login screen… activating the option and entering the pssword, goes nowhere. There seem to be some Jade functions missing, perhaps those weren’t installed via pamac as as WebDad dependency somewhere.

  2. Reselecting XFCE as my login choice (on LightDM)… worked per normal although no WebDad functions appear anywhere on my XFCE DE after login completion.