Manjaro WebDad Community Edition


#61

By the way the right command is

pkill jade-dashboard don’t use a /


#62

Apparently someone made a video with voice here:+1:


#63

Hi everyone

Alpha 2 is out, uploading as i text should be there in around 5h, issues mention above should be fixed.:wink:

https://sourceforge.net/projects/manjaro-webdad/files/


#64

The work you’ve done is amazing to create such a unique and functional desktop is quite an achievement. I’ll probably wait until a stable release to test myself but I shall be watching the development here.


#65

its a work in progress, this update brings (3,576 additions), everything is working as intended, there is some work missing in the theming side, no packages are done in Manjaro yet.

You can always try the Dash in any DE - pacman -S jade-dashboard, it has been around since Feb in the repos.


#66

Nice work indeed.
Some things are still …
I.e. I struggled a lot to make it dual language on keyboard and my patience limits were exceeded. :exploding_head:
All this on Live session, so maybe on installation could be better.
I even tried with localectl and almost worked but no.
If you make a short guide for that I will try it again and list you my findings need attention. :+1:


#67

Did you try manjaro settings keyboard to change the language?


#68

Yes, but as you know it cannot handle two simultaneous lang layouts. So when I changed to Greek it worked but then I lost English and… sudo password entry.:wink:


#69

Edit this file:
/etc/X11/xorg.conf.d/20-keyboard.conf

instructions here
https://wiki.manjaro.org/index.php/Keyboard_Layout


#70

I was thinking “How did you do it” when you tested the Live session.
In a way that doesn’t need reboot.


#71

You have to install on virtualbox or add the file to the ISO profile, and build an ISO yourself, using Manjaro tools


#72

Someone made an Alpha2 video


#73

Thanks for all that hard work … I am testing it in some hours…will let you know my impressions soon. :wink:


#74

Using it on my laptop and loving it, no major issues, removed lightdm to fix the theme issue and installed sddm. Would there be a repository of webdad just like they have for Kibojoe Linux ? That would help installing jade on arch linux as well because currently only manjaro repos have jade packages.


#75

What theme issue? that should be resolved on alpha2 as i removed webkit2 greeter in favour of slick greeter.

WebDad will always be part of Manjaro unofficially, I have no plans to rebrand it or make separate repos.

You could use makepkg to build PKBUILD’S on arch, or add Manjaro repo to arch.

I am glad you like WebDad, but you wont get any updates as I mention above, packages are not yet done in Manjaro upstream, Planing on doing that next year, along with beta1.


#76

Alpha 3 is out.
Have deleted old images to avoid downloading the wrong one.

https://sourceforge.net/projects/manjaro-webdad/files/manjaro-webdad-17.1-alpha3-stable-x86_64.iso/download


#77

alpha4 was skipped.

Upcoming alpha5, brings native notifications to speech functionality, using mimic that sounds very natural as compared with the old text to speech engines that sound very robotic.

That means that any desktop notification or browser notification will be read out loud by JADE to you.

If you connect your phone to the desktop using KDE CONNECT you can also get any of your phone messages to be read by the computer voice to you automatically, so you wont have to stop what you are doing just to read a notification, text notifications still spawn in the corner.

I also redesigned the trays. Now all the trays are hidden so we can take advantage of all the screen space for the applications.

Alpha5 forward can now be installed as it is fully upgradable and all the packages are in the repository’s.

Will make another announcement when iso is ready.

Bottom tray for application switching.

Left tray for shorcuts

Right tray for workspaces

Toptray for system Tray


#78

This is good news hahaha thanks :slight_smile:


#79

Hello,

I installed weddad alpha 3 on my machine and it installed and runs flawlessly except when I try to update the files.

Error message :

Error failed to prepare transaction (Could not satisfy dependencies)
Installing Python2-Nautilus (1.2.1-2) breaks dependency python-nautilus

Other than that it is fantastic. Looking forward to testing Alpha5


#80

That is general Manjaro update quirks, I think back then i just removed python2-nautilus not shure, but you usually find upgrade fixes in the forum when things wont go smooth.