Manjaro v17.1-rc4 feedback thread

Can’t download sha1sum text file for KDE from: (iso and other sha files are downloadeable.

https://manjaro.org/manjaro-preview-releases/

I just downloaded it recently.
Why not try another mirror.

Direct link : https://downloads.sourceforge.net/project/manjarotest/kde/17.1-rc4/manjaro-kde-17.1-rc4-testing-x86_64.iso.sha1?r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Fmanjarotest%2Ffiles%2Fkde%2F17.1-rc4%2F&ts=1514659905&use_mirror=razaoinfo

Thanks.
No big deal for me, I will probably download again tomorrow the final version. I was just informing :slight_smile:

Thank you for implementing xdelta3 patches to save testsers from long downloads!

It would be great if someone with similar hardware as mine tested Gnome with Wayland. @balo?

@philm:

I see, this is kind of fixed now. :slight_smile:

This, however, not and it seems to be this issue: Yakuake auto rolling down on startup Looks like a misconfiguration but since it appears on a freshly installed system, I think, it is a bug somewhere in the profile files?

The desktop settings bug is totally strange, indeed.
I just watched Bézier’s video on this… Apart from him totally freaking out :japanese_goblin: I gather that not only is this depending on language settings but also it has to do with gtk-theming. So with some themes desktop settings is working in French, while with others it isn’t? … Aweome! :stuck_out_tongue_winking_eye:
I don’t really have the slightest idea what the problem here can be.
Anyone?

I have no idea what could be the source of this problem. It just looks like you have some extremely specific conditions (XFCE, French language, Vertex-Maia theme, Vertex-Maia icon theme, Vertex-Maia window border, a very specific number of wallpapers with exactly their specific name in /usr/share/backgrounds) which together, create a monstruous glitch in Desktop settings.

I first reported it a month ago in my thread about RC1 (there was no official thread about RC1) : https://forum.manjaro.org/t/commentaries-about-manjaro-17-1-xfce-rc/36632

I first thought it was fixed in RC2, but I discovered that it was just not affecting Manjaro XFCE if it was installed in English. I only got this strange bug when I installed Manjaro XFCE in French and I don’t know if there are other languages that have this bug.
https://forum.manjaro.org/t/manjaro-v17-1-rc2-feedback-thread/36937/43

I didn’t bother with RC3 at all since it couldn’t be installed at all with “Erase disk”.

And for RC4, I reported it back with more information about possible workarounds to fix the issue manually, as you can see above.

Workaround found so far are :

  • You can remove any wallpaper from /usr/share/backgrounds/;
  • You can add a wallpaper in /usr/share/backgrounds/;
  • Even renaming a single file in /usr/share/backgrounds/ can fix the issue too;
  • As Bezies showed in his last video, there’s some GTK-themes that are not affected by this too.

And concerning Bezies’ case, well, he kind of has a good point. Such a bug can really have a big negative impact on Manjaro’s credibility as a Linux operating system project. I mean, I just hope Manjaro will be known as “a viable rolling release operating system for everyday use” and not “the joke distro that doesn’t even let you change the wallpaper.”

Well, we’ll be happy to fix whatever needs to be fixed, just seems the root of the issue is difficult to spot… really odd… :stuck_out_tongue_winking_eye:
I don’t see why it’s a reason to go mad at the Manjaro team, but then, it’s not you but Bézier. I can’t blame you for someone else’s manners. Only thing we can do is keep looking for the cause of the problem.
My guess is that it could be some tiny bug burried in xfce code - maybe connected to a translation file or whatever - it might just disappear with an upcoming xfce update.

the problem is with this file, removing this file +logoff/logon will fix the issue and the file will be regenerated at next login.

rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml

the bug was there in 7.0.x and 7.1.x . I tested in a VM, fix works fine!

Cool, thank you! Will check that.

1 Like

Hm. I don’t really see where the problem with our default file is.
Here is the original:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-desktop" version="1.0">
  <property name="backdrop" type="empty">
    <property name="screen0" type="empty">
      <property name="monitor0" type="empty">
        <property name="image-path" type="string" value="/usr/share/backgrounds/breath.png"/>
        <property name="last-image" type="string" value="/usr/share/backgrounds/breath.png"/>
        <property name="last-single-image" type="string" value="/usr/share/backgrounds/breath.png"/>
        <property name="image-style" type="int" value="5"/>
      </property>
    </property>
  </property>
  <property name="desktop-icons" type="empty">
    <property name="style" type="int" value="2"/>
    <property name="file-icons" type="empty">
      <property name="show-removable" type="bool" value="false"/>
    </property>
    <property name="icon-size" type="uint" value="32"/>
  </property>
</channel>

and this is the auto-created one on my running system:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-desktop" version="1.0">
  <property name="backdrop" type="empty">
    <property name="screen0" type="empty">
      <property name="monitor0" type="empty">
        <property name="image-path" type="string" value="/usr/share/backgrounds/breath.png"/>
        <property name="last-image" type="string" value="/usr/share/backgrounds/breath.png"/>
        <property name="last-single-image" type="string" value="/usr/share/backgrounds/msx_wallpaper.png"/>
        <property name="image-style" type="int" value="5"/>
      </property>
      <property name="monitoreDP-1" type="empty">
        <property name="workspace0" type="empty">
          <property name="color-style" type="int" value="0"/>
          <property name="image-style" type="int" value="5"/>
          <property name="last-image" type="string" value="/usr/share/backgrounds/breath.png"/>
        </property>
        <property name="workspace1" type="empty">
          <property name="color-style" type="int" value="0"/>
          <property name="image-style" type="int" value="5"/>
          <property name="last-image" type="string" value="/usr/share/backgrounds/breath.png"/>
        </property>
      </property>
    </property>
  </property>
  <property name="desktop-icons" type="empty">
    <property name="style" type="int" value="2"/>
    <property name="file-icons" type="empty">
      <property name="show-removable" type="bool" value="false"/>
    </property>
    <property name="icon-size" type="uint" value="32"/>
  </property>
  <property name="last" type="empty">
    <property name="window-width" type="int" value="616"/>
    <property name="window-height" type="int" value="537"/>
  </property>
</channel>

Could maybe one of you guys who had the initial issue post the auto-created file from your system?
Or we will just have to try to reproduce the faulty behaviour again in a virtual machine with language set to French …
@philm

I’m still investigating but it doesn’t seem that the file itself is wrong. When the file is missing, there is something running that fix the issue.

I deployed a new VM (fr_FR/Paris settings) … by default, it has the bug. I remove the file, logoff/logon, the file that gets generated is the same as the old one (I kept a copy) but it generates new files, ie : display.xml and more…

I don’t know what’s get refreshed when the file is missing, but the problem is there.

Cheers

PS: I’m still trying to investigate

Interesting detail is: When we remove xfce4-desktop.xml and relog, how does xfce remember and know which wallpaper we have been using? :thinking:

UPDATE1: If I boot and login with fr_FR.utf (language setting in the login screen). It will cause the bug. If I logoff and switch to en_US.utf8 it will work. I then logoff an login with fr_FR.utf, the bug is coming back.

So it’s related to the locale setting…

UPDATE2: when I have the problem, in a terminal, if I export LANG=“en_US.UTF8” and launch the xfdisplay-settings it’s OK.

UPDATE3: I no longer confirm the bug is related to the xml file. I’m not able to reproduce the fix by deleting the file. The only way to make it work it to change the locale to en_US.

Yes I also just tried this. Deleting the file doesn’t help. Also, the wallpaper is NOT remembered in the live environment. It drops back to xfce default and when switching directory in the background selection the application crashes.

For some totally obscure reason removing breath wallpaper stops the problem… :thinking:
I’ve tried replacing breath.png with a new breath.jpg since it was the only png, but that didn’t help either - seems somehow xfce in French can’t deal with ‘breath’ as a file name? How does that make sense?? :smiley:

Uhm. No. Renaming the file also will not help… The file itself somehow in a mysterious way is causing the problem.

In any case for now… removing /usr/share/backgrounds/breath.png seems to solve the problem … … :laughing: :+1:

I’ve updated manjaro-xfce-settings to no longer depends on breath-wallpaper, so you can now at least un-install the package.
Temporary solution for the French population … :wink:

1 Like

I am going to say yes before even installing it, the thrend in dark themes does not suit everyone. :wink: