Manjaro v17.1-rc4 feedback thread


#21

I disabled MSM checks now in live-session for all main editions.

@eugen-b: you may check todays unstable-build if you like in regard of your issues you have with wayland on Gnome with given xdelta-patch: download here. You may check with sha1-files at least.


#22

Ok, I have now tried it with prexisting LVM VG. Installation itself seemed fine (modulo a couple of bugs that I’ll report directly to Calamares). However, the system did not boot (unlike with my test on KDE Neon). I was dropped to initramfs. initramfs contained no lvm executable, so I guess that’s why system did not boot.


#23

@stikonas: thx for the feedback. I don’t know what KDE Neon uses exactly. I expect the master-branch of CAL. On my end it is still 3.1.x-stable with kpmcore-3.2 branch for partition module. Also I didn’t found any ISO by Neon with CAL on it. Is it the unstable dev build?


#24

I think it’s just a matter of different initramfs system/generator. Probably theirs autodetects LVM setup without extra configuration.

By the way, on Neon I tried my own calamares build compiled from kpmcore-3.2 branch. But I don’t think that’s too relevent for success or fail.


#25

Well, for Arch and Manjaro we need the lvm2 hook. How to configure is described here. We only have to find a smart way to detect and configure it. @stikonas: what is the lvm partitioning? Can we use some similar like if partition["mountPoint"] == "/" and "luksMapperName" in partition:? Maybe give me an example printout of partitions value.


#26

Yeah, maybe Calamares needs to expose it better. Right now you can see something like

23:10:24 [1]: “/dev/sda1” mtpoint: “” fs: QVariant(QString, “lvm2 pv”) ( QVariant(QString, “lvm2 pv”) ) “UcPdtS-fi4K-CqbF-tpFa-NEit-E26O-kwiEXA”

23:10:24 [1]: “/dev/test/rootfs” mtpoint: “/” fs: QVariant(QString, “ext4”) ( QVariant(QString, “ext4”) ) “90462949-8f8f-4d32-8049-f2350bc31e9a”


#27

OK, then we can work with if partition["fs"] == "lvm2 pv": to add the needed hook … @stikonas: Can you check this commit and that commit on top?


#28

@Ste74: we should consider to use Xorg as default session for Gnome again. Seems with Wayland we still have some issues. How to accomplish that, setting Xorg as default?


#29

Ok let me revert the custom.conf file to revert xorg as default settings. I only leave the manjaro-gdm-check service to override choice User when User want use nvidia closed driver and Wayland ( it automatically revert on xorg)


#30

Already did it and fixed your script. It was currently doing nothing.


#31

Thank you mate…


#32

I’ve added another xdelta-patch for todays Gnome build. You can get it from here. Apply it with:

xdelta3 -d -s manjaro-gnome-17.1-rc4-stable-x86_64.iso manjaro-gnome-17.1-rc4-to-20171230-x86_64.delta manjaro-gnome-17.1-rc4-testing-x86_64.iso

Following issues are fixed now:

  • Calamares not starting at all or later (fixed with using Xorg)
  • Kernel not supported (fixed by disabling update-notifier in live-session)

Open topics:

@stikonas: should I add the two commits to CAL so lvm2 is usable? Can you write me on how you test lvm2 on your end?


#33

Yeah, hopefully this will work. I can’t test those commits myself now (need to travel) but I wrote how to test LVM here:


#34

Thx @stikonas, will test it. Have a nice trip and all the best for 2018 …


#35

I added xdelta patches now also for KDE and XFCE. You can get them from here (kde, xfce). Apply them with:

xdelta3 -d -s manjaro-kde-17.1-rc4-stable-x86_64.iso manjaro-kde-17.1-rc4-to-20171230-x86_64.delta manjaro-kde-17.1-rc4-testing-x86_64.iso

xdelta3 -d -s manjaro-xfce-17.1-rc4-stable-x86_64.iso manjaro-xfce-17.1-rc4-to-20171230-x86_64.delta manjaro-xfce-17.1-rc4-testing-x86_64.iso

#36

So after testing the last lvm feature, which is not yet finished, I assume we are now mostly ready. Please do another final review and if found some, please stop me by releasing v17.1-final tomorrow :stuck_out_tongue:


#37

I just did a clean rc4 install of the KDE edition and can report that the AUR access in Octopi is broken for me. I looked into the settings and it turned out that pacaur was selected as frontend and at the same time grayed out. After I switched to yaourt, AUR access worked fine.

Edit: One more minor thing: Yakuake is active and shows the terminal automatically after every login without me calling it with the corresponding shortcut. I think, it should stay in the background and only pop in when called.


#38

Can’t download sha1sum text file for KDE from: (iso and other sha files are downloadeable.

https://manjaro.org/manjaro-preview-releases/


#39

I just downloaded it recently.
Why not try another mirror.

Direct link : https://downloads.sourceforge.net/project/manjarotest/kde/17.1-rc4/manjaro-kde-17.1-rc4-testing-x86_64.iso.sha1?r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Fmanjarotest%2Ffiles%2Fkde%2F17.1-rc4%2F&ts=1514659905&use_mirror=razaoinfo


#40

Thanks.
No big deal for me, I will probably download again tomorrow the final version. I was just informing :slight_smile: