Manjaro v17.1-rc2 feedback thread


#1

Hi community,

it took us a while to fix all issues we had found in our v17.1 development cycle. We hope now that rc2 is now stable enough so the final install medias can be released soon.

Please test them and give us your feedback. Hope only some few small issues are still there …



#2

Oops, I didn’t see this thread. Sorry!

As I said on this thread about the RC1 (which can be closed since I’ll say everything I said in this thread here too)), the login screen still looks off in the RC2. Fortunately, the Desktop settings isn’t broken anymore.

I only tested the RC2, like the RC1, in a virtual machine and not for a very long time. I haven’t noticed anything else yet.

However, is it planned to include the manjaro-printer package in XFCE? Or is there a technical reason why it isn’t included by default?


[Stable Update] 2017-12-23 - Kernels, KDE-Apps, Cinnamon, Deepin, Xorg, LibreOffice
#3

I installed Xfce edition (btrfs, the usual setup).
I get issues with video-ati driver on the installed system, the DM doesn’t load, just a “starting TLP” message on TTY7.

[eugen@mjro ~]$ inxi -Fxxxz
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: mjro Kernel: 4.14.8-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
           Desktop: N/A info: xfce4-panel dm: lightdm Distro: Manjaro Linux
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: AM1I-A v: Rev X.0x serial: N/A
           UEFI: American Megatrends v: 0801 date: 03/10/2016
CPU:       Quad core AMD Athlon 5370 APU with Radeon R3 (-MCP-) 
           arch: Jaguar rev.1 cache: 2048 KB
           
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 17605
           clock speeds: min/max: 800/2200 MHz 1: 800 MHz 2: 800 MHz
           3: 800 MHz 4: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8400 / R3 Series]
           bus-ID: 00:01.0 chip-ID: 1002:9830
           Display Server: N/A driver: modesetting tty size: 80x24
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1022:780d
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1 chip-ID: 1002:9840
           Sound: Advanced Linux Sound Architecture v: k4.14.8-1-MANJARO
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: e000
           bus-ID: 02:00.0 chip-ID: 10ec:8168
           IF: enp2s0 state: down mac: <filter>
           Card-2: Ralink RT5572 Wireless Adapter
           driver: rt2800usb v: 2.3.0 usb-ID: 001-002 chip-ID: 148f:5572
           IF: wlp0s18f2u2 state: N/A mac: N/A
Drives:    HDD Total Size: 756.2GB (8.6% used)
           ID-1: /dev/sdb model: ST500LM012_HN size: 500.1GB serial: <filter>
           ID-2: /dev/sda model: KINGSTON_RBU size: 128.0GB serial: <filter>
           ID-3: /dev/sdc model: SAMSUNG_MZHPU128 size: 128.0GB
           serial: <filter>
Partition: ID-1: / size: 77G used: 53G (72%) fs: btrfs dev: /dev/sdb1
           ID-2: /home size: 77G used: 53G (72%) fs: btrfs dev: /dev/sdb1
           ID-3: swap-1 size: 9.11GB used: 0.00GB (0%)
           fs: swap dev: /dev/sdb2
Sensors:   System Temperatures: cpu: 25.6C mobo: N/A gpu: 27.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 180 Uptime: 25 min Memory: 1265.6/7416.5MB
           Init: systemd v: 236 Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121 running in xfce4-terminal) inxi: 2.3.53 

Xorg.0.log shows the following errors:

[   138.231] (II) RADEON(0): [DRI2]   DRI driver: radeonsi
[   138.231] (II) RADEON(0): [DRI2]   VDPAU driver: radeonsi
[   138.231] (EE) RADEON(0): failed to initialise surface manager
[   138.231] (EE) RADEON(0): radeon_setup_kernel_mem failed
[   138.231] (EE) 
Fatal server error:
[   138.231] (EE) AddScreen/ScreenInit failed for driver 0

https://hastebin.com/ofugehokod.hs
In TTY2 I ran
sudo mhwd -r pci video-ati
and rebooted. I got the DM and am able to run with modesetting driver. Here is alink to the respective Xorg log:
https://hastebin.com/gejejimafu.hs
I suspect with the new Xorg I cannot run the video-ati driver. I didn’t notice it in my daily usage, because I installed video-amdgpu on all my installed systems.

Another issue is that the highlighted tab in firefox doesn’t have black text colour as it should.

I also plead to replace the theme Vertex-Maia with Adapta-Breath.


#4

Issue confirmed on XFCE RC2: Firefox 57 doesn’t look good at all.

Suggested fix : Delete the ~/.mozilla/firefox/blabla.default/chrome symlink and remove the ff-theme-utils package. After that, it looks way better.


Manjaro v17.1-rc4 feedback thread
#5

@Ste74: seems we have to remove the theming for the new firefox completely. Can you take a look at it.


#6

Downloaded RC2 Gnome but could not get the installer to launch. I’m downloading KDE now see if it works there.

Seems to be some issue with the installer.


#7

I’m trying to install the KDE edition. I get an issue in Calamares with ESP, it doesn’t set the flags esp and boot, no matter what I choose “Format” or “Keep” Yesterday I installed Xfce and chose “Format”.


After Next I get this error message
Screenshot_20171225_170210
To resolve this I had to manually set flags with KDE Partition Manager and restart Calamares.


#8

Hi @eugen-b. Does this also happen with an older version of CAL? Which exact version of CAL was used? Please fill out an bug-report with details, so we can check if the used kpmcore-3.2 branch is broken in some kind.


#9

16:54:12 [1]: Calamares version: 3.1.11-1
Here is the complete output of calamares when it gave me the error: https://hastebin.com/movowaxaso.vbs
I will try to confirm the issue - that calamares cannot set flags to partitions - and then file a bug report.


#10

Sorry for interrupting, but eugen-b, did the installation proceeds and can you boot up?
In /etc/fstab is /boot/efi correctly mounted?

ps: if bootloader is not installed, can you boot up the new installed OS by going to grub prompt in other OS grub by…

grub> set root=(hd0,x)
grub> chainloader /boot/grub/x86_64-efi/core.efi
grub> boot

where (hd0,x) is newly installed manjaro OS root (not $esp)

############################################
ps:if separate boot partition, use (hd0,x) as boot partition and…

grub> set root=(hd0,x)
grub> chainloader /grub/x86_64-efi/core.efi
grub> boot

#############################################


#11

@eugen-b: Can you test if v3.1.11-2 fixes the issue? Also can you check if an earlier version of CAL had not the regression.


#12

Ok, the installed KDE edition 17.1-rc2 boots. I found why the Xfce didn’t boot (see above: It was because I used a custom Grub code with kernel parameters which are meant to boot video-amdgpu. After removing these kernel parameters the installed system boots OK with video-ati. Sorry for false alarm!

I will now try different Calamares versions to find out if they can modify partition flags.


#13

That would be great. You can check the history of the PKGBUILD to compile them as needed. Let me know if one of the given versions broke it somehow.


#14

Well, I’m able to recreate the issue with
13:18:29 [1]: Calamares version: 3.1.11-1

  • In Manual partitioning I deleted the EFI partition and created a new one, I set the boot and esp flags.
    • After pressing Next I got the error message with “esp flag not set”.

I’ll continue with trying different versions of Calamares…

[Update_1]: Same issue with calamares 3.1.11-2, see the terminal output https://hastebin.com/apocumetun.vbs

  • I removed the flags with KDE Partition Manager, then launched calamares. I wasn’t able to set boot and esp flags - got the error with “esp flag not set”.

#15

downloaded and installed KDE version with no Problems, Tried the Gnome Version twice (different downloads.) But the installer would not launch on either download.
KDE one works fine no issues thus far. :slight_smile:


#16

@eugen-b: can you test CAL v3.1.10-2. You might need to compile it from source. I already started a conversation about it with Andrius, however a proper bug report against the new kpmcore-3.2 branch of the partition module might help.


#17

@eugen-b: the issue might be with Use KPMcore SetPartFlags operation. What happens if you revert that in one of the latest CAL packages?


#18

Sorry for dumb question, but how do I compile it? I’m failing with the few dirty hacks known to me.


#19

Well, let me compile it for you. @eugen-b can you try following build and report back. I’d reverted following commits:

	patch -Rp1 -i "${srcdir}/revert-7ce52ec.patch"
	patch -Rp1 -i "${srcdir}/revert-55ed2ba.patch"
	patch -Rp1 -i "${srcdir}/revert-5c4286e.patch"
	patch -Rp1 -i "${srcdir}/revert-38688ba.patch"
	patch -Rp1 -i "${srcdir}/revert-139f5a9.patch"

#20

No, still the same problem. The ESP is unflagged, I set flags, but the Next button is followed by the error message “esp flag is not set”.