Manjaro v17.0.3 released

stable
gellivara
release-announcement

#13

@fhdk ?


#14

Updating to a version from an existing installation (as you normally should) is somewhat different from freshly installing the same version, which this thread is about, in the sense that the main difference between this and previous releases, apart from containing the latest packages, is the installer, which you can only see how well it works if you download the iso and make a fresh install.


#15

Thanks for the i3 v17.0.3 release candidate iso. For some reason my AMD “Kaveri CPU/GPU” A8-xxxx system, with the free video drivers, now properly wakes up from suspend with kernel 4.13rc, which was not true a couple of weeks ago.

Also the Firefox browser now, without adjustments, plays American “Netflix” website streaming videos. A few months ago only the browser google-chrome-stable could play Netflix.

All in all a great release, including a unified/simplified pamac-manager that now also includes pamac-updater within its menu topics.

Found a Dell latitude laptop with NVS 3100 graphics that would not run calamares installer from the USB stick, having chosen the free driver. But Calamares did indeed run after trying again with a choice of the non-free driver. And then after the install, and booting the Dell, and letting all the updating run, the Dell let me switch over to the free driver using the manjaro-settings-manager, nice.


#16

Thank for bringing it to my attention :slight_smile:

v4.2.2 is in unstable - fixing the issue.


#17

If your only argument to pacman-mirrors was the -g/--generate then I don’t understand why you had this error, unless you have manually edited pacman-mirrors.conf and misspelled a country or even entered a country with not mirrors.

However if you had a -c/--country on your CLI and misspelled a country or you entered a country with no mirrors then the error would occur.

The error is a regression - and a fix has been released to unstable branch.

Have a look at this wiki on how to access unstable repo install a package an revert to unstable.


#18

I didn’t change anything. After the update of pacman-mirrors package that appeared in my octopi notification I tried generating mirrorlist again. Strange, it seems that my pacman used mirrors from Brasil

sudo pacman-mirrors -g
Downloading mirrors from repo.manjaro.org
Warning ‘-c/–country’ : Unknown country: ‘Brasil’

So I tried

pacman-mirrors -c all

and it successfully (re)created a list with all avaliable mirrors. After that pacman-mirrors -g worked like a charm. <3


Pacman-mirrors minor updates explained
#19

My thought here is:

At some point you have used -i/--interactive which presents the opportunity to do a selective collection of mirrors.

However - it also changes your pacman-mirrors configuration to use a custom mirror file. Every now and then, mirrors falls of the grid and new ones emerge, resulting in mirrors from Brasil has been removed from the official mirrorlist.

Since pacman-mirrors does not change your custom setup and does not regenerate your mirrorlist not even on updates - then you have caught this bug.

Your approach of resetting the mirrorlist using -c all is the best approach.

Thanks for reporting it :slight_smile: - it gave me the chance of fixing it.

Have a great day.


#20

Understand - the purpose of a rolling release is so you do not have to re-install. I did miss out on the install improvements but that’s about it.


#21

Radio buttons working again in Vertex Maia Dark! Aw yiss.


#22

Call me stupid but I upgraded my OpenRC installation and I don’r see any problems at all. So, when is my system going to break? I do backups before each update so I won’t be hit when it happens.
Ok, I know everyone will say I should be migrating to Artix, but I am not confident nor comfortable with the project yet.


#23

I installed the latest Manjaro Deepin release candidate.
No surprises and functions perfectly.
Congratulations ~ Team Manjaro has pulled another rabbit out of the hat

Life is Good on Manjaro


#24

eli_s: In the Kernel section of MSM, only the installed kernel (4.9) is listed.
Checking for the cause, I’ve noticed that the repositories are not synced by default and therefore I must issue a “pacman -Syu” command.


Or, you can just reboot and run pamac-manager again and all works as intended.

To say this another way, the only time have seen this problem is when running pamac-manager immediately after first boot of a new system. After the next boot the libraries seem to synchronize-up fine.


#25

I always download and burn to disk each new release. I keep it close to hand. Every now and then I get people who want me to turn a bunch of junk into a working computer for them, and they ask if I can put a pirate copy of Windows on it.
I reply, - “No, but you will not believe what I have in store for you!” Thus another Manjaro user is born.

Thanks developers for all of your hard work!


#26

Thanks for the input.
I hope new Manjaro users which are less technologically inclined will get the idea…:slight_smile:


#27

Perhaps the need for the second boot before pamac-updater runs properly, is because of WiFi. My guess is that the (pamac) updater would work immediately after first boot, IF the computer is plugged directly into the internet via Ethernet cable. Because any pamac/updater code will see the internet immediately, even if it is a behind-the-scenes updater daemon or module running during bootup.

But if the internet connection is by WiFi, well, after the first bootup, some updater code is running but you have not set the WiFi password yet. So the updater business thinks it can’t reach the worldwide software database. So after the first boot, set up the WiFi, and just reboot. From then on your Linux computer will “see” the internet much earlier in the booting process, and by the time the boot process settles down the pamac-updater will run OK.

So overall we can just observer that if you are using WiFi, don’t expect pamac-updater to work right until you have set up the WiFi and then done one more reboot.


#28

Hmm… Using Manjaro on the PC via ethernet.
I’ve noticed this problem only with the latest version of Manjaro ISO’s.


#29

Has it ever taken more than 2 boot-ups to fix the pacman-updater problem?


#30

What is? Thanks. Testing Branch.


#31

See here: [Stable Update] 2017-09-08 - Mesa, Kernels, PulseAudio, LibreOffice, KDE Apps, Cinnamon
@philm has informed that the release is now 17.0.4. It has reached also the Stable Branch,


#32

Haven’t tried restarting, only using “pacman -Syu” to refresh the DB.

In any case, I’ve noticed that Guillaume committed an addition into Pamac’s master branch:

Hope it’s relevant to our conundrum.
Will test when a new ISO is created with the updated program.

Thanks for the assistance.